]> git.pld-linux.org Git - packages/klibc.git/blobdiff - klibc-klcc.patch
- tabs in preamble
[packages/klibc.git] / klibc-klcc.patch
index 00acc75f69f0f8a707b5c702453b3a2e79d8f452..faf54dd3bffb664a10909c4f4d617838e15937d7 100644 (file)
@@ -1,7 +1,26 @@
---- klibc-1.0/klcc.in.orig     2005-03-07 22:44:49.000000000 +0100
-+++ klibc-1.0/klcc.in  2005-06-13 21:05:09.000000000 +0200
-@@ -1,9 +1,9 @@
- # -*- perl -*-
+diff -urN klibc-1.1.16.org/klcc/Kbuild klibc-1.1.16/klcc/Kbuild
+--- klibc-1.1.16.org/klcc/Kbuild       2006-01-06 07:11:43.000000000 +0100
++++ klibc-1.1.16/klcc/Kbuild   2006-01-06 19:31:36.327836000 +0100
+@@ -22,10 +22,10 @@
+       $(Q)echo 'EMAIN=$(KLIBCEMAIN)' >> $@
+       $(Q)echo 'BITSIZE=$(KLIBCBITSIZE)' >> $@
+       $(Q)echo 'VERSION=$(shell cat $(srctree)/usr/klibc/version)' >> $@
+-      $(Q)echo 'prefix=$(INSTALLDIR)' >> $@
+-      $(Q)echo 'bindir=$(INSTALLDIR)/$(KCROSS)bin' >> $@
+-      $(Q)echo 'libdir=$(INSTALLDIR)/$(KCROSS)lib' >> $@
+-      $(Q)echo 'includedir=$(INSTALLDIR)/$(KCROSS)include' >> $@
++      $(Q)echo 'prefix=$(rpm_prefix)' >> $@
++      $(Q)echo 'bindir=$(rpm_bindir)' >> $@
++      $(Q)echo 'libdir=$(rpm_libdir)' >> $@
++      $(Q)echo 'includedir=$(rpm_includedir)' >> $@
+ # Generate klcc
+diff -urN klibc-1.1.16.org/klcc/klcc.in klibc-1.1.16/klcc/klcc.in
+--- klibc-1.1.16.org/klcc/klcc.in      2006-01-06 07:11:43.000000000 +0100
++++ klibc-1.1.16/klcc/klcc.in  2006-01-06 19:22:31.481785250 +0100
+@@ -3,22 +3,22 @@
+ use IPC::Open3;
  
  # Standard includes
 -@includes = ("-I${prefix}/${KCROSS}include/arch/${ARCH}",
  
  # Default optimization options (for compiles without -g)
  @optopt =  @OPTFLAGS;
-@@ -13,10 +13,10 @@
- @stdlibpath = ("-L${prefix}/${KCROSS}lib");
+ @goptopt = ('-O');
+ # Standard library directories
+-@stdlibpath = ("-L${prefix}/${KCROSS}lib");
++@stdlibpath = ("-L${libdir}");
  
  # Options and libraries to pass to ld; shared versus static
 -@staticopt = ("${prefix}/${KCROSS}lib/crt0.o");
 -@staticlib = ("${prefix}/${KCROSS}lib/libc.a");
 -@sharedopt = (@EMAIN, "${prefix}/${KCROSS}lib/interp.o");
 -@sharedlib = ('-R', "${prefix}/${KCROSS}lib/libc.so");
-+@staticopt = ("${libdir}/crt0.o");
-+@staticlib = ("${libdir}/libc.a");
-+@sharedopt = (@EMAIN, "${libdir}/interp.o");
-+@sharedlib = ('-R', "${libdir}/libc.so");
++@staticopt = ("${libdir}/klibc/crt0.o");
++@staticlib = ("${libdir}/klibc/libc.a");
++@sharedopt = (@EMAIN, "${libdir}/klibc/interp.o");
++@sharedlib = ('-R', "${libdir}/klibc/libc.so");
  
  # Returns the language (-x option string) for a specific extension.
  sub filename2lang($) {
---- klibc-1.0/Makefile.orig    2005-03-07 19:17:15.000000000 +0100
-+++ klibc-1.0/Makefile 2005-06-13 20:57:41.000000000 +0200
-@@ -27,10 +27,10 @@
-       echo 'STRIPFLAGS=$(STRIPFLAGS)' >> $@
-       echo 'EMAIN=$(EMAIN)' >> $@
-       echo 'BITSIZE=$(BITSIZE)' >> $@
--      echo 'prefix=$(INSTALLDIR)' >> $@
--      echo 'bindir=$(INSTALLDIR)/$(KCROSS)bin' >> $@
--      echo 'libdir=$(INSTALLDIR)/$(KCROSS)lib' >> $@
--      echo 'includedir=$(INSTALLDIR)/$(KCROSS)include' >> $@
-+      echo 'prefix=$(prefix)' >> $@
-+      echo 'bindir=$(bindir)' >> $@
-+      echo 'libdir=$(libdir)' >> $@
-+      echo 'includedir=$(includedir)' >> $@
- $(CROSS)klcc: klcc.in $(CROSS)klibc.config makeklcc.pl
-       $(PERL) makeklcc.pl klcc.in $(CROSS)klibc.config \
+@@ -113,7 +113,7 @@
+ $save_temps = 0;              # The -save-temps option
+ $verbose = 0;                 # The -v option
+-$shared = 0;                  # Are we compiling shared?
++$shared = 1;                  # Are we compiling shared?
+ $debugging = 0;                       # -g or -p option present?
+ $strip = 0;                   # -s option present?
+ undef $output;                        # -o option present?
+@@ -175,6 +175,7 @@
+     } elsif ( $a eq '-shared' ) {
+       $shared = 1;
+     } elsif ( $a eq '-static' ) {
++      push(@ldopt, $a);
+       $shared = 0;
+     } elsif ( $a eq '-s' ) {
+       $strip = 1;
+diff -urN klibc-1.1.16.org/Makefile klibc-1.1.16/Makefile
+--- klibc-1.1.16.org/Makefile  2006-01-06 07:11:43.000000000 +0100
++++ klibc-1.1.16/Makefile      2006-01-06 19:32:24.054818750 +0100
+@@ -21,11 +21,11 @@
+ export PERL       := perl
+ # Location for installation
+-export prefix      = /usr
+-export bindir      = $(prefix)/bin
+-export libdir      = $(prefix)/lib
+-export mandir      = $(prefix)/man
+-export INSTALLDIR  = $(prefix)/lib/klibc
++export prefix      = $(rpm_prefix)
++export bindir      = $(rpm_bindir)
++export libdir      = $(rpm_libdir)
++export mandir      = $(rpm_mandir)
++export INSTALLDIR  = $(rpm_libdir)/klibc
+ export INSTALLROOT =
+ # Create a fake .config as present in the kernel tree
This page took 0.126578 seconds and 4 git commands to generate.