]> git.pld-linux.org Git - packages/klibc.git/blob - klibc.spec
- updated to 1.3.21.
[packages/klibc.git] / klibc.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # build without distribution kernel-headers
4 #
5 Summary:        Minimalistic libc subset for use with initramfs
6 Summary(pl):    Zminimalizowany podzbiór biblioteki C do u¿ywania z initramfs
7 Name:           klibc
8 Version:        1.3.21
9 Release:        1
10 License:        BSD/GPL
11 Group:          Libraries
12 Source0:        http://www.kernel.org/pub/linux/libs/klibc/Testing/%{name}-%{version}.tar.bz2
13 # Source0-md5:  f4b7d9cf529818d09936d9124c19f288
14 #Source0:       http://www.kernel.org/pub/linux/libs/klibc/%{name}-%{version}.tar.bz2
15 Patch0:         %{name}-klcc.patch
16 Patch1:         %{name}-kill_interp_sohash.patch
17 URL:            http://www.zytor.com/mailman/listinfo/klibc/
18 %{?with_dist_kernel:BuildRequires:      kernel-headers >= 2.4}
19 BuildRequires:  bison
20 BuildRequires:  flex
21 BuildRequires:  rpmbuild(macros) >= 1.153
22 BuildRequires:  perl-base
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         no_install_post_strip   1
26
27 %description
28 klibc, what is intended to be a minimalistic libc subset for use with
29 initramfs. It is deliberately written for small size, minimal
30 entaglement and portability, not speed. It is definitely a work in
31 progress, and a lot of things are still missing.
32
33 %description -l pl
34 klibc w zamierzeniu ma byæ minimalistycznym podzbiorem biblioteki libc
35 do u¿ycia z initramfs. Celem jest minimalizacja, przeno¶no¶æ ale nie
36 szybko¶æ. klibc jest rozwijan± bibliotek± w zwi±zku z czym nadal
37 brakuje wielu rzeczy.
38
39 %package devel
40 Summary:        Development files for klibc
41 Summary(pl):    Pliki dla programistów klibc
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       binutils
45 %{?with_dist_kernel:Requires:   kernel-headers >= 2.4}
46
47 %description devel
48 Small libc for building embedded applications - development files.
49
50 %description devel -l pl
51 Ma³a libc do budowania aplikacji wbudowanych - pliki dla programistów.
52
53 %package static
54 Summary:        Static klibc libraries
55 Summary(pl):    Biblioteki statyczne klibc
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static klibc libraries.
61
62 %description static -l pl
63 Biblioteki statyczne klibc.
64
65 %package utils-shared
66 Summary:        Utilities dynamically linked with klibc
67 Summary(pl):    Narzêdzia dynamicznie zlinkowane z klibc
68 Group:          Base
69 Requires:       %{name} = %{version}-%{release}
70
71 %description utils-shared
72 Utilities dynamically linked with klibc.
73
74 %description utils-shared -l pl
75 Narzêdzia dynamicznie zlinkowane z klibc.
76
77 %package utils-static
78 Summary:        Utilities statically linked with klibc
79 Summary(pl):    Narzêdzia statycznie zlinkowane z klibc
80 Group:          Base
81
82 %description utils-static
83 Utilities staticly linked with klibc.
84
85 %description utils-static -l pl
86 Narzêdzia statycznie zlinkowane z klibc.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91 %patch1 -p1
92
93 %build
94 rm -rf usr/include/{asm,asm-generic,linux}
95 %ifarch ppc powerpc
96 if [ -d %{_kernelsrcdir}/include/asm-powerpc ]; then
97         install -d usr/include/asm
98         cp -a %{_kernelsrcdir}/include/asm-ppc/* usr/include/asm/
99         cp -a %{_kernelsrcdir}/include/asm-powerpc/* usr/include/asm/
100 else
101         ln -sf %{_kernelsrcdir}/include/asm-%{_target_base_arch} usr/include/asm
102 fi
103 %else
104         ln -sf %{_kernelsrcdir}/include/asm-%{_target_base_arch} usr/include/asm
105 %endif
106 cd usr/include
107 ln -sf %{_kernelsrcdir}/include/asm-generic .
108 ln -sf %{_kernelsrcdir}/include/linux .
109 %if %{with dist_kernel}
110 [ ! -d arch/%{_target_base_arch}/linux ] && mkdir arch/%{_target_base_arch}/linux
111 ln -sf  %{_kernelsrcdir}/include/linux/autoconf-up.h arch/%{_target_base_arch}/linux/autoconf.h
112 %endif
113 for a in `ls arch`; do [ "$a" != "%{_target_base_arch}" ] && rm -rf arch/$a; done
114 cd ../..
115
116 %ifarch sparc
117 # hack; missing dependency in make system
118 ( cd usr/klibc && %{__make} -f arch/sparc/Makefile.inc ARCH=sparc \
119         arch/sparc/sdiv.S arch/sparc/udiv.S arch/sparc/srem.S arch/sparc/urem.S )
120 %endif
121
122 %{__make} \
123         ARCH=%{_target_base_arch} \
124         HOSTCC="%{__cc}" \
125         rpm_prefix=%{_prefix} \
126         rpm_bindir=%{_bindir} \
127         rpm_includedir=%{_includedir}/klibc \
128         rpm_libdir=%{_libdir} \
129         SHLIBDIR=/%{_lib} \
130         OPTFLAGS="%{rpmcflags} -Os -fomit-frame-pointer -falign-functions=0 \
131                 -falign-jumps=0 -falign-loops=0 -ffreestanding"
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135 install -d $RPM_BUILD_ROOT/%{_lib}
136 install -d $RPM_BUILD_ROOT%{_includedir}/klibc
137 install -d $RPM_BUILD_ROOT%{_libdir}/klibc/bin-{shared,static}
138
139 cp -a usr/include/* $RPM_BUILD_ROOT%{_includedir}/klibc
140 install klcc/klcc -D $RPM_BUILD_ROOT%{_bindir}/klcc
141 install klcc/klcc.1 -D $RPM_BUILD_ROOT%{_mandir}/man1/klcc.1
142 install usr/klibc/libc.* usr/klibc/arch/%{_target_base_arch}/crt0.o usr/klibc/interp.o $RPM_BUILD_ROOT%{_libdir}/klibc
143 install usr/klibc/klibc.so $RPM_BUILD_ROOT/%{_lib}
144 install usr/dash/sh.shared $RPM_BUILD_ROOT%{_libdir}/klibc/bin-shared/sh
145 install usr/dash/sh.shared.g $RPM_BUILD_ROOT%{_libdir}/klibc/bin-shared/sh.g
146 install usr/dash/sh $RPM_BUILD_ROOT%{_libdir}/klibc/bin-static/sh
147 install usr/dash/sh.g $RPM_BUILD_ROOT%{_libdir}/klibc/bin-static/sh.g
148 install usr/kinit/*/shared/* $RPM_BUILD_ROOT%{_libdir}/klibc/bin-shared
149 install usr/kinit/*/static/* $RPM_BUILD_ROOT%{_libdir}/klibc/bin-static
150 install usr/utils/shared/* $RPM_BUILD_ROOT%{_libdir}/klibc/bin-shared
151 install usr/utils/static/* $RPM_BUILD_ROOT%{_libdir}/klibc/bin-static
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %files
157 %defattr(644,root,root,755)
158 %attr(755,root,root) /%{_lib}/klibc.so
159
160 %files devel
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_bindir}/klcc
163 %{_includedir}/klibc
164 %dir %{_libdir}/klibc
165 %attr(755,root,root) %{_libdir}/klibc/*.so
166 %{_libdir}/klibc/*.o
167 %{_mandir}/man1/*
168
169 %files static
170 %defattr(644,root,root,755)
171 %{_libdir}/klibc/*.a
172
173 %files utils-shared
174 %defattr(644,root,root,755)
175 %dir %{_libdir}/klibc/bin-shared
176 %attr(755,root,root) %{_libdir}/klibc/bin-shared/*
177
178 %files utils-static
179 %defattr(644,root,root,755)
180 %dir %{_libdir}/klibc/bin-static
181 %attr(755,root,root) %{_libdir}/klibc/bin-static/*
This page took 0.082606 seconds and 4 git commands to generate.