]> git.pld-linux.org Git - packages/klibc.git/blob - klibc.spec
- crossbuild enabled, license updated.
[packages/klibc.git] / klibc.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # build without distribution kernel-headers
4 #
5 Summary:        Minimalistic libc subset for use with initramfs
6 Summary(pl):    Zminimalizowany podzbiór biblioteki C do u¿ywania z initramfs
7 Name:           klibc
8 Version:        1.0
9 Release:        0.1
10 License:        BSD/GPL
11 Group:          Libraries
12 Source0:        http://www.kernel.org/pub/linux/libs/klibc/%{name}-%{version}.tar.bz2
13 # Source0-md5:  daaa233fb7905cbe110896fcad9bec7f
14 Patch0:         %{name}-ksh-quotation.patch
15 Patch1:         %{name}-dirent.patch
16 URL:            http://www.zytor.com/mailman/listinfo/klibc/
17 %{?with_dist_kernel:BuildRequires:      kernel-headers >= 2.4}
18 BuildRequires:  rpmbuild(macros) >= 1.153
19 BuildRequires:  perl-base
20 %{?with_dist_kernel:Requires:   kernel-headers >= 2.4}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         no_install_post_strip   1
24
25 %description
26 klibc, what is intended to be a minimalistic libc subset for use with
27 initramfs. It is deliberately written for small size, minimal
28 entaglement and portability, not speed. It is definitely a work in
29 progress, and a lot of things are still missing.
30
31 %description -l pl
32 klibc w zamierzeniu ma byæ minimalistycznym podzbiorem biblioteki libc
33 do u¿ycia z initramfs. Celem jest minimalizacja, przeno¶no¶æ ale nie
34 szybko¶æ. klibc jest rozwijan± bibliotek± w zwi±zku z czym nadal
35 brakuje wielu rzeczy.
36
37 %package utils-shared
38 Summary:        Utilities dynamically linked with klibc
39 Summary(pl):    Narzêdzia dynamicznie zlinkowane z klibc
40 Group:          Base
41 Requires:       %{name} = %{version}-%{release}
42
43 %description utils-shared
44 Utilities dynamically linked with klibc.
45
46 %description utils-shared -l pl
47 Narzêdzia dynamicznie zlinkowane z klibc.
48
49 %package utils-static
50 Summary:        Utilities statically linked with klibc
51 Summary(pl):    Narzêdzia statycznie zlinkowane z klibc
52 Group:          Base
53
54 %description utils-static
55 Utilities staticly linked with klibc.
56
57 %description utils-static -l pl
58 Narzêdzia statycznie zlinkowane z klibc.
59
60 %prep
61 %setup -q
62 %patch0 -p1
63 #patch1 -p1
64
65 %build
66 rm -rf include/{asm,asm-generic,linux}
67 ln -sf %{_kernelsrcdir}/include/asm-%{_target_base_arch} include/asm
68 ln -sf %{_kernelsrcdir}/include/asm-generic include/asm-generic
69 cp -ar %{_kernelsrcdir}/include/linux include/linux
70 ln -sf %{_kernelsrcdir}/include/linux/autoconf-up.h include/linux/autoconf.h
71
72 %{__make} \
73 %if "%{_target_base_arch}" != "%{_arch}"
74         ARCH=%{_target_base_arch} \
75         CROSS=%{_target_base_arch}-pld-linux- \
76 %else
77         CC=%{__cc} \
78 %endif
79         OPTFLAGS="%{rpmcflags} -Os -fomit-frame-pointer -falign-functions=0 \
80                 -falign-jumps=0 -falign-loops=0 -ffreestanding"
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT%{_includedir}/klibc
85 install -d $RPM_BUILD_ROOT%{_libdir}/klibc/bin-{shared,static}
86
87 cp -a include/* $RPM_BUILD_ROOT%{_includedir}/klibc
88 install klcc -D $RPM_BUILD_ROOT%{_bindir}/klcc
89 install klcc.1 -D $RPM_BUILD_ROOT%{_mandir}/man1/klcc.1
90 install klibc/libc.* klibc/crt0.o $RPM_BUILD_ROOT%{_libdir}/klibc
91 install utils/shared/* $RPM_BUILD_ROOT%{_libdir}/klibc/bin-shared
92 install utils/static/* $RPM_BUILD_ROOT%{_libdir}/klibc/bin-static
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_bindir}/klcc
100 %{_includedir}/klibc
101 %dir %{_libdir}/klibc
102 %attr(755,root,root) %{_libdir}/klibc/*.so
103 %{_libdir}/klibc/*.[ao]
104 %{_mandir}/man1/*
105
106 %files utils-shared
107 %defattr(644,root,root,755)
108 %dir %{_libdir}/klibc/bin-shared
109 %attr(755,root,root) %{_libdir}/klibc/bin-shared/*
110
111 %files utils-static
112 %defattr(644,root,root,755)
113 %dir %{_libdir}/klibc/bin-static
114 %attr(755,root,root) %{_libdir}/klibc/bin-static/*
This page took 0.089006 seconds and 4 git commands to generate.