]> git.pld-linux.org Git - packages/klibc.git/blob - klibc.spec
- build shared binaries by default.
[packages/klibc.git] / klibc.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # build without distribution kernel-headers
4 #
5 Summary:        Minimalistic libc subset for use with initramfs
6 Summary(pl):    Zminimalizowany podzbiór biblioteki C do u¿ywania z initramfs
7 Name:           klibc
8 Version:        1.1.1
9 Release:        0.1
10 License:        BSD/GPL
11 Group:          Libraries
12 Source0:        http://www.kernel.org/pub/linux/libs/klibc/Testing/%{name}-%{version}.tar.bz2
13 # Source0-md5:  baa1f6e0b6acbf9576bb28cca5c32c89
14 Patch0:         %{name}-ksh-quotation.patch
15 Patch1:         %{name}-klcc.patch
16 URL:            http://www.zytor.com/mailman/listinfo/klibc/
17 %{?with_dist_kernel:BuildRequires:      kernel-headers >= 2.4}
18 BuildRequires:  rpmbuild(macros) >= 1.153
19 BuildRequires:  perl-base
20 %{?with_dist_kernel:Requires:   kernel-headers >= 2.4}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         no_install_post_strip   1
24
25 %description
26 klibc, what is intended to be a minimalistic libc subset for use with
27 initramfs. It is deliberately written for small size, minimal
28 entaglement and portability, not speed. It is definitely a work in
29 progress, and a lot of things are still missing.
30
31 %description -l pl
32 klibc w zamierzeniu ma byæ minimalistycznym podzbiorem biblioteki libc
33 do u¿ycia z initramfs. Celem jest minimalizacja, przeno¶no¶æ ale nie
34 szybko¶æ. klibc jest rozwijan± bibliotek± w zwi±zku z czym nadal
35 brakuje wielu rzeczy.
36
37 %package utils-shared
38 Summary:        Utilities dynamically linked with klibc
39 Summary(pl):    Narzêdzia dynamicznie zlinkowane z klibc
40 Group:          Base
41 Requires:       %{name} = %{version}-%{release}
42
43 %description utils-shared
44 Utilities dynamically linked with klibc.
45
46 %description utils-shared -l pl
47 Narzêdzia dynamicznie zlinkowane z klibc.
48
49 %package utils-static
50 Summary:        Utilities statically linked with klibc
51 Summary(pl):    Narzêdzia statycznie zlinkowane z klibc
52 Group:          Base
53
54 %description utils-static
55 Utilities staticly linked with klibc.
56
57 %description utils-static -l pl
58 Narzêdzia statycznie zlinkowane z klibc.
59
60 %prep
61 %setup -q
62 %patch0 -p1
63 %patch1 -p1
64
65 %build
66 cd include
67 rm -rf asm asm-generic linux
68 cp -a %{_kernelsrcdir}/include/asm-%{_target_base_arch} .
69 ln -sf asm-%{_target_base_arch} asm
70 cp -a %{_kernelsrcdir}/include/asm-generic .
71 cp -a %{_kernelsrcdir}/include/linux .
72 %{?with_dist_kernel:cp -a %{_kernelsrcdir}/include/linux/autoconf-up.h linux/autoconf.h}
73 cd ..
74
75 %{__make} \
76         ARCH=%{_target_base_arch} \
77         CC="%{__cc}" \
78         prefix=%{_prefix} \
79         bindir=%{_bindir} \
80         includedir=%{_includedir}/klibc \
81         libdir=%{_libdir} \
82         OPTFLAGS="%{rpmcflags} -Os -fomit-frame-pointer -falign-functions=0 \
83                 -falign-jumps=0 -falign-loops=0 -ffreestanding"
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT/%{_lib}
88 install -d $RPM_BUILD_ROOT%{_includedir}/klibc
89 install -d $RPM_BUILD_ROOT%{_libdir}/klibc/bin-{shared,static}
90
91 cp -a include/* $RPM_BUILD_ROOT%{_includedir}/klibc
92
93 install klcc -D $RPM_BUILD_ROOT%{_bindir}/klcc
94 install klcc.1 -D $RPM_BUILD_ROOT%{_mandir}/man1/klcc.1
95 install klibc/libc.* klibc/crt0.o klibc/interp.o $RPM_BUILD_ROOT%{_libdir}/klibc
96 install klibc/klibc-*.so $RPM_BUILD_ROOT/%{_lib}
97 install utils/shared/* $RPM_BUILD_ROOT%{_libdir}/klibc/bin-shared
98 install utils/static/* $RPM_BUILD_ROOT%{_libdir}/klibc/bin-static
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files
104 %defattr(644,root,root,755)
105 %attr(755,root,root) /%{_lib}/klibc*.so
106 %attr(755,root,root) %{_bindir}/klcc
107 %{_includedir}/klibc
108 %dir %{_libdir}/klibc
109 %attr(755,root,root) %{_libdir}/klibc/*.so
110 %{_libdir}/klibc/*.so.hash
111 %{_libdir}/klibc/*.[ao]
112 %{_mandir}/man1/*
113
114 %files utils-shared
115 %defattr(644,root,root,755)
116 %dir %{_libdir}/klibc/bin-shared
117 %attr(755,root,root) %{_libdir}/klibc/bin-shared/*
118
119 %files utils-static
120 %defattr(644,root,root,755)
121 %dir %{_libdir}/klibc/bin-static
122 %attr(755,root,root) %{_libdir}/klibc/bin-static/*
This page took 0.052161 seconds and 4 git commands to generate.