]> git.pld-linux.org Git - packages/klibc.git/blob - klibc.spec
- addedd ppc and ppc64
[packages/klibc.git] / klibc.spec
1 Summary:        Minimalistic libc subset for use with initramfs
2 Summary(pl):    Zminimalizowany podzbiór bibliteki C do u¿ywa z initramfs
3 Name:           klibc
4 Version:        0.22
5 Release:        1
6 License:        BSD
7 Group:          Libraries
8 Source0:        ftp://ftp.kernel.org/pub/linux/libs/klibc/%{name}-%{version}.tar.bz2
9 BuildRequires:  kernel-source >= 2.4
10 BuildRequires:  perl
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %define no_install_post_strip 1
14
15 %description
16 klibc, what is intended to be a minimalistic libc subset for use with
17 initramfs. It is deliberately written for small size, minimal
18 entaglement and portability, not speed. It is definitely a work in
19 progress, and a lot of things are still missing.
20
21 %description -l pl
22 klibc w zamierzeniu ma byæ minimalistycznym podzbiorem biblioteki libc
23 do u¿ycia z initramfs. Celem jest minimalizacja, przenaszalno¶æ ale
24 nie szybko¶æ. klibc jest rozwijan± bibliotek± w zwi±zku z czym nadal
25 brakuje wielu rzeczy.
26
27 %prep
28 %setup -q
29
30 %build
31 ln -s %{_kernelsrcdir} linux
32
33 # 32 bit archs
34 %ifarch %{ix86} sparc sparc32 ppc
35 ln -sf bits32 include/bitsize
36 %endif
37 # 64 bit archs
38 %ifarch alpha sparc64 ppc64
39 ln -sf bits64 include/bitsize
40 %endif
41
42 %{__make} \
43 %ifarch %{ix86}
44         ARCH=i386 \
45 %else
46         ARCH=%{_target_cpu} \
47 %endif
48         OPTFLAGS="%{rpmcflags} -Os -fomit-frame-pointer -falign-functions=0 \
49                 -falign-jumps=0 -falign-loops=0"
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT%{_includedir}/klibc
54 install -d $RPM_BUILD_ROOT%{_libdir}/klibc
55
56 cp -a include/* $RPM_BUILD_ROOT%{_includedir}/klibc
57 install libc.* crt0.o   $RPM_BUILD_ROOT%{_libdir}/klibc
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %{_includedir}/klibc
65 %dir %{_libdir}/klibc
66 %{_libdir}/klibc/*.[ao]
67 %attr(755,root,root) %{_libdir}/klibc/*.so
This page took 0.061929 seconds and 4 git commands to generate.