]> git.pld-linux.org Git - packages/kicad.git/commitdiff
- updated to 5.1.4 auto/th/kicad-5.1.4-1
authorBartek Szady <bszx@bszx.eu>
Sat, 17 Aug 2019 09:48:07 +0000 (11:48 +0200)
committerBartek Szady <bszx@bszx.eu>
Sat, 17 Aug 2019 09:53:03 +0000 (11:53 +0200)
- lto.patch dropped; lto had been disabled for the libcontext.cpp file by upstream.

kicad.spec
lto.patch [deleted file]

index 50f21869baf56b93bd1d4d573933edbbc2a178db..9c5a0fe0ddfe72e3f083c2282bca83a8d7882584 100644 (file)
@@ -7,27 +7,26 @@
 Summary:       KiCad - is a GPL'd suite of programs for EDA
 Summary(pl.UTF-8):     KiCad - zestaw programów na licencji GPL zaliczany do kategorii EDA
 Name:          kicad
-Version:       5.1.3
+Version:       5.1.4
 Release:       1
 Epoch:         1
 License:       GPL v2+
 Group:         X11/Applications
 Source0:       https://launchpad.net/kicad/5.0/%{version}/+download/%{name}-%{version}.tar.xz
-# Source0-md5: 2b19f725af87acb95a1738ca7e77454a
+# Source0-md5: 7118929c3ada6baede7fae5d217a1101
 Source1:       https://github.com/KiCad/kicad-doc/archive/%{version}/%{name}-doc-%{version}.tar.gz
-# Source1-md5: 24aca594d7eaafee02c9dc710fc7cc0a
+# Source1-md5: 291af9a09674032c88f8ba4c8b07c651
 Source2:       https://github.com/KiCad/kicad-i18n/archive/%{version}/%{name}-i18n-%{version}.tar.gz
-# Source2-md5: cf1897243d31bf6882ab6e60f77adb4a
+# Source2-md5: f8f88696977bdb78e0ebc40761331626
 Source3:       https://github.com/KiCad/kicad-symbols/archive/%{version}/%{name}-symbols-%{version}.tar.gz
-# Source3-md5: 84b1d245deb8ee043384f1b933fc485d
+# Source3-md5: 92b64f0a88782b95be887378289002b4
 Source4:       https://github.com/KiCad/kicad-footprints/archive/%{version}/%{name}-footprints-%{version}.tar.gz
-# Source4-md5: 7aa398aa0f82295b7c27399538145ee7
+# Source4-md5: 8db001204ae43e28648d3acea4f472de
 Source5:       https://github.com/KiCad/kicad-packages3D/archive/%{version}/%{name}-packages3D-%{version}.tar.gz
-# Source5-md5: 7cafcf48ecba76b8c3e0280684774e9b
+# Source5-md5: e12f72c4a5c65cb0bb6a3c242e2ed482
 Source6:       https://github.com/KiCad/kicad-templates/archive/%{version}/%{name}-templates-%{version}.tar.gz
-# Source6-md5: a15e178b79df779c36195a7ff2997f48
+# Source6-md5: ac9e18f5e22cc90b669b186531f76314
 Patch0:                nostrip.patch
-Patch1:                lto.patch
 URL:           http://www.kicad-pcb.org/
 BuildRequires: GLM >= 0.9.9.4
 BuildRequires: OCE-devel
@@ -238,7 +237,6 @@ Documentation and tutorials for Kicad in Chinese.
 %prep
 %setup -q -a 1 -a 2 -a 3 -a 4 %{?with_packages3D:-a 5} -a 6
 %patch0 -p1
-%patch1 -p1
 
 %build
 
diff --git a/lto.patch b/lto.patch
deleted file mode 100644 (file)
index ad2c2f0..0000000
--- a/lto.patch
+++ /dev/null
@@ -1,148 +0,0 @@
---- kicad-5.0.0/common/system/libcontext.cpp.orig      2018-07-13 21:53:52.000000000 +0200
-+++ kicad-5.0.0/common/system/libcontext.cpp   2018-08-12 12:01:30.930309888 +0200
-@@ -258,12 +258,10 @@
- #endif
- #if defined(LIBCONTEXT_PLATFORM_linux_i386) && defined(LIBCONTEXT_COMPILER_gcc)
-+intptr_t LIBCONTEXT_CALL_CONVENTION libcontext::jump_fcontext( libcontext::fcontext_t* ofc, libcontext::fcontext_t nfc,
-+        intptr_t vp, bool preserve_fpu )
-+{
- __asm (
--".text\n"
--".globl jump_fcontext\n"
--".align 2\n"
--".type jump_fcontext,@function\n"
--"jump_fcontext:\n"
- "    movl  0x10(%esp), %ecx\n"
- "    pushl  %ebp  \n"
- "    pushl  %ebx  \n"
-@@ -293,19 +291,16 @@
- "    popl  %edx\n"
- "    movl  %eax, 0x4(%esp)\n"
- "    jmp  *%edx\n"
--".size jump_fcontext,.-jump_fcontext\n"
--".section .note.GNU-stack,\"\",%progbits\n"
- );
-+}
- #endif
- #if defined(LIBCONTEXT_PLATFORM_linux_i386) && defined(LIBCONTEXT_COMPILER_gcc)
-+libcontext::fcontext_t LIBCONTEXT_CALL_CONVENTION libcontext::make_fcontext( void* sp, size_t size,
-+        void (* fn)( intptr_t ) )
-+{
- __asm (
--".text\n"
--".globl make_fcontext\n"
--".align 2\n"
--".type make_fcontext,@function\n"
--"make_fcontext:\n"
- "    movl  0x4(%esp), %eax\n"
- "    leal  -0x8(%eax), %eax\n"
- "    andl  $-16, %eax\n"
-@@ -327,19 +322,16 @@
- "    movl  %eax, (%esp)\n"
- "    call  _exit@PLT\n"
- "    hlt\n"
--".size make_fcontext,.-make_fcontext\n"
--".section .note.GNU-stack,\"\",%progbits\n"
- );
-+}
- #endif
- #if defined(LIBCONTEXT_PLATFORM_linux_x86_64) && defined(LIBCONTEXT_COMPILER_gcc)
-+intptr_t LIBCONTEXT_CALL_CONVENTION libcontext::jump_fcontext( libcontext::fcontext_t* ofc, libcontext::fcontext_t nfc,
-+        intptr_t vp, bool preserve_fpu )
-+{
- __asm (
--".text\n"
--".globl jump_fcontext\n"
--".type jump_fcontext,@function\n"
--".align 16\n"
--"jump_fcontext:\n"
- "    pushq  %rbp  \n"
- "    pushq  %rbx  \n"
- "    pushq  %r15  \n"
-@@ -370,19 +362,16 @@
- "    movq  %rdx, %rax\n"
- "    movq  %rdx, %rdi\n"
- "    jmp  *%r8\n"
--".size jump_fcontext,.-jump_fcontext\n"
--".section .note.GNU-stack,\"\",%progbits\n"
- );
-+}
- #endif
- #if defined(LIBCONTEXT_PLATFORM_linux_x86_64) && defined(LIBCONTEXT_COMPILER_gcc)
-+libcontext::fcontext_t LIBCONTEXT_CALL_CONVENTION libcontext::make_fcontext( void* sp, size_t size,
-+        void (* fn)( intptr_t ) )
-+{
- __asm (
--".text\n"
--".globl make_fcontext\n"
--".type make_fcontext,@function\n"
--".align 16\n"
--"make_fcontext:\n"
- "    movq  %rdi, %rax\n"
- "    andq  $-16, %rax\n"
- "    leaq  -0x48(%rax), %rax\n"
-@@ -396,9 +385,8 @@
- "    xorq  %rdi, %rdi\n"
- "    call  _exit@PLT\n"
- "    hlt\n"
--".size make_fcontext,.-make_fcontext\n"
--".section .note.GNU-stack,\"\",%progbits\n"
- );
-+}
- #endif
---- kicad-5.1.0/include/system/libcontext.h.orig       2019-03-08 13:31:50.000000000 +0100
-+++ kicad-5.1.0/include/system/libcontext.h    2019-03-15 22:51:14.620823853 +0100
-@@ -30,15 +30,19 @@
-     #if defined(__x86_64__) || defined(__amd64__)
-         #define LIBCONTEXT_PLATFORM_linux_x86_64
-         #define LIBCONTEXT_CALL_CONVENTION
-+        #define LIBCONTEXT_FUNCTION_ALIGN 16
-     #elif __i386__
-         #define LIBCONTEXT_PLATFORM_linux_i386
-         #define LIBCONTEXT_CALL_CONVENTION
-+        #define LIBCONTEXT_FUNCTION_ALIGN 2
-     #elif __arm__
-         #define LIBCONTEXT_PLATFORM_linux_arm32
-         #define LIBCONTEXT_CALL_CONVENTION
-+        #define LIBCONTEXT_FUNCTION_ALIGN 2
-     #elif __aarch64__
-         #define LIBCONTEXT_PLATFORM_linux_arm64
-         #define LIBCONTEXT_CALL_CONVENTION
-+        #define LIBCONTEXT_FUNCTION_ALIGN 2
-     #elif (__mips__ && _MIPS_SIM == _ABI64)
-         #define LIBCONTEXT_PLATFORM_linux_mips_n64
-         #define LIBCONTEXT_CALL_CONVENTION
-@@ -85,22 +89,15 @@
- typedef void* fcontext_t;
--#ifdef __cplusplus
--extern "C" {
--#endif
- intptr_t LIBCONTEXT_CALL_CONVENTION jump_fcontext( fcontext_t* ofc, fcontext_t nfc,
--        intptr_t vp, bool preserve_fpu = true );
-+        intptr_t vp, bool preserve_fpu = true )  __attribute__ ((naked, aligned(LIBCONTEXT_FUNCTION_ALIGN) ));
- fcontext_t LIBCONTEXT_CALL_CONVENTION make_fcontext( void* sp, size_t size,
--        void (* fn)( intptr_t ) );
-+        void (* fn)( intptr_t ) )  __attribute__ ((naked, aligned(LIBCONTEXT_FUNCTION_ALIGN) ));
- #ifdef __cplusplus
- }    // namespace
- #endif
--#ifdef __cplusplus
--}    // extern "C"
--#endif
--
- #endif
This page took 0.043651 seconds and 4 git commands to generate.