]> git.pld-linux.org Git - packages/kf5-sonnet.git/blob - kf5-sonnet.spec
c281053fbd4d3b7d45889dce334e975694692e4a
[packages/kf5-sonnet.git] / kf5-sonnet.spec
1 # TODO:
2 # - fix build with aspell
3 %define         kdeframever     5.24
4 %define         qtver           5.3.2
5 %define         kfname          sonnet
6
7 Summary:        Multi-language spell checker
8 Name:           kf5-%{kfname}
9 Version:        5.24.0
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14 # Source0-md5:  2b6d47648a14410eb236d5fe2923600d
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Gui-devel >= %{qtver}
18 BuildRequires:  Qt5Test-devel >= %{qtver}
19 BuildRequires:  Qt5Widgets-devel >= %{qtver}
20 BuildRequires:  aspell-devel
21 BuildRequires:  cmake >= 2.8.12
22 BuildRequires:  hspell-devel
23 BuildRequires:  hunspell-devel
24 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
25 BuildRequires:  qt5-linguist >= %{qtver}
26 BuildRequires:  rpmbuild(macros) >= 1.164
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 BuildRequires:  zlib-devel
30 Requires:       kf5-dirs
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         qt5dir          %{_libdir}/qt5
34
35 %description
36 Sonnet is a plugin-based spell checking library for Qt-based
37 applications. It supports several different plugins, including HSpell,
38 Enchant, ASpell and HUNSPELL.
39
40 It also supports automated language detection, based on a combination
41 of different algorithms.
42
43 The simplest way to use Sonnet in your application is to use the
44 SpellCheckDecorator class on your QTextEdit.
45
46 %package devel
47 Summary:        Header files for %{kfname} development
48 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
49 Group:          X11/Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description devel
53 Header files for %{kfname} development.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe dla programistów używających %{kfname}.
57
58 %prep
59 %setup -q -n %{kfname}-%{version}
60
61 %build
62 install -d build
63 cd build
64 %cmake \
65         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
66         ../
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} -C build/ install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files -f %{kfname}5_qt.lang
84 %defattr(644,root,root,755)
85 %doc README.md
86 %attr(755,root,root) %{_bindir}/parsetrigrams
87 %attr(755,root,root) %ghost %{_libdir}/libKF5SonnetCore.so.5
88 %attr(755,root,root) %{_libdir}/libKF5SonnetCore.so.*.*
89 %attr(755,root,root) %ghost %{_libdir}/libKF5SonnetUi.so.5
90 %attr(755,root,root) %{_libdir}/libKF5SonnetUi.so.*.*
91 %dir %{qt5dir}/plugins/kf5/sonnet
92 #%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/aspell.so
93 %attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/hspell.so
94 %attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/hunspell.so
95 %dir %{_datadir}/kf5/sonnet
96 %{_datadir}/kf5/sonnet/trigrams.map
97
98 %files devel
99 %defattr(644,root,root,755)
100 %{_includedir}/KF5/SonnetCore
101 %{_includedir}/KF5/SonnetUi
102 %{_includedir}/KF5/sonnet_version.h
103 %{_libdir}/cmake/KF5Sonnet
104 %attr(755,root,root) %{_libdir}/libKF5SonnetCore.so
105 %attr(755,root,root) %{_libdir}/libKF5SonnetUi.so
106 %{qt5dir}/mkspecs/modules/qt_SonnetCore.pri
107 %{qt5dir}/mkspecs/modules/qt_SonnetUi.pri
This page took 0.083147 seconds and 2 git commands to generate.