]> git.pld-linux.org Git - packages/kf5-sonnet.git/blame - kf5-sonnet.spec
- updated to 5.105.0
[packages/kf5-sonnet.git] / kf5-sonnet.spec
CommitLineData
e932793f
WF
1#
2# Conditional build:
3%bcond_with tests # build with tests
e35ff744 4# TODO:
61d3db40 5# - fix build with aspell
834d3c22 6%define kdeframever 5.105
6291070e 7%define qtver 5.15.2
61d3db40 8%define kfname sonnet
e35ff744
WF
9
10Summary: Multi-language spell checker
379e0ba4 11Summary(pl.UTF-8): Wielojęzyczne narzędzie do sprawdzania pisowni
61d3db40 12Name: kf5-%{kfname}
834d3c22
WF
13Version: 5.105.0
14Release: 1
e35ff744
WF
15License: LGPL v2.1+
16Group: X11/Libraries
a021bbe3 17Source0: https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
834d3c22 18# Source0-md5: ad60debd2f9f533412a015def8983c90
e35ff744 19URL: http://www.kde.org/
61d3db40 20BuildRequires: Qt5Core-devel >= %{qtver}
61d3db40
AM
21BuildRequires: Qt5Test-devel >= %{qtver}
22BuildRequires: Qt5Widgets-devel >= %{qtver}
3f3358fd 23BuildRequires: aspell
e35ff744 24BuildRequires: aspell-devel
6291070e 25BuildRequires: cmake >= 3.16
e35ff744
WF
26BuildRequires: hspell-devel
27BuildRequires: hunspell-devel
7551183b 28BuildRequires: kf5-extra-cmake-modules >= %{version}
f88c2bcc 29BuildRequires: libvoikko-devel
3345f3c2 30BuildRequires: ninja
61d3db40 31BuildRequires: qt5-linguist >= %{qtver}
ee8f0811 32BuildRequires: rpmbuild(macros) >= 1.736
cb665e08
ER
33BuildRequires: tar >= 1:1.22
34BuildRequires: xz
e35ff744 35BuildRequires: zlib-devel
3557adce
JP
36Requires: Qt5Core >= %{qtver}
37Requires: Qt5Widgets >= %{qtver}
fa53934d 38Requires: kf5-dirs
e35ff744
WF
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41%define qt5dir %{_libdir}/qt5
42
43%description
44Sonnet is a plugin-based spell checking library for Qt-based
45applications. It supports several different plugins, including HSpell,
379e0ba4 46ASpell and HUNSPELL.
e35ff744
WF
47
48It also supports automated language detection, based on a combination
49of different algorithms.
50
51The simplest way to use Sonnet in your application is to use the
52SpellCheckDecorator class on your QTextEdit.
53
379e0ba4
JB
54%description -l pl.UTF-8
55Sonnet to oparta na wtyczkach biblioteka do sprawdzania pisowni dla
56aplikacji opartych na Qt. Obsługuje kilka różnych wtyzek, w tym
57HSpell, ASpell i HUNSPELL.
58
59Pozwala automatycznie wykrywać język w oparciu o połączenie różnych
60algorytmów.
61
62Najprostszy sposób użycia Sonneta w aplikacji to użycie klasy
63SpellCheckDecorator w obiekcie QTextEdit.
64
e35ff744 65%package devel
61d3db40
AM
66Summary: Header files for %{kfname} development
67Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{kfname}
e35ff744
WF
68Group: X11/Development/Libraries
69Requires: %{name} = %{version}-%{release}
3557adce 70Requires: Qt5Core-devel >= %{qtver}
e35ff744
WF
71
72%description devel
61d3db40 73Header files for %{kfname} development.
e35ff744
WF
74
75%description devel -l pl.UTF-8
61d3db40 76Pliki nagłówkowe dla programistów używających %{kfname}.
e35ff744
WF
77
78%prep
61d3db40 79%setup -q -n %{kfname}-%{version}
e35ff744
WF
80
81%build
82install -d build
83cd build
3345f3c2 84%cmake -G Ninja \
e932793f 85 %{!?with_tests:-DBUILD_TESTING=OFF} \
61d3db40 86 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
e35ff744 87 ../
3345f3c2 88%ninja_build
e35ff744 89
e932793f
WF
90%if %{with tests}
91ctest
92%endif
93
94
e35ff744
WF
95%install
96rm -rf $RPM_BUILD_ROOT
3345f3c2 97%ninja_install -C build
e35ff744 98
535c7d7c 99%find_lang %{kfname}5_qt --with-qm --all-name --with-kde
e35ff744
WF
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
f88c2bcc
JB
104%post -p /sbin/ldconfig
105%postun -p /sbin/ldconfig
e35ff744 106
61d3db40 107%files -f %{kfname}5_qt.lang
e35ff744
WF
108%defattr(644,root,root,755)
109%doc README.md
69e779c3 110%attr(755,root,root) %{_bindir}/gentrigrams
fa53934d 111%attr(755,root,root) %{_bindir}/parsetrigrams
f91897c1 112%ghost %{_libdir}/libKF5SonnetCore.so.5
689dcc14 113%attr(755,root,root) %{_libdir}/libKF5SonnetCore.so.*.*
f91897c1 114%ghost %{_libdir}/libKF5SonnetUi.so.5
689dcc14 115%attr(755,root,root) %{_libdir}/libKF5SonnetUi.so.*.*
e35ff744 116%dir %{qt5dir}/plugins/kf5/sonnet
561a8ff3
AM
117%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_aspell.so
118%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_hspell.so
119%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_hunspell.so
3f3358fd 120%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_voikko.so
e86d6925
WF
121%attr(755,root,root) %{_libdir}/qt5/qml/org/kde/sonnet/libsonnetquickplugin.so
122%dir %{_libdir}/qt5/qml/org/kde/sonnet
123%{_libdir}/qt5/qml/org/kde/sonnet/plugins.qmltypes
124%{_libdir}/qt5/qml/org/kde/sonnet/qmldir
e0059170 125%attr(755,root,root) %{qt5dir}/plugins/designer/sonnetui5widgets.so
bf0726eb 126%{_datadir}/qlogging-categories5/sonnet.categories
2eecfd0e 127%{_datadir}/qlogging-categories5/sonnet.renamecategories
e35ff744
WF
128
129%files devel
130%defattr(644,root,root,755)
131%{_includedir}/KF5/SonnetCore
132%{_includedir}/KF5/SonnetUi
0425db44 133%{_includedir}/KF5/Sonnet
e35ff744 134%{_libdir}/cmake/KF5Sonnet
f91897c1
WF
135%{_libdir}/libKF5SonnetCore.so
136%{_libdir}/libKF5SonnetUi.so
e35ff744
WF
137%{qt5dir}/mkspecs/modules/qt_SonnetCore.pri
138%{qt5dir}/mkspecs/modules/qt_SonnetUi.pri
This page took 2.300924 seconds and 4 git commands to generate.