]> git.pld-linux.org Git - packages/kf5-sonnet.git/blame - kf5-sonnet.spec
- rebuild with hunspell 1.6
[packages/kf5-sonnet.git] / kf5-sonnet.spec
CommitLineData
e35ff744 1# TODO:
61d3db40 2# - fix build with aspell
37b34334 3%define kdeframever 5.24
61d3db40
AM
4%define qtver 5.3.2
5%define kfname sonnet
e35ff744
WF
6
7Summary: Multi-language spell checker
61d3db40 8Name: kf5-%{kfname}
37b34334 9Version: 5.24.0
3ae44a59 10Release: 2
e35ff744
WF
11License: LGPL v2.1+
12Group: X11/Libraries
61d3db40 13Source0: http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
37b34334 14# Source0-md5: 2b6d47648a14410eb236d5fe2923600d
e35ff744 15URL: http://www.kde.org/
61d3db40
AM
16BuildRequires: Qt5Core-devel >= %{qtver}
17BuildRequires: Qt5Gui-devel >= %{qtver}
18BuildRequires: Qt5Test-devel >= %{qtver}
19BuildRequires: Qt5Widgets-devel >= %{qtver}
e35ff744
WF
20BuildRequires: aspell-devel
21BuildRequires: cmake >= 2.8.12
22BuildRequires: hspell-devel
23BuildRequires: hunspell-devel
61d3db40
AM
24BuildRequires: kf5-extra-cmake-modules >= 1.4.0
25BuildRequires: qt5-linguist >= %{qtver}
e35ff744 26BuildRequires: rpmbuild(macros) >= 1.164
cb665e08
ER
27BuildRequires: tar >= 1:1.22
28BuildRequires: xz
e35ff744 29BuildRequires: zlib-devel
fa53934d 30Requires: kf5-dirs
e35ff744
WF
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%define qt5dir %{_libdir}/qt5
34
35%description
36Sonnet is a plugin-based spell checking library for Qt-based
37applications. It supports several different plugins, including HSpell,
38Enchant, ASpell and HUNSPELL.
39
40It also supports automated language detection, based on a combination
41of different algorithms.
42
43The simplest way to use Sonnet in your application is to use the
44SpellCheckDecorator class on your QTextEdit.
45
46%package devel
61d3db40
AM
47Summary: Header files for %{kfname} development
48Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{kfname}
e35ff744
WF
49Group: X11/Development/Libraries
50Requires: %{name} = %{version}-%{release}
51
52%description devel
61d3db40 53Header files for %{kfname} development.
e35ff744
WF
54
55%description devel -l pl.UTF-8
61d3db40 56Pliki nagłówkowe dla programistów używających %{kfname}.
e35ff744
WF
57
58%prep
61d3db40 59%setup -q -n %{kfname}-%{version}
e35ff744
WF
60
61%build
62install -d build
63cd build
64%cmake \
61d3db40 65 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
e35ff744
WF
66 ../
67%{__make}
68
69%install
70rm -rf $RPM_BUILD_ROOT
71
72%{__make} -C build/ install \
73 DESTDIR=$RPM_BUILD_ROOT
74
535c7d7c 75%find_lang %{kfname}5_qt --with-qm --all-name --with-kde
e35ff744
WF
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80%post -p /sbin/ldconfig
81%postun -p /sbin/ldconfig
82
61d3db40 83%files -f %{kfname}5_qt.lang
e35ff744
WF
84%defattr(644,root,root,755)
85%doc README.md
fa53934d 86%attr(755,root,root) %{_bindir}/parsetrigrams
e35ff744 87%attr(755,root,root) %ghost %{_libdir}/libKF5SonnetCore.so.5
689dcc14 88%attr(755,root,root) %{_libdir}/libKF5SonnetCore.so.*.*
e35ff744 89%attr(755,root,root) %ghost %{_libdir}/libKF5SonnetUi.so.5
689dcc14 90%attr(755,root,root) %{_libdir}/libKF5SonnetUi.so.*.*
e35ff744 91%dir %{qt5dir}/plugins/kf5/sonnet
cabd9c16 92#%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/aspell.so
e35ff744
WF
93%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/hspell.so
94%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/hunspell.so
95%dir %{_datadir}/kf5/sonnet
96%{_datadir}/kf5/sonnet/trigrams.map
97
98%files devel
99%defattr(644,root,root,755)
100%{_includedir}/KF5/SonnetCore
101%{_includedir}/KF5/SonnetUi
102%{_includedir}/KF5/sonnet_version.h
103%{_libdir}/cmake/KF5Sonnet
104%attr(755,root,root) %{_libdir}/libKF5SonnetCore.so
105%attr(755,root,root) %{_libdir}/libKF5SonnetUi.so
106%{qt5dir}/mkspecs/modules/qt_SonnetCore.pri
107%{qt5dir}/mkspecs/modules/qt_SonnetUi.pri
This page took 0.079363 seconds and 4 git commands to generate.