]> git.pld-linux.org Git - packages/kf5-kcoreaddons.git/blobdiff - kf5-kcoreaddons.spec
-updated to 5.24.0; fetch sources
[packages/kf5-kcoreaddons.git] / kf5-kcoreaddons.spec
index 9bbde458401cd1345a3592a4a36ca49565ef01ed..a85f112ec266bbb94a3db4a2dec1fea6491e2ce9 100644 (file)
@@ -1,32 +1,36 @@
+#
+# Conditional build:
+%bcond_without tests           # build without tests
+
 # TODO:
-# - proper place for *.pri,
-# - set ECM_MKSPECS_INSTALL_DIR in kde5-extra-cmake-modules
 # - runtime Requires if any
-# - dir /usr/include/KF5 not packaged
-%define         _state          stable
-%define                orgname         kcoreaddons
 
+%define                kdeframever     5.24
+%define                qtver           5.3.2
+%define                kfname          kcoreaddons
 Summary:       Utilities for core application functionality and accessing the OS
-Name:          kf5-%{orgname}
-Version:       5.0.0
-Release:       0.1
+Name:          kf5-%{kfname}
+Version:       5.24.0
+Release:       1
 License:       GPL v2+/LGPL v2.1+
 Group:         X11/Libraries
-Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
-# Source0-md5: 90dcfc98dbb0c55981370e264fb6f21f
+Source0:       http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
+# Source0-md5: 03dfc4b55274c8ecb5290baa305c0a7d
+Patch0:                flaky-tests.patch
 URL:           http://www.kde.org/
-BuildRequires: Qt5Core-devel >= 5.2.0
-BuildRequires: Qt5Test-devel
+BuildRequires: Qt5Core-devel >= %{qtver}
+BuildRequires: Qt5Test-devel >= %{qtver}
 BuildRequires: cmake >= 2.8.12
 BuildRequires: fam-devel
-BuildRequires: kf5-extra-cmake-modules >= 1.0.0
-BuildRequires: qt5-linguist
+BuildRequires: kf5-extra-cmake-modules >= 1.4.0
+BuildRequires: qt5-linguist >= %{qtver}
 BuildRequires: rpmbuild(macros) >= 1.164
 BuildRequires: shared-mime-info
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
+Requires:      kf5-dirs
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                qt5dir          %{_libdir}/qt5
-
 %description
 KCoreAddons provides classes built on top of QtCore to perform various
 tasks such as manipulating mime types, autosaving files, creating
@@ -35,63 +39,56 @@ manipulations such as macro replacement, accessing user information
 and many more.
 
 %package devel
-Summary:       Header files for %{orgname} development
-Summary(pl.UTF-8):     Pliki nagłówkowe dla programistów używających %{orgname}
+Summary:       Header files for %{kfname} development
+Summary(pl.UTF-8):     Pliki nagłówkowe dla programistów używających %{kfname}
 Group:         X11/Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 
 %description devel
-Header files for %{orgname} development.
+Header files for %{kfname} development.
 
 %description devel -l pl.UTF-8
-Pliki nagłówkowe dla programistów używających %{orgname}.
+Pliki nagłówkowe dla programistów używających %{kfname}.
 
 %prep
-%setup -q -n %{orgname}-%{version}
+%setup -q -n %{kfname}-%{version}
+#%patch0 -p1
 
 %build
 install -d build
 cd build
 %cmake \
-       -DBIN_INSTALL_DIR=%{_bindir} \
-       -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
-       -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
-       -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
-       -DQML_INSTALL_DIR=%{qt5dir}/qml \
-       -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
-       -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
-       -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
-       -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
-       -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
-       -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
+       -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
        ../
 %{__make}
 
+%{?with_tests:%{__make} test}
+
 %install
 rm -rf $RPM_BUILD_ROOT
-
-%{__make} -C build/ install \
+%{__make} -C build install \
         DESTDIR=$RPM_BUILD_ROOT
 
-%find_lang %{orgname}5_qt --with-qm
+%find_lang %{kfname}5_qt --with-qm --all-name --with-kde
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
 
-%files -f %{orgname}5_qt.lang
+%files -f %{kfname}5_qt.lang
 %defattr(644,root,root,755)
 %doc README.md
 %{_datadir}/mime/packages/kde5.xml
+%attr(755,root,root) %{_libdir}/libKF5CoreAddons.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libKF5CoreAddons.so.5
-%attr(755,root,root) %{_libdir}/libKF5CoreAddons.so.5.0.0
 
 %files devel
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/desktoptojson
 %{_includedir}/KF5/KCoreAddons
 %{_includedir}/KF5/kcoreaddons_version.h
 %{_libdir}/cmake/KF5CoreAddons
 %attr(755,root,root) %{_libdir}/libKF5CoreAddons.so
-%{qt5dir}/mkspecs/modules/qt_KCoreAddons.pri
+%{_libdir}/qt5/mkspecs/modules/qt_KCoreAddons.pri
This page took 0.120225 seconds and 4 git commands to generate.