]> git.pld-linux.org Git - packages/kf5-kcoreaddons.git/blame - kf5-kcoreaddons.spec
Revert "- updated to 5.249.0; rel 0.1"
[packages/kf5-kcoreaddons.git] / kf5-kcoreaddons.spec
CommitLineData
33f59a00
ER
1#
2# Conditional build:
519e4d44 3%bcond_with tests # build with tests
33f59a00 4
5ac406ba 5# TODO:
5ac406ba 6# - runtime Requires if any
3c1e7cb9 7
b5a9f82e 8%define kdeframever 5.114
e8c6165d 9%define qtver 5.15.2
33f59a00 10%define kfname kcoreaddons
5ac406ba 11Summary: Utilities for core application functionality and accessing the OS
33f59a00 12Name: kf5-%{kfname}
b5a9f82e
WF
13Version: 5.114.0
14Release: 1
5ac406ba
WF
15License: GPL v2+/LGPL v2.1+
16Group: X11/Libraries
b5a9f82e
WF
17Source0: https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
18# Source0-md5: 3bdf763a3ca15383822e97dfe2635269
ccdad5cc 19Patch0: flaky-tests.patch
5ac406ba 20URL: http://www.kde.org/
b5a9f82e 21BuildRequires: Qt5Core-devel >= %{qtver}
5ced6b28 22%if %{with tests}
b5a9f82e
WF
23BuildRequires: Qt5Test-devel >= %{qtver}
24BuildRequires: Qt5Widgets-devel >= %{qtver}
5ced6b28 25%endif
e8c6165d 26BuildRequires: cmake >= 3.16
5ced6b28 27BuildRequires: kf5-extra-cmake-modules >= %{version}
660a4795 28BuildRequires: ninja
33f59a00 29BuildRequires: qt5-linguist >= %{qtver}
4104425e 30BuildRequires: rpmbuild(macros) >= 1.736
5ced6b28 31BuildRequires: shared-mime-info >= 1.3
ddbe1ed5
ER
32BuildRequires: tar >= 1:1.22
33BuildRequires: xz
b5a9f82e 34Requires: Qt5Core >= %{qtver}
3dc0910e 35Requires: kf5-dirs
5ac406ba
WF
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39KCoreAddons provides classes built on top of QtCore to perform various
40tasks such as manipulating mime types, autosaving files, creating
41backup files, generating random sequences, performing text
42manipulations such as macro replacement, accessing user information
43and many more.
44
45%package devel
33f59a00
ER
46Summary: Header files for %{kfname} development
47Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{kfname}
5ac406ba
WF
48Group: X11/Development/Libraries
49Requires: %{name} = %{version}-%{release}
b5a9f82e 50Requires: Qt5Core >= %{qtver}
e8c6165d 51Requires: cmake >= 3.16
5ac406ba
WF
52
53%description devel
33f59a00 54Header files for %{kfname} development.
5ac406ba
WF
55
56%description devel -l pl.UTF-8
33f59a00 57Pliki nagłówkowe dla programistów używających %{kfname}.
5ac406ba
WF
58
59%prep
33f59a00 60%setup -q -n %{kfname}-%{version}
3dc0910e 61#%patch0 -p1
5ac406ba
WF
62
63%build
cdecc31f
WF
64%cmake -B build \
65 -G Ninja \
e7f0c914 66 %{!?with_tests:-DBUILD_TESTING=OFF} \
cdecc31f 67 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
5ac406ba 68
cdecc31f
WF
69%ninja_build -C build
70
71%{?with_tests:%ninja_build -C build test}
3c1e7cb9 72
e7f0c914 73
5ac406ba
WF
74%install
75rm -rf $RPM_BUILD_ROOT
660a4795 76%ninja_install -C build
5ac406ba 77
cfd4d676 78# not supported by glibc yet
d5ed4ff5 79%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{ie,tok}
cfd4d676 80
d768fe92 81%find_lang %{kfname}5_qt --with-qm --all-name --with-kde
5ac406ba
WF
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
33f59a00
ER
86%post -p /sbin/ldconfig
87%postun -p /sbin/ldconfig
5ac406ba 88
33f59a00 89%files -f %{kfname}5_qt.lang
5ac406ba
WF
90%defattr(644,root,root,755)
91%doc README.md
b5a9f82e
WF
92%{_datadir}/mime/packages/kde5.xml
93%attr(755,root,root) %{_libdir}/libKF5CoreAddons.so.*.*.*
94%ghost %{_libdir}/libKF5CoreAddons.so.5
08833e86
WF
95##%dir %{_libdir}/qt5/plugins/namespace
96##%attr(755,root,root) %{_libdir}/qt5/plugins/namespace/jsonplugin_cmake_macro.so
97##%attr(755,root,root) %{_libdir}/qt5/plugins/namespace/pluginwithoutmetadata.so
b5a9f82e
WF
98%{_datadir}/qlogging-categories5/kcoreaddons.categories
99%dir %{_datadir}/kf5/licenses
100%{_datadir}/kf5/licenses/ARTISTIC
101%{_datadir}/kf5/licenses/BSD
102%{_datadir}/kf5/licenses/GPL_V2
103%{_datadir}/kf5/licenses/GPL_V3
104%{_datadir}/kf5/licenses/LGPL_V2
105%{_datadir}/kf5/licenses/LGPL_V21
106%{_datadir}/kf5/licenses/LGPL_V3
107%{_datadir}/kf5/licenses/QPL_V1.0
108%{_datadir}/qlogging-categories5/kcoreaddons.renamecategories
5ac406ba
WF
109
110%files devel
111%defattr(644,root,root,755)
b5a9f82e
WF
112%attr(755,root,root) %{_bindir}/desktoptojson
113%{_includedir}/KF5/KCoreAddons
114%{_libdir}/cmake/KF5CoreAddons
115%{_libdir}/libKF5CoreAddons.so
116%{_libdir}/qt5/mkspecs/modules/qt_KCoreAddons.pri
This page took 0.610915 seconds and 4 git commands to generate.