]> git.pld-linux.org Git - packages/kf5-kcodecs.git/blob - kf5-kcodecs.spec
453c26e4f3de93bfa25ec6b06d7467abf4dcfecb
[packages/kf5-kcodecs.git] / kf5-kcodecs.spec
1 # TODO:
2 # - runtime Requires if any
3 %define         kdeframever     5.24
4 %define         qtver           5.4.0
5 %define         kfname          kcodecs
6
7 Summary:        String encoding
8 Name:           kf5-%{kfname}
9 Version:        5.24.0
10 Release:        2
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14 # Source0-md5:  970920c17542e24d3520a05f1cf7695e
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Test-devel >= %{qtver}
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  kf5-extra-cmake-modules >= %{version}
20 BuildRequires:  qt5-linguist >= %{qtver}
21 BuildRequires:  rpmbuild(macros) >= 1.164
22 BuildRequires:  tar >= 1:1.22
23 BuildRequires:  xz
24 Requires:       kf5-dirs
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 KCodecs provide a collection of methods to manipulate strings using
29 various encodings. It supports:
30
31 - base64
32 - uu
33 - quoted-printable
34
35 %package devel
36 Summary:        Header files for %{kfname} development
37 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
38 Group:          X11/Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       Qt5Core-devel >= %{qtver}
41 Requires:       cmake >= 2.6.0
42
43 %description devel
44 Header files for %{kfname} development.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe dla programistów używających %{kfname}.
48
49 %prep
50 %setup -q -n %{kfname}-%{version}
51
52 %build
53 install -d build
54 cd build
55 %cmake \
56         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
57         ../
58 %{__make}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} -C build/ install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post -p /sbin/ldconfig
72 %postun -p /sbin/ldconfig
73
74 %files -f %{kfname}5_qt.lang
75 %defattr(644,root,root,755)
76 %doc README.md
77 %attr(755,root,root) %ghost %{_libdir}/libKF5Codecs.so.5
78 %attr(755,root,root) %{_libdir}/libKF5Codecs.so.*.*
79
80 %files devel
81 %defattr(644,root,root,755)
82 %attr(755,root,root) %{_libdir}/libKF5Codecs.so
83 %{_includedir}/KF5/KCodecs
84 %{_includedir}/KF5/kcodecs_version.h
85 %{_libdir}/cmake/KF5Codecs
86 %{_libdir}/qt5/mkspecs/modules/qt_KCodecs.pri
This page took 0.061792 seconds and 2 git commands to generate.