]> git.pld-linux.org Git - packages/kf5-karchive.git/blobdiff - kf5-karchive.spec
- updated to 5.104.0
[packages/kf5-karchive.git] / kf5-karchive.spec
index 86113ee1dc2772c668ab33186ea36bcb40fc631a..e29fd237be224f2713c8f255ea6f1c7cdf0c6f1e 100644 (file)
@@ -1,30 +1,35 @@
+#
+# Conditional build:
+%bcond_with    tests           # build with tests
 # TODO:
 # - runtime Requires if any
-%define                kdeframever     5.86
-%define                qtver           5.14.0
+%define                kdeframever     5.104
+%define                qtver           5.15.2
 %define                kfname          karchive
 
 Summary:       Reading, creating, and manipulating file archives
 Name:          kf5-%{kfname}
-Version:       5.86.0
+Version:       5.104.0
 Release:       1
 License:       GPL v2+/LGPL v2.1+
 Group:         X11/Libraries
 Source0:       https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
-# Source0-md5: e331dcceaf1d05bf3840cfa19e8a465d
+# Source0-md5: 8e165cf7d85f015a82091b05bcb9a951
 URL:           http://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
 BuildRequires: Qt5Network-devel >= %{qtver}
 BuildRequires: Qt5Test-devel >= %{qtver}
 BuildRequires: bzip2-devel
-BuildRequires: cmake >= 3.5
+BuildRequires: cmake >= 3.16
 BuildRequires: kf5-extra-cmake-modules >= %{version}
 BuildRequires: ninja
+BuildRequires: pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.736
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
 BuildRequires: xz-devel
 BuildRequires: zlib-devel
+BuildRequires: zstd-devel
 Requires:      Qt5Core >= %{qtver}
 Requires:      kf5-dirs
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -44,7 +49,7 @@ Summary(pl.UTF-8):    Pliki nagłówkowe dla programistów używających %{kfname}
 Group:         X11/Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      Qt5Core-devel >= %{qtver}
-Requires:      cmake >= 3.5
+Requires:      cmake >= 3.16
 
 %description devel
 Header files for %{kfname} development.
@@ -59,10 +64,16 @@ Pliki nagłówkowe dla programistów używających %{kfname}.
 install -d build
 cd build
 %cmake -G Ninja \
+       %{!?with_tests:-DBUILD_TESTING=OFF} \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
        ..
 %ninja_build
 
+%if %{with tests}
+ctest
+%endif
+
+
 %install
 rm -rf $RPM_BUILD_ROOT
 %ninja_install -C build
@@ -84,7 +95,6 @@ rm -rf $RPM_BUILD_ROOT
 %files devel
 %defattr(644,root,root,755)
 %{_includedir}/KF5/KArchive
-%{_includedir}/KF5/karchive_version.h
 %{_libdir}/libKF5Archive.so
 %{_libdir}/cmake/KF5Archive
 %{qt5dir}/mkspecs/modules/qt_KArchive.pri
This page took 0.041154 seconds and 4 git commands to generate.