]> git.pld-linux.org Git - packages/kf5-attica.git/blob - kf5-attica.spec
bdcdd15257210bce8088837f507dd9ec2ff40bbc
[packages/kf5-attica.git] / kf5-attica.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 # TODO:
6 # - runtime Requires if any
7
8 %define         kdeframever     5.62
9 %define         qtver           5.9.0
10 %define         kfname          attica
11 Summary:        A Qt library that implements the Open Collaboration Services API
12 Name:           kf5-%{kfname}
13 Version:        5.62.0
14 Release:        1
15 License:        GPL v2+/LGPL v2.1+
16 Group:          X11/Libraries
17 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
18 # Source0-md5:  516c84e8e758786b6b201164fdc5ecc2
19 URL:            http://www.kde.org/
20 BuildRequires:  Qt5Core-devel >= %{qtver}
21 BuildRequires:  Qt5Gui-devel >= %{qtver}
22 BuildRequires:  Qt5Network-devel >= %{qtver}
23 BuildRequires:  Qt5Test-devel >= %{qtver}
24 %if %{with tests}
25 BuildRequires:  Qt5Gui-devel >= %{qtver}
26 BuildRequires:  Qt5Widgets-devel >= %{qtver}
27 %endif
28 BuildRequires:  cmake >= 2.8.12
29 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
30 BuildRequires:  ninja
31 BuildRequires:  qt5-build >= %{qtver}
32 BuildRequires:  rpmbuild(macros) >= 1.164
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  xz
35 Requires:       kf5-dirs
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Attica is a Qt library that implements the Open Collaboration Services
40 API version 1.6. The REST API is defined here:
41 <http://freedesktop.org/wiki/Specifications/open-collaboration-services-draft/>.
42
43 It grants easy access to the services such as querying information
44 about persons and contents. The library is used in KNewStuff3 as
45 content provider. In order to integrate with KDE's Plasma Desktop, a
46 platform plugin exists in kdebase.
47
48 %package devel
49 Summary:        Header files for %{kfname} development
50 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
51 Group:          X11/Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53
54 %description devel
55 Header files for %{kfname} development.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe dla programistów używających %{kfname}.
59
60 %prep
61 %setup -q -n %{kfname}-%{version}
62
63 %build
64 install -d build
65 cd build
66 %cmake -G Ninja \
67         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
68         ..
69 %ninja_build
70
71 %{?with_tests:%ninja_build test}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 %ninja_install -C build
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files
84 %defattr(644,root,root,755)
85 %doc AUTHORS README.md
86 %attr(755,root,root) %{_libdir}/libKF5Attica.so.*.*.*
87 %attr(755,root,root) %ghost %{_libdir}/libKF5Attica.so.5
88 %{_datadir}/qlogging-categories5/attica.categories
89
90 %files devel
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_libdir}/libKF5Attica.so
93 %{_includedir}/KF5/Attica
94 %{_includedir}/KF5/attica_version.h
95 %{_libdir}/cmake/KF5Attica
96 %{_pkgconfigdir}/libKF5Attica.pc
97 %{_libdir}/qt5/mkspecs/modules/qt_Attica.pri
This page took 0.108137 seconds and 2 git commands to generate.