]> git.pld-linux.org Git - packages/kf5-attica.git/blame_incremental - kf5-attica.spec
- updated to 5.39.0
[packages/kf5-attica.git] / kf5-attica.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
5# TODO:
6# - runtime Requires if any
7
8%define kdeframever 5.39
9%define qtver 5.3.2
10%define kfname attica
11Summary: A Qt library that implements the Open Collaboration Services API
12Name: kf5-%{kfname}
13Version: 5.39.0
14Release: 1
15License: GPL v2+/LGPL v2.1+
16Group: X11/Libraries
17Source0: http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
18# Source0-md5: b72d8db01a36deaa50ac46e221bbd469
19URL: http://www.kde.org/
20BuildRequires: Qt5Core-devel >= %{qtver}
21BuildRequires: Qt5Gui-devel >= %{qtver}
22BuildRequires: Qt5Network-devel >= %{qtver}
23BuildRequires: Qt5Test-devel >= %{qtver}
24%if %{with tests}
25BuildRequires: Qt5Gui-devel >= %{qtver}
26BuildRequires: Qt5Widgets-devel >= %{qtver}
27%endif
28BuildRequires: cmake >= 2.8.12
29BuildRequires: kf5-extra-cmake-modules >= 1.4.0
30BuildRequires: qt5-build >= %{qtver}
31BuildRequires: rpmbuild(macros) >= 1.164
32BuildRequires: tar >= 1:1.22
33BuildRequires: xz
34Requires: kf5-dirs
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38Attica is a Qt library that implements the Open Collaboration Services
39API version 1.6. The REST API is defined here:
40<http://freedesktop.org/wiki/Specifications/open-collaboration-services-draft/>.
41
42It grants easy access to the services such as querying information
43about persons and contents. The library is used in KNewStuff3 as
44content provider. In order to integrate with KDE's Plasma Desktop, a
45platform plugin exists in kdebase.
46
47%package devel
48Summary: Header files for %{kfname} development
49Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{kfname}
50Group: X11/Development/Libraries
51Requires: %{name} = %{version}-%{release}
52
53%description devel
54Header files for %{kfname} development.
55
56%description devel -l pl.UTF-8
57Pliki nagłówkowe dla programistów używających %{kfname}.
58
59%prep
60%setup -q -n %{kfname}-%{version}
61
62%build
63install -d build
64cd build
65%cmake \
66 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
67 ..
68%{__make}
69
70%{?with_tests:%{__make} test}
71
72%install
73rm -rf $RPM_BUILD_ROOT
74%{__make} -C build install \
75 DESTDIR=$RPM_BUILD_ROOT
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80%post -p /sbin/ldconfig
81%postun -p /sbin/ldconfig
82
83%files
84%defattr(644,root,root,755)
85%doc AUTHORS README.md
86%attr(755,root,root) %{_libdir}/libKF5Attica.so.*.*.*
87%attr(755,root,root) %ghost %{_libdir}/libKF5Attica.so.5
88/etc/xdg/attica.categories
89
90%files devel
91%defattr(644,root,root,755)
92%attr(755,root,root) %{_libdir}/libKF5Attica.so
93%{_includedir}/KF5/Attica
94%{_includedir}/KF5/attica_version.h
95%{_libdir}/cmake/KF5Attica
96%{_pkgconfigdir}/libKF5Attica.pc
97%{_libdir}/qt5/mkspecs/modules/qt_Attica.pri
This page took 0.229815 seconds and 4 git commands to generate.