]> git.pld-linux.org Git - packages/kernel.git/commitdiff
add support for building kernel with icecream
authorJan Palus <atler@pld-linux.org>
Sat, 11 Dec 2021 19:47:28 +0000 (20:47 +0100)
committerJan Palus <atler@pld-linux.org>
Sat, 11 Dec 2021 19:47:28 +0000 (20:47 +0100)
compiler needs access to custom kernel gcc plugins so distribute them as
well by building them first (make scripts) and adding them to
ICECC_EXTRAFILES

kernel.spec

index 584b4983c0a3f84c15dc11f160bc37e230d986c6..9da147907fc1bdad8f4f25d8895f08f09b231e6d 100644 (file)
@@ -935,8 +935,14 @@ cd -
 
 %{__awk} %{?debug:-v dieOnError=1} -v infile=%{objdir}/%{defconfig} -f %{SOURCE8} %{objdir}/.config
 
+%{__make} \
+       TARGETOBJ=%{targetobj} \
+       %{?with_verbose:V=1} \
+       scripts
+
 # build kernel
 export DTC_FLAGS=-@
+ICECC_EXTRAFILES="${ICECC_EXTRAFILES:+$ICECC_EXTRAFILES:}$(test -d %{objdir}/scripts/gcc-plugins && find %{objdir}/scripts/gcc-plugins -name '*.so' | paste -s -d :)"
 %{__make} \
        TARGETOBJ=%{targetobj} \
        %{?with_verbose:V=1} \
This page took 0.306958 seconds and 4 git commands to generate.