]> git.pld-linux.org Git - packages/kernel.git/commitdiff
compress kernel modules by rpm build, with "xz"
authorElan Ruusamäe <glen@delfi.ee>
Mon, 26 Jan 2015 21:58:52 +0000 (23:58 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 26 Jan 2015 21:58:59 +0000 (23:58 +0200)
this fixes problem that kernel modules were not stripped:
http://lists.pld-linux.org/mailman/pipermail/pld-devel-en/2015-January/024218.html

kernel.spec

index 66f25bf736bad562c651bd09622e5b6ad53bdfae..a92eb38bfb1360a2f1cff823eba77c5ac9e2989e 100644 (file)
@@ -253,7 +253,7 @@ BuildRequires:      hostname
 BuildRequires: kmod >= 12-2
 BuildRequires: perl-base
 BuildRequires: rpm-build >= 4.5-24
-BuildRequires: rpmbuild(macros) >= 1.704
+BuildRequires: rpmbuild(macros) >= 1.707
 Requires(post):        coreutils
 Requires(post):        geninitrd >= 10000.32
 Requires(post):        kmod >= 12-2
@@ -312,6 +312,8 @@ ExclusiveArch:      i486 i586 i686 pentium3 pentium4 athlon %{x8664} x32 alpha arm ia
 ExclusiveOS:   Linux
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                kmod_compress_cmd       %{__xz}
+
 %ifarch %{ix86} %{x8664} x32
 %define                target_arch_dir         x86
 %endif
@@ -947,6 +949,7 @@ rm -rf $RPM_BUILD_ROOT
        -C %{objdir} \
        %{?with_verbose:V=1} \
        DEPMOD=%{DepMod} \
+       mod_compress_cmd=true \
        INSTALL_MOD_PATH=$RPM_BUILD_ROOT \
        INSTALL_FW_PATH=$RPM_BUILD_ROOT/lib/firmware/%{kernel_release} \
        KERNELRELEASE=%{kernel_release}
This page took 0.122831 seconds and 4 git commands to generate.