]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- 3.14.59 auto/th/kernel-3.14-3.14.59-1
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 24 Jan 2016 16:28:11 +0000 (17:28 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 24 Jan 2016 16:28:11 +0000 (17:28 +0100)
kernel-small_fixes.patch
kernel.spec

index 6091ea7d312eaec436f063420665e34057da7f63..475b02db71518b9c0feafc6ccdf212999629da7c 100644 (file)
@@ -147,78 +147,3 @@ index 4e565c8..732648b 100644
  
  static spinlock_t pnp_bios_lock;
  
-From 7ca88764d45c209791e8813131c1457c2e9e51e7 Mon Sep 17 00:00:00 2001
-From: Yevgeny Pats <yevgeny@perception-point.io>
-Date: Mon, 11 Jan 2016 12:05:28 +0000
-Subject: KEYS: Fix keyring ref leak in join_session_keyring()
-
-If a thread is asked to join as a session keyring the keyring that's already
-set as its session, we leak a keyring reference.
-
-This can be tested with the following program:
-
-       #include <stddef.h>
-       #include <stdio.h>
-       #include <sys/types.h>
-       #include <keyutils.h>
-
-       int main(int argc, const char *argv[])
-       {
-               int i = 0;
-               key_serial_t serial;
-
-               serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
-                               "leaked-keyring");
-               if (serial < 0) {
-                       perror("keyctl");
-                       return -1;
-               }
-
-               if (keyctl(KEYCTL_SETPERM, serial,
-                          KEY_POS_ALL | KEY_USR_ALL) < 0) {
-                       perror("keyctl");
-                       return -1;
-               }
-
-               for (i = 0; i < 100; i++) {
-                       serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
-                                       "leaked-keyring");
-                       if (serial < 0) {
-                               perror("keyctl");
-                               return -1;
-                       }
-               }
-
-               return 0;
-       }
-
-If, after the program has run, there something like the following line in
-/proc/keys:
-
-3f3d898f I--Q---   100 perm 3f3f0000     0     0 keyring   leaked-keyring: empty
-
-with a usage count of 100 * the number of times the program has been run,
-then the kernel is malfunctioning.  If leaked-keyring has zero usages or
-has been garbage collected, then the problem is fixed.
-
-Reported-by: Yevgeny Pats <yevgeny@perception-point.io>
-Signed-off-by: David Howells <dhowells@redhat.com>
----
- security/keys/process_keys.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/security/keys/process_keys.c b/security/keys/process_keys.c
-index a3f85d2..e6d50172 100644
---- a/security/keys/process_keys.c
-+++ b/security/keys/process_keys.c
-@@ -794,6 +794,7 @@ long join_session_keyring(const char *name)
-               ret = PTR_ERR(keyring);
-               goto error2;
-       } else if (keyring == new->session_keyring) {
-+              key_put(keyring);
-               ret = 0;
-               goto error2;
-       }
--- 
-2.7.0.rc3
-
index 5e65062a738e2c23bdc15dd5e03c5f981fd1e2c7..1f74ab2d079e81ed389e968d50d612b03cb342cb 100644 (file)
@@ -68,9 +68,9 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             2
+%define                rel             1
 %define                basever         3.14
-%define                postver         .58
+%define                postver         .59
 
 %define                versuffix       -%{basever}
 
@@ -115,7 +115,7 @@ Source0:    http://www.kernel.org/pub/linux/kernel/v3.x/linux-%{basever}.tar.xz
 # Source0-md5: b621207b3f6ecbb67db18b13258f8ea8
 %if "%{postver}" != ".0"
 Patch0:                http://www.kernel.org/pub/linux/kernel/v3.x/patch-%{version}.xz
-# Patch0-md5:  3e5cfa1699b8a99aaa274cdcba82bf9b
+# Patch0-md5:  1659dff6662b9fab2730d47bf82acd94
 %endif
 Source1:       kernel.sysconfig
 
This page took 0.217772 seconds and 4 git commands to generate.