]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- up to 5.3.9; some aacraid fixes for 6-series controllers auto/th/kernel-5.3.9-1 auto/th/kernel-nopae-5.3.9-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 6 Nov 2019 17:39:56 +0000 (18:39 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 6 Nov 2019 17:39:56 +0000 (18:39 +0100)
kernel-small_fixes.patch
kernel.spec

index 8443eba94462d9d53ddb9ef8821c6850f8153abb..081469f23909b77a1605a99fb0e406a9336026ab 100644 (file)
@@ -472,4 +472,111 @@ index 0ed3f806ace5..2388143d59f5 100644
  
        dprintk((KERN_DEBUG "aac_write[cpu %d]: lba = %llu, t = %ld.\n",
 
-
+; https://lkml.org/lkml/2019/7/10/244
+diff -ur linux-5.3/drivers/scsi/aacraid.org/aacraid.h linux-5.3/drivers/scsi/aacraid/aacraid.h
+--- linux-5.3/drivers/scsi/aacraid.org/aacraid.h       2019-11-01 22:42:37.011469816 +0100
++++ linux-5.3/drivers/scsi/aacraid/aacraid.h   2019-11-04 09:29:51.321486211 +0100
+@@ -2740,17 +2740,6 @@
+ int aac_rx_deliver_producer(struct fib * fib);
+ void aac_reinit_aif(struct aac_dev *aac, unsigned int index);
+-static inline int aac_is_src(struct aac_dev *dev)
+-{
+-      u16 device = dev->pdev->device;
+-
+-      if (device == PMC_DEVICE_S6 ||
+-              device == PMC_DEVICE_S7 ||
+-              device == PMC_DEVICE_S8)
+-              return 1;
+-      return 0;
+-}
+-
+ static inline int aac_supports_2T(struct aac_dev *dev)
+ {
+       return (dev->adapter_info.options & AAC_OPT_NEW_COMM_64);
+diff -ur linux-5.3/drivers/scsi/aacraid.org/comminit.c linux-5.3/drivers/scsi/aacraid/comminit.c
+--- linux-5.3/drivers/scsi/aacraid.org/comminit.c      2019-11-01 22:42:37.014803249 +0100
++++ linux-5.3/drivers/scsi/aacraid/comminit.c  2019-11-04 09:29:51.321486211 +0100
+@@ -41,8 +41,11 @@
+ {
+       u32 status = 0;
+-      if (aac_is_src(dev))
++      if (dev->pdev->device == PMC_DEVICE_S6 ||
++              dev->pdev->device == PMC_DEVICE_S7 ||
++              dev->pdev->device == PMC_DEVICE_S8) {
+               status = src_readl(dev, MUnit.OMR);
++      }
+       return (status & AAC_INT_MODE_MSIX);
+ }
+@@ -349,7 +352,8 @@
+       /* FIB should be freed only after getting the response from the F/W */
+       if (status != -ERESTARTSYS)
+               aac_fib_free(fibctx);
+-      if (aac_is_src(dev) &&
++      if ((dev->pdev->device == PMC_DEVICE_S7 ||
++           dev->pdev->device == PMC_DEVICE_S8) &&
+            dev->msi_enabled)
+               aac_set_intx_mode(dev);
+       return status;
+@@ -610,7 +614,8 @@
+               dev->max_fib_size = status[1] & 0xFFE0;
+               host->sg_tablesize = status[2] >> 16;
+               dev->sg_tablesize = status[2] & 0xFFFF;
+-              if (aac_is_src(dev)) {
++              if (dev->pdev->device == PMC_DEVICE_S7 ||
++                  dev->pdev->device == PMC_DEVICE_S8) {
+                       if (host->can_queue > (status[3] >> 16) -
+                                       AAC_NUM_MGT_FIB)
+                               host->can_queue = (status[3] >> 16) -
+@@ -629,7 +634,9 @@
+                       pr_warn("numacb=%d ignored\n", numacb);
+       }
+-      if (aac_is_src(dev))
++      if (dev->pdev->device == PMC_DEVICE_S6 ||
++          dev->pdev->device == PMC_DEVICE_S7 ||
++          dev->pdev->device == PMC_DEVICE_S8)
+               aac_define_int_mode(dev);
+       /*
+        *      Ok now init the communication subsystem
+diff -ur linux-5.3/drivers/scsi/aacraid.org/commsup.c linux-5.3/drivers/scsi/aacraid/commsup.c
+--- linux-5.3/drivers/scsi/aacraid.org/commsup.c       2019-11-01 22:42:37.014803249 +0100
++++ linux-5.3/drivers/scsi/aacraid/commsup.c   2019-11-04 09:29:51.321486211 +0100
+@@ -2593,7 +2593,9 @@
+ {
+       int i;
+-      if (aac_is_src(dev)) {
++      if (dev->pdev->device == PMC_DEVICE_S6 ||
++          dev->pdev->device == PMC_DEVICE_S7 ||
++          dev->pdev->device == PMC_DEVICE_S8) {
+               if (dev->max_msix > 1) {
+                       for (i = 0; i < dev->max_msix; i++)
+                               free_irq(pci_irq_vector(dev->pdev, i),
+diff -ur linux-5.3/drivers/scsi/aacraid.org/linit.c linux-5.3/drivers/scsi/aacraid/linit.c
+--- linux-5.3/drivers/scsi/aacraid.org/linit.c 2019-11-01 22:42:37.011469816 +0100
++++ linux-5.3/drivers/scsi/aacraid/linit.c     2019-11-04 09:29:51.321486211 +0100
+@@ -1567,8 +1567,9 @@
+       aac_send_shutdown(aac);
+       aac_adapter_disable_int(aac);
+-
+-      if (aac_is_src(aac)) {
++      if (aac->pdev->device == PMC_DEVICE_S6 ||
++          aac->pdev->device == PMC_DEVICE_S7 ||
++          aac->pdev->device == PMC_DEVICE_S8) {
+               if (aac->max_msix > 1) {
+                       for (i = 0; i < aac->max_msix; i++) {
+                               free_irq(pci_irq_vector(aac->pdev, i),
+@@ -1858,7 +1859,8 @@
+       aac_adapter_enable_int(dev);
+-      if (aac_is_src(dev))
++      if (dev->pdev->device == PMC_DEVICE_S7 ||
++          dev->pdev->device == PMC_DEVICE_S8)
+               aac_define_int_mode(dev);
+       if (dev->msi_enabled)
index cf9e32a54f8dab884b3bea5b8026fd0017af6d4e..ad5dc31c7de699c8bd47734cae07bc37d5f2515b 100644 (file)
@@ -69,7 +69,7 @@
 
 %define                rel             1
 %define                basever         5.3
-%define                postver         .8
+%define                postver         .9
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       %{nil}
@@ -123,7 +123,7 @@ Source0:    https://www.kernel.org/pub/linux/kernel/v5.x/linux-%{basever}.tar.xz
 # Source0-md5: c99feaade8047339528fb066ec5f8a49
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v5.x/patch-%{version}.xz
-# Patch0-md5:  bc4fb6eff8cc62dafc097cb561a51729
+# Patch0-md5:  1285e9d40e694274668f1e3cf6f031b9
 %endif
 Source1:       kernel.sysconfig
 
This page took 0.102261 seconds and 4 git commands to generate.