]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- up to 3.14.24 auto/th/kernel-3.14-3.14.24-1
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 15 Nov 2014 17:44:41 +0000 (18:44 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 15 Nov 2014 17:44:41 +0000 (18:44 +0100)
- removed patches applied upstream

kernel-fbcon-margins.patch [deleted file]
kernel-small_fixes.patch
kernel-vserver-2.3.patch
kernel.spec

diff --git a/kernel-fbcon-margins.patch b/kernel-fbcon-margins.patch
deleted file mode 100644 (file)
index fd77379..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-This fixes "margin colour" (colour used to clear margins - e.g. a half of line
-at the bottom of 100x37 console on 800x600 framebuffer).
-
-I don't know what was the intention behind using attr_bgcol_ec() here, but it
-caused using of background colour of last erase character to clear margins -
-which definitely isn't what we want...
-This patch changes margin colour to black (or colour 0 in palette modes).
-
-       -- Jakub Bogusz <qboosh@pld-linux.org>
-
---- linux-2.6.9/drivers/video/console/bitblit.c.orig   2004-10-20 18:13:32.000000000 +0200
-+++ linux-2.6.9/drivers/video/console/bitblit.c        2004-10-20 18:22:35.153056112 +0200
-@@ -206,7 +206,6 @@
- static void bit_clear_margins(struct vc_data *vc, struct fb_info *info,
-                             int bottom_only)
- {
--      int bgshift = (vc->vc_hi_font_mask) ? 13 : 12;
-       unsigned int cw = vc->vc_font.width;
-       unsigned int ch = vc->vc_font.height;
-       unsigned int rw = info->var.xres - (vc->vc_cols*cw);
-@@ -215,7 +214,7 @@
-       unsigned int bs = info->var.yres - bh;
-       struct fb_fillrect region;
--      region.color = attr_bgcol_ec(bgshift, vc, info);
-+      region.color = 0;
-       region.rop = ROP_COPY;
-       if (rw && !bottom_only) {
index e40d6e56044d3bb35b3161743ca97ba41e061f81..5c0de9dc69173692d54668458550909557c8ebd4 100644 (file)
@@ -112,95 +112,3 @@ index 4e565c8..732648b 100644
        spin_lock_init(&group->fanotify_data.access_lock);
 -- 
 cgit v0.10.1
-commit 5ef828c4152726f56751c78ea844f08d2b2a4fa3
-Author: Eric Sandeen <sandeen@sandeen.net>
-Date:   Mon Aug 4 11:35:44 2014 +1000
-
-    xfs: avoid false quotacheck after unclean shutdown
-    
-    The commit
-    
-    83e782e xfs: Remove incore use of XFS_OQUOTA_ENFD and XFS_OQUOTA_CHKD
-    
-    added a new function xfs_sb_quota_from_disk() which swaps
-    on-disk XFS_OQUOTA_* flags for in-core XFS_GQUOTA_* and XFS_PQUOTA_*
-    flags after the superblock is read.
-    
-    However, if log recovery is required, the superblock is read again,
-    and the modified in-core flags are re-read from disk, so we have
-    XFS_OQUOTA_* flags in memory again.  This causes the
-    XFS_QM_NEED_QUOTACHECK() test to be true, because the XFS_OQUOTA_CHKD
-    is still set, and not XFS_GQUOTA_CHKD or XFS_PQUOTA_CHKD.
-    
-    Change xfs_sb_from_disk to call xfs_sb_quota_from disk and always
-    convert the disk flags to in-memory flags.
-    
-    Add a lower-level function which can be called with "false" to
-    not convert the flags, so that the sb verifier can verify
-    exactly what was on disk, per Brian Foster's suggestion.
-    
-    Reported-by: Cyril B. <cbay@excellency.fr>
-    Signed-off-by: Eric Sandeen <sandeen@redhat.com>
-
-diff --git a/fs/xfs/xfs_sb.c b/fs/xfs/xfs_sb.c
-index f5ca028..8db9e92 100644
---- a/fs/xfs/xfs_sb.c
-+++ b/fs/xfs//xfs_sb.c
-@@ -386,10 +386,11 @@ xfs_sb_quota_from_disk(struct xfs_sb *sbp)
-       }
- }
--void
--xfs_sb_from_disk(
-+static void
-+__xfs_sb_from_disk(
-       struct xfs_sb   *to,
--      xfs_dsb_t       *from)
-+      xfs_dsb_t       *from,
-+      bool            convert_xquota)
- {
-       to->sb_magicnum = be32_to_cpu(from->sb_magicnum);
-       to->sb_blocksize = be32_to_cpu(from->sb_blocksize);
-@@ -445,6 +446,17 @@ xfs_sb_from_disk(
-       to->sb_pad = 0;
-       to->sb_pquotino = be64_to_cpu(from->sb_pquotino);
-       to->sb_lsn = be64_to_cpu(from->sb_lsn);
-+      /* Convert on-disk flags to in-memory flags? */
-+      if (convert_xquota)
-+              xfs_sb_quota_from_disk(to);
-+}
-+
-+void
-+xfs_sb_from_disk(
-+      struct xfs_sb   *to,
-+      xfs_dsb_t       *from)
-+{
-+      __xfs_sb_from_disk(to, from, true);
- }
- static inline void
-@@ -560,7 +572,11 @@ xfs_sb_verify(
-       struct xfs_mount *mp = bp->b_target->bt_mount;
-       struct xfs_sb   sb;
--      xfs_sb_from_disk(&sb, XFS_BUF_TO_SBP(bp));
-+      /*
-+       * Use call variant which doesn't convert quota flags from disk 
-+       * format, because xfs_mount_validate_sb checks the on-disk flags.
-+       */
-+      __xfs_sb_from_disk(&sb, XFS_BUF_TO_SBP(bp), false);
-       /*
-        * Only check the in progress field for the primary superblock as
-diff --git a/fs/xfs/xfs_mount.c b/fs/xfs/xfs_mount.c
-index d5c44a6..5612aa8 100644
---- a/fs/xfs/xfs_mount.c
-+++ b/fs/xfs/xfs_mount.c
-@@ -324,7 +324,6 @@ reread:
-        * Initialize the mount structure from the superblock.
-        */
-       xfs_sb_from_disk(sbp, XFS_BUF_TO_SBP(bp));
--      xfs_sb_quota_from_disk(sbp);
-       /*
-        * If we haven't validated the superblock, do so now before we try
index 55966945b512a940efc48ac521168db7bb5f9f9f..ff3c537c05cf687d01d7feb718307bd4641b70fb 100644 (file)
@@ -1296,9 +1296,9 @@ diff -NurpP --minimal linux-3.14.17/drivers/net/tun.c linux-3.14.17-vs2.3.6.13/d
  #include <linux/virtio_net.h>
  #include <linux/rcupdate.h>
 +#include <linux/vs_network.h>
+ #include <net/ipv6.h>
  #include <net/net_namespace.h>
  #include <net/netns/generic.h>
- #include <net/rtnetlink.h>
 @@ -170,6 +171,7 @@ struct tun_struct {
        unsigned int            flags;
        kuid_t                  owner;
index 6b49ad9b29dfa587d067b81f6c159e6e1f5a6b2b..56b08987f4489fed959d2828cad4ca844f39b1d8 100644 (file)
@@ -70,7 +70,7 @@
 
 %define                rel             1
 %define                basever         3.14
-%define                postver         .23
+%define                postver         .24
 
 %define                versuffix       -%{basever}
 
@@ -115,7 +115,7 @@ Source0:    http://www.kernel.org/pub/linux/kernel/v3.x/linux-%{basever}.tar.xz
 # Source0-md5: b621207b3f6ecbb67db18b13258f8ea8
 %if "%{postver}" != ".0"
 Patch0:                http://www.kernel.org/pub/linux/kernel/v3.x/patch-%{version}.xz
-# Patch0-md5:  45a2b9fbe6c9075093fb015f818b4e37
+# Patch0-md5:  651a92fc1d45c02fa02358bb07e80697
 %endif
 Source1:       kernel.sysconfig
 
@@ -144,7 +144,6 @@ Source58:   kernel-inittmpfs.config
 
 # http://dev.gentoo.org/~spock/projects/fbcondecor/archive/fbcondecor-0.9.4-2.6.25-rc6.patch
 Patch3:                kernel-fbcondecor.patch
-Patch4:                kernel-fbcon-margins.patch
 Patch5:                linux-wistron-amilo8210.patch
 Patch6:                linux-wistron-nx.patch
 
@@ -660,7 +659,6 @@ cd linux-%{basever}
 %if %{with fbcondecor}
 %patch3 -p1
 %endif
-%patch4 -p1
 %patch5 -p1
 %patch6 -p1
 
This page took 0.10093 seconds and 4 git commands to generate.