]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
- up to 5.11.11
[packages/kernel.git] / kernel.spec
index 82cbfa08cb7a3e49210fde2ca3e0761ab10e17bf..f834efc6823348fa6c27c03982b6286c7f86c6fc 100644 (file)
@@ -71,9 +71,9 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             0.1
-%define                basever         5.8
-%define                postver         .0
+%define                rel             1
+%define                basever         5.11
+%define                postver         .11
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       %{nil}
@@ -124,10 +124,10 @@ Epoch:            3
 License:       GPL v2
 Group:         Base/Kernel
 Source0:       https://www.kernel.org/pub/linux/kernel/v5.x/linux-%{basever}.tar.xz
-# Source0-md5: 0e5c4c15266218ef26c50fac0016095b
+# Source0-md5: d2985a3f16ef1ea3405c04c406e29dcc
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v5.x/patch-%{version}.xz
-# Patch0-md5:  a2824a09c83af1bacb337288a41c80d9
+# Patch0-md5:  f6ed67b110711d1814521f6b9f200179
 %endif
 Source1:       kernel.sysconfig
 
@@ -197,16 +197,7 @@ Patch85:   kernel-hostap.patch
 Patch100:      kernel-vserver-2.3.patch
 Patch101:      kernel-vserver-fixes.patch
 
-# git://github.com/sfjro/aufs5-standalone.git, read README
-# Patch creation:
-# git clone git://github.com/sfjro/aufs5-standalone.git
-# cd aufs5-standalone
-# git checkout -b aufs5.8 origin/aufs5.8
-# cat aufs5-kbuild.patch aufs5-base.patch aufs5-mmap.patch aufs5-standalone.patch > ~/rpm/packages/kernel/kernel-aufs5.patch
-# rm -rf linux && mkdir linux; cp -a Documentation fs include linux
-# diff -urN /usr/share/empty linux | filterdiff -x linux/include/uapi/linux/Kbuild >> ~/rpm/packages/kernel/kernel-aufs5.patch
-# cat aufs5-loopback.patch >> ~/rpm/packages/kernel/kernel-aufs5.patch
-#
+# see update-source.sh
 Patch145:      kernel-aufs5.patch
 Patch146:      kernel-aufs+vserver.patch
 
@@ -220,12 +211,16 @@ Patch500: kernel-rt.patch
 Patch2000:     kernel-small_fixes.patch
 Patch2001:     kernel-pwc-uncompress.patch
 Patch2003:     kernel-regressions.patch
-Patch2004:     xfs-reclaim-hack.patch
 
 # for rescuecd
 # based on ftp://ftp.leg.uct.ac.za/pub/linux/rip/tmpfs_root-2.6.30.diff.gz
 Patch7000:     kernel-inittmpfs.patch
 
+# ARM only
+Patch8000:     rpi-wm8804.patch
+Patch8001:     kernel-pinebook-pro.patch
+Patch8002:     kernel-rk3399-afbc-ytr.patch
+
 # Do not remove this line, please. It is easier for me to uncomment two lines, then patch
 # kernel.spec every time.
 #Patch50000:   kernel-usb_reset.patch
@@ -248,9 +243,11 @@ BuildRequires:     hostname
 BuildRequires: kmod >= %{kmod_ver}
 BuildRequires: libstdc++-devel
 BuildRequires: openssl-devel
+BuildRequires: openssl-tools
 BuildRequires: perl-base
 BuildRequires: rpm-build >= 4.5-24
-BuildRequires: rpmbuild(macros) >= 1.743
+BuildRequires: rpmbuild(macros) >= 1.752
+BuildRequires: tar >= 1:1.22
 %ifarch ppc
 BuildRequires: uboot-mkimage
 %endif
@@ -293,6 +290,7 @@ Obsoletes:  kernel-smp
 Conflicts:     e2fsprogs < 1.29
 Conflicts:     isdn4k-utils < 3.1pre1
 Conflicts:     jfsutils < 1.1.3
+Conflicts:     libcap-libs < 1:2.34
 Conflicts:     libusb < 1.0.9
 Conflicts:     linux-firmware < 20120720
 Conflicts:     lvm2 < 2.02.40
@@ -454,6 +452,7 @@ Summary(pl.UTF-8):  Sterowniki DRM
 Group:         Base/Kernel
 Requires(postun):      %{name} = %{epoch}:%{version}-%{release}
 Requires:      %{name} = %{epoch}:%{version}-%{release}
+Provides:      kernel(vboxvideo) = %{kernel_release}
 Obsoletes:     kernel-smp-drm
 AutoReqProv:   no
 
@@ -576,9 +575,7 @@ Summary(pl.UTF-8):  Kod źródłowy jądra Linuksa
 Group:         Development/Building
 Requires:      %{name}-module-build = %{epoch}:%{version}-%{release}
 AutoReqProv:   no
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description source
 This is the source code for the Linux kernel. You can build a custom
@@ -609,9 +606,7 @@ Summary(de.UTF-8):  Kernel Dokumentation
 Summary(pl.UTF-8):     Dokumentacja do jądra Linuksa
 Group:         Documentation
 AutoReqProv:   no
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description doc
 This is the documentation for the Linux kernel, as found in
@@ -690,6 +685,12 @@ cd linux-%{basever}
 %patch7000 -p1
 %endif
 
+%ifarch %{arm} aarch64
+%patch8000 -p1
+%patch8001 -p1
+%patch8002 -p1
+%endif
+
 %if %{with rt}
 %patch500 -p1
 rm -f localversion-rt
@@ -703,7 +704,6 @@ rm -f localversion-rt
 %patch2000 -p1
 %patch2001 -p1
 #%patch2003 -p1
-%patch2004 -p1
 
 # Do not remove this, please!
 #%%patch50000 -p1
@@ -717,13 +717,13 @@ sed -i 's#EXTRAVERSION =.*#EXTRAVERSION = %{?alt_kernel:.%{alt_kernel}}#g' Makef
 find '(' -name '*~' -o -name '*.orig' -o -name '.gitignore' ')' -print0 | xargs -0 -r -l512 rm -f
 
 find -name '*.py' -print0 | \
-       xargs -0 %{__sed} -i -e '1s,/usr/bin/python,%{__python},' \
-                            -e '1s,/usr/bin/env python,%{__python},' \
-                            -e '1s,/usr/bin/env python3,%{__python3},'
+       xargs -0 %{__sed} -i -e '1s,/usr/bin/python$,%{__python},' \
+                            -e '1s,/usr/bin/env python$,%{__python},' \
+                            -e '1s,/usr/bin/env python3$,%{__python3},'
 
-%{__sed} -i -e '1s,/usr/bin/python,%{__python},' \
-           -e '1s,/usr/bin/env python,%{__python},' \
-           -e '1s,/usr/bin/env python3,%{__python3},' \
+%{__sed} -i -e '1s,/usr/bin/python$,%{__python},' \
+           -e '1s,/usr/bin/env python$,%{__python},' \
+           -e '1s,/usr/bin/env python3$,%{__python3},' \
        drivers/staging/greybus/tools/lbtest \
        scripts/bloat-o-meter \
        scripts/diffconfig \
@@ -743,8 +743,12 @@ find -name '*.pl' -print0 | \
        scripts/documentation-file-ref-check \
        scripts/get_dvb_firmware \
        scripts/kernel-doc \
+       scripts/sphinx-pre-install \
        scripts/stackdelta
 
+%{__sed} -i -e '1s,/usr/bin/env bash,%{__bash},' \
+       scripts/config
+
 %build
 install -d %{objdir}
 cat > %{targetobj}.mk <<'EOF'
@@ -903,6 +907,10 @@ BuildConfig() {
                CONFIG_NFS_FS=y
                CONFIG_ROOT_NFS=y
 %endif
+
+%ifarch x32
+               CONFIG_BPF_PRELOAD=n
+%endif
 EOCONFIG
 
 %if %{with rescuecd}
@@ -1465,7 +1473,6 @@ fi
 %{_kernelsrcdir}/scripts/mod/modpost.h
 %attr(755,root,root) %{_kernelsrcdir}/scripts/mkcompile_h
 %{_kernelsrcdir}/scripts/mkmakefile
-%{_kernelsrcdir}/scripts/module-common.lds
 %attr(755,root,root) %{_kernelsrcdir}/scripts/setlocalversion
 %{_kernelsrcdir}/scripts/subarch.include
 %{_kernelsrcdir}/scripts/*.c
@@ -1486,7 +1493,6 @@ fi
 %dir %{_docdir}/%{name}-%{version}
 
 %{_docdir}/%{name}-%{version}/[!jkz]*
-%{_docdir}/%{name}-%{version}/[jkz]*.txt
 %{_docdir}/%{name}-%{version}/kbuild
 %{_docdir}/%{name}-%{version}/kernel-hacking
 %endif
@@ -1536,7 +1542,6 @@ fi
 %exclude %{_kernelsrcdir}/scripts/mkcompile_h
 %exclude %{_kernelsrcdir}/scripts/mkmakefile
 %exclude %{_kernelsrcdir}/scripts/mod
-%exclude %{_kernelsrcdir}/scripts/module-common.lds
 %exclude %{_kernelsrcdir}/scripts/setlocalversion
 %exclude %{_kernelsrcdir}/scripts/subarch.include
 %exclude %{_kernelsrcdir}/scripts/*.c
This page took 0.150949 seconds and 4 git commands to generate.