]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
- 3.14.63
[packages/kernel.git] / kernel.spec
index 70771543cf9dfb461deb1d0bba9725d6c2627e46..ed84f43bfbdc8c674c9be4ec8a7a084b92da139b 100644 (file)
@@ -28,7 +28,7 @@
 %bcond_without imq             # imq support
 %bcond_without esfq            # esfq support
 %bcond_without ipv6            # ipv6 support
-%bcond_without padmcrypt       # parallel dm-crypt
+%bcond_with    padmcrypt       # parallel dm-crypt
 
 %bcond_without vserver         # support for VServer
 
@@ -39,6 +39,7 @@
 %{?debug:%define with_verbose 1}
 
 %define                have_drm        1
+%define                have_ide        1
 %define                have_oss        1
 %define                have_sound      1
 %define                have_pcmcia     1
@@ -51,6 +52,7 @@
 
 %if %{with myown}
 %define                have_drm        0
+%define                have_ide        0
 %define                have_oss        0
 %define                have_sound      0
 %define                have_pcmcia     0
 %endif
 
 %define                rel             1
-%define                basever         3.13
-%define                postver         .6
+%define                basever         3.14
+%define                postver         .63
 
-# define this to '-%{basever}' for longterm branch
-%define                versuffix       %{nil}
+%define                versuffix       -%{basever}
 
 # __alt_kernel is list of features, empty string if none set
 # _alt kernel is defined as: %{nil}%{?alt_kernel:-%{?alt_kernel}} (defined in rpm.macros)
@@ -111,10 +112,10 @@ Epoch:            3
 License:       GPL v2
 Group:         Base/Kernel
 Source0:       http://www.kernel.org/pub/linux/kernel/v3.x/linux-%{basever}.tar.xz
-# Source0-md5: 0ecbaf65c00374eb4a826c2f9f37606f
+# Source0-md5: b621207b3f6ecbb67db18b13258f8ea8
 %if "%{postver}" != ".0"
 Patch0:                http://www.kernel.org/pub/linux/kernel/v3.x/patch-%{version}.xz
-# Patch0-md5:  a9b131a589a176b4c437b8ca4557b85e
+# Patch0-md5:  0a339395e7c1c42a050f799c1946ba35
 %endif
 Source1:       kernel.sysconfig
 
@@ -143,7 +144,6 @@ Source58:   kernel-inittmpfs.config
 
 # http://dev.gentoo.org/~spock/projects/fbcondecor/archive/fbcondecor-0.9.4-2.6.25-rc6.patch
 Patch3:                kernel-fbcondecor.patch
-Patch4:                kernel-fbcon-margins.patch
 Patch5:                linux-wistron-amilo8210.patch
 Patch6:                linux-wistron-nx.patch
 
@@ -183,10 +183,8 @@ Patch59:   kernel-rndis_host-wm5.patch
 # http://patches.aircrack-ng.org/hostap-kernel-2.6.18.patch
 Patch85:       kernel-hostap.patch
 
-# http://www.linuxtv.org/wiki/index.php/TechniSat_CableStar_Combo_HD_CI#Patch
-Patch90:       kernel-technisat-combo-hd-ci.patch
-
-# http://vserver.13thfloor.at/Experimental/patch-3.13.1-vs2.3.6.10.diff
+%define        vserver_patch 3.10.9-vs2.3.6.6
+# http://vserver.13thfloor.at/Experimental/patch-3.13.6-vs2.3.6.11.diff
 # note there are additional patches from above url:
 # - *fix* are real fixes (we want these)
 # - *feat* are new features/tests (we don't want these)
@@ -209,12 +207,13 @@ Patch118: ovl09-fs-limit-filesystem-stacking-depth.patch
 # Patch creation:
 # git clone git://aufs.git.sourceforge.net/gitroot/aufs/aufs3-standalone.git
 # cd aufs3-standalone
-# git checkout -b aufs3.13 origin/aufs3.13
-# cat aufs3-kbuild.patch aufs3-base.patch aufs3-standalone.patch > ~/rpm/packages/kernel/kernel-aufs3.patch
+# git checkout -b aufs3.14 origin/aufs3.14
+# cat aufs3-kbuild.patch aufs3-base.patch aufs3-mmap.patch aufs3-standalone.patch > ~/rpm/packages/kernel/kernel-aufs3.patch
 # mkdir linux
 # cp -a Documentation fs include linux
 # diff -urN /usr/share/empty linux >> ~/rpm/packages/kernel/kernel-aufs3.patch
 # drop hunk at the end of patch (hunk is patching include/linux/Kbuild with single line change)
+# cat aufs3-loopback.patch >> ~/rpm/packages/kernel/kernel-aufs3.patch
 #
 Patch145:      kernel-aufs3.patch
 Patch146:      kernel-aufs3+vserver.patch
@@ -227,11 +226,14 @@ Patch400: kernel-virtio-gl-accel.patch
 
 # http://people.redhat.com/mpatocka/patches/kernel/dm-crypt-paralelizace/current/series.html
 Patch500:      dm-crypt-remove-percpu.patch
-Patch501:      dm-crypt-unbound-workqueue.patch
-Patch502:      dm-crypt-dont-allocate-partial-pages.patch
-Patch503:      dm-crypt-fix-allocation-deadlock.patch
-Patch504:      dm-crypt-offload-writes-to-thread.patch
-Patch505:      dm-crypt-sort-requests.patch
+Patch501:      bio-kmalloc-align.patch
+Patch502:      dm-crypt-per_bio_data.patch
+Patch503:      dm-crypt-unbound-workqueue.patch
+Patch504:      dm-crypt-dont-allocate-partial-pages.patch
+Patch505:      dm-crypt-fix-allocation-deadlock.patch
+Patch506:      dm-crypt-remove-io-pool.patch
+Patch507:      dm-crypt-offload-writes-to-thread.patch
+Patch508:      dm-crypt-sort-requests.patch
 
 Patch2000:     kernel-small_fixes.patch
 Patch2001:     kernel-pwc-uncompress.patch
@@ -282,6 +284,7 @@ Requires:   cpuinfo(pae)
 Suggests:      crda
 Suggests:      dracut
 Suggests:      keyutils
+Suggests:      kernel%{versuffix}-ide = %{epoch}:%{version}-%{release}
 Suggests:      linux-firmware
 Provides:      %{name}(netfilter) = 20070806
 Provides:      %{name}(vermagic) = %{kernel_release}
@@ -320,11 +323,11 @@ Conflicts:        udev < 1:081
 Conflicts:     util-linux < 2.10o
 Conflicts:     util-vserver < 0.30.216
 Conflicts:     xfsprogs < 2.6.0
-ExclusiveArch: i486 i586 i686 pentium3 pentium4 athlon %{x8664} alpha arm ia64 ppc ppc64 sparc sparc64
+ExclusiveArch: i486 i586 i686 pentium3 pentium4 athlon %{x8664} x32 alpha arm ia64 ppc ppc64 sparc sparc64
 ExclusiveOS:   Linux
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%ifarch %{ix86} %{x8664}
+%ifarch %{ix86} %{x8664} x32
 %define                target_arch_dir         x86
 %endif
 %ifarch ppc ppc64
@@ -333,7 +336,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %ifarch sparc sparc64
 %define                target_arch_dir         sparc
 %endif
-%ifnarch %{ix86} %{x8664} ppc ppc64 sparc sparc64
+%ifnarch %{ix86} %{x8664} x32 ppc ppc64 sparc sparc64
 %define                target_arch_dir         %{_target_base_arch}
 %endif
 
@@ -395,6 +398,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %{!?with_vserver:WARNING: VSERVER IS DISABLED IN THIS KERNEL BUILD!}\
 %{?with_fbcondecor:Fbsplash/fbcondecor - enabled }\
 %{?with_nfsroot:Root on NFS - enabled}\
+%{?with_vserver:Linux-VServer - %{vserver_patch}}\
 
 %define Features %(echo "%{__features}" | sed '/^$/d')
 
@@ -463,6 +467,24 @@ DRM Kernel Treiber.
 %description drm -l pl.UTF-8
 Sterowniki DRM.
 
+%package ide
+Summary:       IDE kernel modules
+Summary(de.UTF-8):     IDE Kernel Treiber
+Summary(pl.UTF-8):     Sterowniki IDE
+Group:         Base/Kernel
+Requires(postun):      %{name} = %{epoch}:%{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+AutoReqProv:   no
+
+%description ide
+IDE kernel modules.
+
+%description ide -l de.UTF-8
+IDE Kernel Treiber.
+
+%description ide -l pl.UTF-8
+Sterowniki IDE.
+
 %package pcmcia
 Summary:       PCMCIA modules
 Summary(de.UTF-8):     PCMCIA Module
@@ -637,7 +659,6 @@ cd linux-%{basever}
 %if %{with fbcondecor}
 %patch3 -p1
 %endif
-%patch4 -p1
 %patch5 -p1
 %patch6 -p1
 
@@ -679,9 +700,6 @@ cd linux-%{basever}
 # hostap enhancements from/for aircrack-ng
 %patch85 -p1
 
-# TechniSat_CableStar_Combo_HD_CI
-%patch90 -p1
-
 # vserver
 %if %{with vserver}
 %patch100 -p1
@@ -724,6 +742,9 @@ cd linux-%{basever}
 %patch503 -p1
 %patch504 -p1
 %patch505 -p1
+%patch506 -p1
+%patch507 -p1
+%patch508 -p1
 %endif
 
 %endif # vanilla
@@ -984,7 +1005,7 @@ done
 install -d $RPM_BUILD_ROOT/boot
 cp -a %{objdir}/System.map $RPM_BUILD_ROOT/boot/System.map-%{kernel_release}
 cp -aL %{objdir}/.config $RPM_BUILD_ROOT/boot/config-%{kernel_release}
-%ifarch %{ix86} %{x8664}
+%ifarch %{ix86} %{x8664} x32
        cp -a %{objdir}/arch/%{target_arch_dir}/boot/bzImage $RPM_BUILD_ROOT/boot/vmlinuz-%{kernel_release}
        install -p %{objdir}/vmlinux $RPM_BUILD_ROOT/boot/vmlinux-%{kernel_release}
 %endif
@@ -1161,7 +1182,7 @@ if [ -x /sbin/update-grub -a -f /etc/sysconfig/grub ]; then
        fi
 fi
 if [ -x /sbin/new-kernel-pkg ]; then
-       /sbin/new-kernel-pkg --initrdfile=%{initrd_dir}/initrd-%{kernel_release}.gz --install %{kernel_release} --banner "PLD Linux (%{pld_release})%{?alt_kernel: / %{alt_kernel}}"
+       /sbin/new-kernel-pkg --initrdfile=%{initrd_dir}/$initrd_file --install %{kernel_release} --banner "PLD Linux (%{pld_release})%{?alt_kernel: / %{alt_kernel}}"
 fi
 if [ -x /sbin/rc-boot ]; then
        /sbin/rc-boot 1>&2 || :
@@ -1187,6 +1208,12 @@ fi
 %postun drm
 %depmod %{kernel_release}
 
+%post ide
+%depmod %{kernel_release}
+
+%postun ide
+%depmod %{kernel_release}
+
 %post pcmcia
 %depmod %{kernel_release}
 
@@ -1250,6 +1277,9 @@ fi
 %if %{have_drm}
 %exclude /lib/modules/%{kernel_release}/kernel/drivers/gpu
 %endif
+%if %{have_ide}
+%exclude /lib/modules/%{kernel_release}/kernel/drivers/ide/*
+%endif
 /lib/modules/%{kernel_release}/kernel/fs
 /lib/modules/%{kernel_release}/kernel/kernel
 /lib/modules/%{kernel_release}/kernel/lib
@@ -1311,7 +1341,7 @@ fi
 %ghost /lib/modules/%{kernel_release}/build
 %ghost /lib/modules/%{kernel_release}/source
 
-%ifarch alpha %{ix86} %{x8664} ppc ppc64 sparc sparc64
+%ifarch alpha %{ix86} %{x8664} x32 ppc ppc64 sparc sparc64
 %files vmlinux
 %defattr(644,root,root,755)
 /boot/vmlinux-%{kernel_release}
@@ -1323,6 +1353,15 @@ fi
 /lib/modules/%{kernel_release}/kernel/drivers/gpu
 %endif
 
+%if %{have_ide}
+%files ide
+%defattr(644,root,root,755)
+/lib/modules/%{kernel_release}/kernel/drivers/ide/*
+%if %{have_pcmcia}
+%exclude /lib/modules/%{kernel_release}/kernel/drivers/ide/ide-cs.ko*
+%endif
+%endif
+
 %if %{have_pcmcia}
 %files pcmcia
 %defattr(644,root,root,755)
@@ -1416,6 +1455,7 @@ fi
 %{_kernelsrcdir}/scripts/module-common.lds
 %attr(755,root,root) %{_kernelsrcdir}/scripts/setlocalversion
 %{_kernelsrcdir}/scripts/*.c
+%{_kernelsrcdir}/scripts/*.h
 %attr(755,root,root) %{_kernelsrcdir}/scripts/*.sh
 %{_kernelsrcdir}/scripts/selinux/genheaders/*.c
 %{_kernelsrcdir}/scripts/selinux/mdp/*.c
@@ -1486,6 +1526,7 @@ fi
 %exclude %{_kernelsrcdir}/scripts/module-common.lds
 %exclude %{_kernelsrcdir}/scripts/setlocalversion
 %exclude %{_kernelsrcdir}/scripts/*.c
+%exclude %{_kernelsrcdir}/scripts/*.h
 %exclude %{_kernelsrcdir}/scripts/*.sh
 %exclude %dir %{_kernelsrcdir}/scripts/selinux
 %exclude %{_kernelsrcdir}/scripts/selinux/Makefile
This page took 0.044262 seconds and 4 git commands to generate.