]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
package /etc/depmod.d/%{kernel_release}
[packages/kernel.git] / kernel.spec
index 2a9cafcd048a37fc2c8f42c7c1d668ba4d2c70fc..d26dfff90630cca0b3d87591d16f3e9285ab19f5 100644 (file)
@@ -29,7 +29,6 @@
 %bcond_without ipv6            # ipv6 support
 
 %bcond_without aufs            # aufs4 support
-%bcond_without apparmor        # UBUNTU SAUCE apparmor patches
 
 %bcond_with    vserver         # support for VServer
 
@@ -68,9 +67,9 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             0.1
-%define                basever         4.16
-%define                postver         .3
+%define                rel             1
+%define                basever         5.0
+%define                postver         .4
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       %{nil}
@@ -118,11 +117,11 @@ Release:  %{rel}
 Epoch:         3
 License:       GPL v2
 Group:         Base/Kernel
-Source0:       https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
-# Source0-md5: 1357fb4ee7c288fdeac5d4e0048f5c18
+Source0:       https://www.kernel.org/pub/linux/kernel/v5.x/linux-%{basever}.tar.xz
+# Source0-md5: 7381ce8aac80a01448e065ce795c19c0
 %if "%{postver}" != ".0"
-Patch0:                https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  c52a532ca7b18a3058ac85c98d67f1e4
+Patch0:                https://www.kernel.org/pub/linux/kernel/v5.x/patch-%{version}.xz
+# Patch0-md5:  195ebc16dd961271f18abbce42a0d8cb
 %endif
 Source1:       kernel.sysconfig
 
@@ -196,7 +195,7 @@ Patch101:   kernel-vserver-fixes.patch
 # Patch creation:
 # git clone git://github.com/sfjro/aufs4-standalone.git
 # cd aufs4-standalone
-# git checkout -b aufs4.14 origin/aufs4.14
+# git checkout -b aufs4.17 origin/aufs4.17
 # cat aufs4-kbuild.patch aufs4-base.patch aufs4-mmap.patch aufs4-standalone.patch > ~/rpm/packages/kernel/kernel-aufs4.patch
 # rm -rf linux && mkdir linux; cp -a Documentation fs include linux
 # diff -urN /usr/share/empty linux | filterdiff -x linux/include/uapi/linux/Kbuild >> ~/rpm/packages/kernel/kernel-aufs4.patch
@@ -215,10 +214,7 @@ Patch500:  kernel-rt.patch
 Patch2000:     kernel-small_fixes.patch
 Patch2001:     kernel-pwc-uncompress.patch
 Patch2003:     kernel-regressions.patch
-
-# https://gitlab.com/apparmor/apparmor/tree/master/kernel-patches/v4.15
-Patch5001:     0001-apparmor-add-base-infastructure-for-socket-mediation.patch
-Patch5002:     0002-apparmor-af_unix-mediation.patch
+Patch2004:     xfs-reclaim-hack.patch
 
 # for rescuecd
 # based on ftp://ftp.leg.uct.ac.za/pub/linux/rip/tmpfs_root-2.6.30.diff.gz
@@ -250,11 +246,11 @@ BuildRequires:    uboot-mkimage
 %endif
 BuildRequires: xz >= 1:4.999.7
 Requires(post):        coreutils
-Requires(post):        geninitrd >= 12749
+Requires(post):        geninitrd >= 12757-8
 Requires(post):        kmod >= 12-2
 Requires:      /sbin/depmod
 Requires:      coreutils
-Requires:      geninitrd >= 12749
+Requires:      geninitrd >= 12757-8
 Requires:      kmod >= 12-2
 %if %{with pae}
 %ifarch i686 athlon pentium3 pentium4
@@ -682,12 +678,6 @@ cd linux-%{basever}
 rm -f localversion-rt
 %endif
 
-# apparmor
-%if %{with apparmor}
-%patch5001 -p1
-%patch5002 -p1
-%endif
-
 %patch250 -p1
 
 %endif # vanilla
@@ -696,6 +686,7 @@ rm -f localversion-rt
 %patch2000 -p1
 %patch2001 -p1
 #%patch2003 -p1
+%patch2004 -p1
 
 # Do not remove this, please!
 #%%patch50000 -p1
@@ -990,8 +981,8 @@ touch $RPM_BUILD_ROOT%{initrd_dir}/initramfs-%{kernel_release}.img
 touch $RPM_BUILD_ROOT/lib/modules/%{kernel_release}/modules.dep
 %endif
 
-# /etc/modrobe.d
-install -d $RPM_BUILD_ROOT%{_sysconfdir}/modprobe.d/%{kernel_release}
+# /etc/depmod.d /etc/modrobe.d
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/{depmod.d,modprobe.d}/%{kernel_release}
 
 install -d $RPM_BUILD_ROOT/etc/sysconfig
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/kernel
@@ -1282,6 +1273,7 @@ fi
 /lib/modules/%{kernel_release}/kernel/security
 /lib/modules/%{kernel_release}/kernel/virt
 
+%dir %{_sysconfdir}/depmod.d/%{kernel_release}
 %dir %{_sysconfdir}/modprobe.d/%{kernel_release}
 
 # provided by build
@@ -1397,7 +1389,6 @@ fi
 %{_kernelsrcdir}/kernel/bounds.c
 %{_kernelsrcdir}/scripts/basic/*.c
 %attr(755,root,root) %{_kernelsrcdir}/scripts/kconfig/*.sh
-%{_kernelsrcdir}/scripts/kconfig/*.in
 %{_kernelsrcdir}/scripts/kconfig/*.pl
 %{_kernelsrcdir}/scripts/kconfig/*.glade
 %{_kernelsrcdir}/scripts/kconfig/*.cc
@@ -1415,6 +1406,7 @@ fi
 %{_kernelsrcdir}/scripts/mkmakefile
 %{_kernelsrcdir}/scripts/module-common.lds
 %attr(755,root,root) %{_kernelsrcdir}/scripts/setlocalversion
+%{_kernelsrcdir}/scripts/subarch.include
 %{_kernelsrcdir}/scripts/*.c
 %{_kernelsrcdir}/scripts/*.h
 %attr(755,root,root) %{_kernelsrcdir}/scripts/*.sh
@@ -1487,6 +1479,7 @@ fi
 %exclude %{_kernelsrcdir}/scripts/mod
 %exclude %{_kernelsrcdir}/scripts/module-common.lds
 %exclude %{_kernelsrcdir}/scripts/setlocalversion
+%exclude %{_kernelsrcdir}/scripts/subarch.include
 %exclude %{_kernelsrcdir}/scripts/*.c
 %exclude %{_kernelsrcdir}/scripts/*.h
 %exclude %{_kernelsrcdir}/scripts/*.sh
This page took 0.04003 seconds and 4 git commands to generate.