]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
- 3.14.15
[packages/kernel.git] / kernel.spec
index 55f812898543f56b4adf59ca6907ca0c8c09f4cb..ce24d210f10843197dad6c1680f0fb33ca89fbf4 100644 (file)
@@ -28,7 +28,7 @@
 %bcond_without imq             # imq support
 %bcond_without esfq            # esfq support
 %bcond_without ipv6            # ipv6 support
-%bcond_without padmcrypt       # parallel dm-crypt
+%bcond_with    padmcrypt       # parallel dm-crypt
 
 %bcond_without vserver         # support for VServer
 
@@ -39,6 +39,7 @@
 %{?debug:%define with_verbose 1}
 
 %define                have_drm        1
+%define                have_ide        1
 %define                have_oss        1
 %define                have_sound      1
 %define                have_pcmcia     1
@@ -51,6 +52,7 @@
 
 %if %{with myown}
 %define                have_drm        0
+%define                have_ide        0
 %define                have_oss        0
 %define                have_sound      0
 %define                have_pcmcia     0
 %endif
 
 %define                rel             1
-%define                basever         3.13
-%define                postver         .5
+%define                basever         3.14
+%define                postver         .15
 
-# define this to '-%{basever}' for longterm branch
-%define                versuffix       %{nil}
+%define                versuffix       -%{basever}
 
 # __alt_kernel is list of features, empty string if none set
 # _alt kernel is defined as: %{nil}%{?alt_kernel:-%{?alt_kernel}} (defined in rpm.macros)
@@ -111,10 +112,10 @@ Epoch:            3
 License:       GPL v2
 Group:         Base/Kernel
 Source0:       http://www.kernel.org/pub/linux/kernel/v3.x/linux-%{basever}.tar.xz
-# Source0-md5: 0ecbaf65c00374eb4a826c2f9f37606f
+# Source0-md5: b621207b3f6ecbb67db18b13258f8ea8
 %if "%{postver}" != ".0"
 Patch0:                http://www.kernel.org/pub/linux/kernel/v3.x/patch-%{version}.xz
-# Patch0-md5:  114c391a592131f1c12544e063173a45
+# Patch0-md5:  497579393986bb76e08abc355e59550c
 %endif
 Source1:       kernel.sysconfig
 
@@ -183,10 +184,7 @@ Patch59:   kernel-rndis_host-wm5.patch
 # http://patches.aircrack-ng.org/hostap-kernel-2.6.18.patch
 Patch85:       kernel-hostap.patch
 
-# http://www.linuxtv.org/wiki/index.php/TechniSat_CableStar_Combo_HD_CI#Patch
-Patch90:       kernel-technisat-combo-hd-ci.patch
-
-# http://vserver.13thfloor.at/Experimental/patch-3.13.1-vs2.3.6.10.diff
+# http://vserver.13thfloor.at/Experimental/patch-3.13.6-vs2.3.6.11.diff
 # note there are additional patches from above url:
 # - *fix* are real fixes (we want these)
 # - *feat* are new features/tests (we don't want these)
@@ -209,12 +207,13 @@ Patch118: ovl09-fs-limit-filesystem-stacking-depth.patch
 # Patch creation:
 # git clone git://aufs.git.sourceforge.net/gitroot/aufs/aufs3-standalone.git
 # cd aufs3-standalone
-# git checkout -b aufs3.13 origin/aufs3.13
-# cat aufs3-kbuild.patch aufs3-base.patch aufs3-standalone.patch > ~/rpm/packages/kernel/kernel-aufs3.patch
+# git checkout -b aufs3.14 origin/aufs3.14
+# cat aufs3-kbuild.patch aufs3-base.patch aufs3-mmap.patch aufs3-standalone.patch > ~/rpm/packages/kernel/kernel-aufs3.patch
 # mkdir linux
 # cp -a Documentation fs include linux
 # diff -urN /usr/share/empty linux >> ~/rpm/packages/kernel/kernel-aufs3.patch
 # drop hunk at the end of patch (hunk is patching include/linux/Kbuild with single line change)
+# cat aufs3-loopback.patch >> ~/rpm/packages/kernel/kernel-aufs3.patch
 #
 Patch145:      kernel-aufs3.patch
 Patch146:      kernel-aufs3+vserver.patch
@@ -227,11 +226,14 @@ Patch400: kernel-virtio-gl-accel.patch
 
 # http://people.redhat.com/mpatocka/patches/kernel/dm-crypt-paralelizace/current/series.html
 Patch500:      dm-crypt-remove-percpu.patch
-Patch501:      dm-crypt-unbound-workqueue.patch
-Patch502:      dm-crypt-dont-allocate-partial-pages.patch
-Patch503:      dm-crypt-fix-allocation-deadlock.patch
-Patch504:      dm-crypt-offload-writes-to-thread.patch
-Patch505:      dm-crypt-sort-requests.patch
+Patch501:      bio-kmalloc-align.patch
+Patch502:      dm-crypt-per_bio_data.patch
+Patch503:      dm-crypt-unbound-workqueue.patch
+Patch504:      dm-crypt-dont-allocate-partial-pages.patch
+Patch505:      dm-crypt-fix-allocation-deadlock.patch
+Patch506:      dm-crypt-remove-io-pool.patch
+Patch507:      dm-crypt-offload-writes-to-thread.patch
+Patch508:      dm-crypt-sort-requests.patch
 
 Patch2000:     kernel-small_fixes.patch
 Patch2001:     kernel-pwc-uncompress.patch
@@ -282,6 +284,7 @@ Requires:   cpuinfo(pae)
 Suggests:      crda
 Suggests:      dracut
 Suggests:      keyutils
+Suggests:      kernel%{versuffix}-ide = %{epoch}:%{version}-%{release}
 Suggests:      linux-firmware
 Provides:      %{name}(netfilter) = 20070806
 Provides:      %{name}(vermagic) = %{kernel_release}
@@ -463,6 +466,24 @@ DRM Kernel Treiber.
 %description drm -l pl.UTF-8
 Sterowniki DRM.
 
+%package ide
+Summary:       IDE kernel modules
+Summary(de.UTF-8):     IDE Kernel Treiber
+Summary(pl.UTF-8):     Sterowniki IDE
+Group:         Base/Kernel
+Requires(postun):      %{name} = %{epoch}:%{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+AutoReqProv:   no
+
+%description ide
+IDE kernel modules.
+
+%description ide -l de.UTF-8
+IDE Kernel Treiber.
+
+%description ide -l pl.UTF-8
+Sterowniki IDE.
+
 %package pcmcia
 Summary:       PCMCIA modules
 Summary(de.UTF-8):     PCMCIA Module
@@ -679,9 +700,6 @@ cd linux-%{basever}
 # hostap enhancements from/for aircrack-ng
 %patch85 -p1
 
-# TechniSat_CableStar_Combo_HD_CI
-%patch90 -p1
-
 # vserver
 %if %{with vserver}
 %patch100 -p1
@@ -724,6 +742,9 @@ cd linux-%{basever}
 %patch503 -p1
 %patch504 -p1
 %patch505 -p1
+%patch506 -p1
+%patch507 -p1
+%patch508 -p1
 %endif
 
 %endif # vanilla
@@ -1187,6 +1208,12 @@ fi
 %postun drm
 %depmod %{kernel_release}
 
+%post ide
+%depmod %{kernel_release}
+
+%postun ide
+%depmod %{kernel_release}
+
 %post pcmcia
 %depmod %{kernel_release}
 
@@ -1250,6 +1277,9 @@ fi
 %if %{have_drm}
 %exclude /lib/modules/%{kernel_release}/kernel/drivers/gpu
 %endif
+%if %{have_ide}
+%exclude /lib/modules/%{kernel_release}/kernel/drivers/ide/*
+%endif
 /lib/modules/%{kernel_release}/kernel/fs
 /lib/modules/%{kernel_release}/kernel/kernel
 /lib/modules/%{kernel_release}/kernel/lib
@@ -1323,6 +1353,15 @@ fi
 /lib/modules/%{kernel_release}/kernel/drivers/gpu
 %endif
 
+%if %{have_ide}
+%files ide
+%defattr(644,root,root,755)
+/lib/modules/%{kernel_release}/kernel/drivers/ide/*
+%if %{have_pcmcia}
+%exclude /lib/modules/%{kernel_release}/kernel/drivers/ide/ide-cs.ko*
+%endif
+%endif
+
 %if %{have_pcmcia}
 %files pcmcia
 %defattr(644,root,root,755)
This page took 0.050854 seconds and 4 git commands to generate.