]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
- rel 1
[packages/kernel.git] / kernel.spec
index 21ff0d186595ab17a10365cda14e0b7e3a4b1c70..ba5988d584e8550f1a662637f4e937cfe4cfdb9b 100644 (file)
@@ -18,7 +18,6 @@
 %bcond_without source          # don't build kernel-source package
 %bcond_without doc                     # don't build kernel-doc package
 %bcond_without pcmcia          # don't build pcmcia
-%bcond_without firmware        # don't build firmware into main package
 
 %bcond_with    verbose         # verbose build (V=1)
 
@@ -30,7 +29,6 @@
 %bcond_without ipv6            # ipv6 support
 
 %bcond_without aufs            # aufs4 support
-%bcond_without apparmor        # UBUNTU SAUCE apparmor patches
 
 %bcond_with    vserver         # support for VServer
 
@@ -69,9 +67,9 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             2
-%define                basever         4.13
-%define                postver         .2
+%define                rel             1
+%define                basever         4.18
+%define                postver         .0
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       %{nil}
@@ -120,10 +118,10 @@ Epoch:            3
 License:       GPL v2
 Group:         Base/Kernel
 Source0:       https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
-# Source0-md5: ab1a2abc6f37b752dd2595338bec4e78
+# Source0-md5: bee5fe53ee1c3142b8f0c12c0d3348f9
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  0aed60167525cb5cecdd29e78fc5f58e
+# Patch0-md5:  ad9acd78874e9ad9a5a0cd3c28d9d941
 %endif
 Source1:       kernel.sysconfig
 
@@ -197,10 +195,9 @@ Patch101:  kernel-vserver-fixes.patch
 # Patch creation:
 # git clone git://github.com/sfjro/aufs4-standalone.git
 # cd aufs4-standalone
-# git checkout -b aufs4.12 origin/aufs4.12
+# git checkout -b aufs4.17 origin/aufs4.17
 # cat aufs4-kbuild.patch aufs4-base.patch aufs4-mmap.patch aufs4-standalone.patch > ~/rpm/packages/kernel/kernel-aufs4.patch
-# rm -rf linux && mkdir linux
-# cp -a Documentation fs include linux
+# rm -rf linux && mkdir linux; cp -a Documentation fs include linux
 # diff -urN /usr/share/empty linux | filterdiff -x linux/include/uapi/linux/Kbuild >> ~/rpm/packages/kernel/kernel-aufs4.patch
 # cat aufs4-loopback.patch >> ~/rpm/packages/kernel/kernel-aufs4.patch
 #
@@ -218,24 +215,6 @@ Patch2000: kernel-small_fixes.patch
 Patch2001:     kernel-pwc-uncompress.patch
 Patch2003:     kernel-regressions.patch
 
-# http://bazaar.launchpad.net/~apparmor-dev/apparmor/master/files/head:/kernel-patches/v4.13/
-Patch5001:     0002-apparmor-Fix-shadowed-local-variable-in-unpack_trans.patch
-Patch5002:     0003-apparmor-Fix-logical-error-in-verify_header.patch
-Patch5003:     0004-apparmor-Fix-an-error-code-in-aafs_create.patch
-Patch5004:     0005-apparmor-Redundant-condition-prev_ns.-in-label.c-149.patch
-Patch5005:     0006-apparmor-add-the-ability-to-mediate-signals.patch
-Patch5006:     0007-apparmor-add-mount-mediation.patch
-Patch5007:     0008-apparmor-cleanup-conditional-check-for-label-in-labe.patch
-Patch5008:     0009-apparmor-add-support-for-absolute-root-view-based-la.patch
-Patch5009:     0010-apparmor-make-policy_unpack-able-to-audit-different-.patch
-Patch5010:     0011-apparmor-add-more-debug-asserts-to-apparmorfs.patch
-Patch5011:     0012-apparmor-add-base-infastructure-for-socket-mediation.patch
-Patch5012:     0013-apparmor-move-new_null_profile-to-after-profile-look.patch
-Patch5013:     0014-apparmor-fix-race-condition-in-null-profile-creation.patch
-Patch5014:     0015-apparmor-ensure-unconfined-profiles-have-dfas-initia.patch
-Patch5015:     0016-apparmor-fix-incorrect-type-assignment-when-freeing-.patch
-Patch5016:     0017-UBUNTU-SAUCE-apparmor-af_unix-mediation.patch
-
 # for rescuecd
 # based on ftp://ftp.leg.uct.ac.za/pub/linux/rip/tmpfs_root-2.6.30.diff.gz
 Patch7000:     kernel-inittmpfs.patch
@@ -253,7 +232,7 @@ BuildRequires:      binutils >= 3:2.18
 BuildRequires: elftoaout
 %endif
 BuildRequires: elfutils-devel
-BuildRequires: gcc >= 5:3.2
+BuildRequires: gcc >= 6:7.2.0-6
 BuildRequires: gcc-plugin-devel
 BuildRequires: hostname
 BuildRequires: kmod >= 12-2
@@ -266,11 +245,11 @@ BuildRequires:    uboot-mkimage
 %endif
 BuildRequires: xz >= 1:4.999.7
 Requires(post):        coreutils
-Requires(post):        geninitrd >= 12749
+Requires(post):        geninitrd >= 12757-8
 Requires(post):        kmod >= 12-2
 Requires:      /sbin/depmod
 Requires:      coreutils
-Requires:      geninitrd >= 12749
+Requires:      geninitrd >= 12757-8
 Requires:      kmod >= 12-2
 %if %{with pae}
 %ifarch i686 athlon pentium3 pentium4
@@ -280,12 +259,7 @@ Requires:  cpuinfo(pae)
 Suggests:      crda
 Suggests:      dracut
 Suggests:      keyutils
-Suggests:      kernel%{versuffix}-ide = %{epoch}:%{version}-%{release}
-%if %{with firmware}
-Suggests:      linux-firmware
-%else
 Requires:      linux-firmware
-%endif
 Provides:      %{name}(netfilter) = 20070806
 Provides:      %{name}(vermagic) = %{kernel_release}
 Obsoletes:     kernel%{_alt_kernel}-char-lirc-ene0100
@@ -703,26 +677,6 @@ cd linux-%{basever}
 rm -f localversion-rt
 %endif
 
-# apparmor
-%if %{with apparmor}
-%patch5001 -p1
-%patch5002 -p1
-%patch5003 -p1
-%patch5004 -p1
-%patch5005 -p1
-%patch5006 -p1
-%patch5007 -p1
-%patch5008 -p1
-%patch5009 -p1
-%patch5010 -p1
-%patch5011 -p1
-%patch5012 -p1
-%patch5013 -p1
-%patch5014 -p1
-%patch5015 -p1
-%patch5016 -p1
-%endif
-
 %patch250 -p1
 
 %endif # vanilla
@@ -735,6 +689,8 @@ rm -f localversion-rt
 # Do not remove this, please!
 #%%patch50000 -p1
 
+chmod 755 tools/objtool/sync-check.sh
+
 # Fix EXTRAVERSION in main Makefile
 sed -i 's#EXTRAVERSION =.*#EXTRAVERSION = %{?alt_kernel:.%{alt_kernel}}#g' Makefile
 
@@ -952,13 +908,12 @@ cd -
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} %{MakeOpts} -j1 %{!?with_verbose:-s} modules_install %{?with_firmware:firmware_install} \
+%{__make} %{MakeOpts} -j1 %{!?with_verbose:-s} modules_install \
        -C %{objdir} \
        %{?with_verbose:V=1} \
        DEPMOD=%{DepMod} \
        mod_compress_cmd=true \
        INSTALL_MOD_PATH=$RPM_BUILD_ROOT \
-       INSTALL_FW_PATH=$RPM_BUILD_ROOT/lib/firmware/%{kernel_release} \
        KERNELRELEASE=%{kernel_release}
 
 install -d $RPM_BUILD_ROOT/lib/modules/%{kernel_release}/misc
@@ -1049,6 +1004,13 @@ for dir in $(cd %{objdir} && find arch -name generated -type d); do
        find $RPM_BUILD_ROOT%{_kernelsrcdir}/$dir -name '.*.cmd' -exec rm "{}" ";"
 done
 
+%ifarch %{x8664} x32
+# Needed for CONFIG_STACK_VALIDATION / ORC_UNWINDER enabled builds
+install -d $RPM_BUILD_ROOT%{_kernelsrcdir}/tools/objtool
+cp -a %{objdir}/tools/objtool/fixdep $RPM_BUILD_ROOT%{_kernelsrcdir}/tools/objtool
+cp -a %{objdir}/tools/objtool/objtool $RPM_BUILD_ROOT%{_kernelsrcdir}/tools/objtool
+%endif
+
 # version.h location changed in 3.7, but a lot of external modules don't know about it
 # add a compatibility symlink
 ln -s ../generated/uapi/linux/version.h $RPM_BUILD_ROOT%{_kernelsrcdir}/include/linux/version.h
@@ -1242,9 +1204,6 @@ fi
 /boot/config-%{kernel_release}
 %ghost %{initrd_dir}/initrd-%{kernel_release}.gz
 %ghost %{initrd_dir}/initramfs-%{kernel_release}.img
-%if %{with firmware}
-/lib/firmware/%{kernel_release}
-%endif
 
 %dir /lib/modules/%{kernel_release}
 %dir /lib/modules/%{kernel_release}/kernel
@@ -1423,16 +1382,12 @@ fi
 %exclude %dir %{_kernelsrcdir}/arch/um
 %{_kernelsrcdir}/arch/*/kernel/asm-offsets*
 %{_kernelsrcdir}/arch/*/kernel/sigframe*.h
-%{_kernelsrcdir}/drivers/lguest/lg.h
 %{_kernelsrcdir}/drivers/media/pci/bt8xx/bttv.h
 %{_kernelsrcdir}/kernel/bounds.c
 %{_kernelsrcdir}/scripts/basic/*.c
 %attr(755,root,root) %{_kernelsrcdir}/scripts/kconfig/*.sh
-%{_kernelsrcdir}/scripts/kconfig/*.in
-%{_kernelsrcdir}/scripts/kconfig/*_shipped
 %{_kernelsrcdir}/scripts/kconfig/*.pl
 %{_kernelsrcdir}/scripts/kconfig/*.glade
-%{_kernelsrcdir}/scripts/kconfig/*.gperf
 %{_kernelsrcdir}/scripts/kconfig/*.cc
 %{_kernelsrcdir}/scripts/kconfig/*.y
 %{_kernelsrcdir}/scripts/kconfig/*.l
@@ -1455,6 +1410,10 @@ fi
 %{_kernelsrcdir}/scripts/selinux/mdp/*.c
 %exclude %dir %{_kernelsrcdir}/security
 %exclude %dir %{_kernelsrcdir}/security/selinux
+%ifarch %{x8664} x32
+%attr(755,root,root) %{_kernelsrcdir}/tools/objtool/fixdep
+%attr(755,root,root) %{_kernelsrcdir}/tools/objtool/objtool
+%endif
 
 %if %{with doc}
 %files doc
@@ -1490,7 +1449,6 @@ fi
 %{_kernelsrcdir}/arch/x86/kvm
 %exclude %{_kernelsrcdir}/arch/*/kernel/asm-offsets*
 %exclude %{_kernelsrcdir}/arch/*/kernel/sigframe*.h
-%exclude %{_kernelsrcdir}/drivers/lguest/lg.h
 %exclude %{_kernelsrcdir}/drivers/media/pci/bt8xx/bttv.h
 %{_kernelsrcdir}/block
 %{_kernelsrcdir}/certs
@@ -1532,6 +1490,10 @@ fi
 %{_kernelsrcdir}/security
 %exclude %{_kernelsrcdir}/security/selinux/include
 %{_kernelsrcdir}/tools/*
+%ifarch %{x8664} x32
+%exclude %{_kernelsrcdir}/tools/objtool/fixdep
+%exclude %{_kernelsrcdir}/tools/objtool/objtool
+%endif
 %{_kernelsrcdir}/usr
 %{_kernelsrcdir}/COPYING
 %{_kernelsrcdir}/CREDITS
This page took 0.037104 seconds and 4 git commands to generate.