]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
- 4.10.11
[packages/kernel.git] / kernel.spec
index d28a55e364769f5fb0f6b66cff7fc2e3c5c19a7e..b1fb87a30b680f554aa82ba87d80569c81f734fe 100644 (file)
 %bcond_with    fbcondecor      # build fbcondecor (disable FB_TILEBLITTING and affected fb modules)
 %bcond_without pae             # build PAE (HIGHMEM64G) support on 32bit i686 athlon pentium3 pentium4
 %bcond_with    nfsroot         # build with root on NFS support
-%bcond_with    uksm            # build with UKSM patch, http://kerneldedup.org/projects/uksm/
 
 %bcond_without imq             # imq support
-%bcond_without esfq            # esfq support
 %bcond_without ipv6            # ipv6 support
 
+%bcond_without aufs            # aufs4 support
+
 %bcond_with    vserver         # support for VServer
 
+%bcond_with    rt              # real-time kernel (CONFIG_PREEMPT_RT) for low latencies
+
 %bcond_with    vanilla         # don't include any patches
 %bcond_with    rescuecd        # build kernel for our rescue
 %bcond_with    myown           # build with your own config (kernel-myown.config)
@@ -69,9 +71,9 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             2
-%define                basever         4.6
-%define                postver         .1
+%define                rel             1
+%define                basever         4.10
+%define                postver         .11
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       %{nil}
 %if %{without pae}
 %define                alt_kernel      nopae
 %endif
+%if %{with rt}
+%define                alt_kernel      rt
+%endif
 
 # kernel release (used in filesystem and eventually in uname -r)
 # modules will be looked from /lib/modules/%{kernel_release}
@@ -117,10 +122,10 @@ Epoch:            3
 License:       GPL v2
 Group:         Base/Kernel
 Source0:       https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
-# Source0-md5: d2927020e24a76da4ab482a8bc3e9ef3
+# Source0-md5: b5e7f6b9b2fe1b6cc7bc56a3a0bfc090
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  e3479d9c8a0e8757c16eb03a4258587c
+# Patch0-md5:  dcb540cfe8204e637fa38e2c04963fef
 %endif
 Source1:       kernel.sysconfig
 
@@ -142,9 +147,9 @@ Source25:   kernel-ia64.config
 
 Source41:      kernel-patches.config
 Source43:      kernel-vserver.config
+Source44:      kernel-rt.config
 
 Source55:      kernel-imq.config
-Source56:      kernel-uksm.config
 
 Source58:      kernel-inittmpfs.config
 
@@ -167,15 +172,9 @@ Patch40:   kernel-layer7.patch
 
 ### End netfilter
 
-# http://zph.bratcheda.org/linux-2.6.26.3-zph.patch
-Patch49:       kernel-zph.patch
-
 # http://www.linuximq.net
 Patch50:       kernel-imq.patch
 
-# http://fatooh.org/esfq-2.6/sfq-2.6.24.1.tar.bz2
-Patch53:       kernel-esfq.patch
-
 # by Baggins request:
 # derived from ftp://ftp.cmf.nrl.navy.mil/pub/chas/linux-atm/vbr/vbr-kernel-diffs
 Patch55:       kernel-atm-vbr.patch
@@ -200,32 +199,30 @@ Patch101: kernel-vserver-fixes.patch
 # Patch creation:
 # git clone git://github.com/sfjro/aufs4-standalone.git
 # cd aufs4-standalone
-# git checkout -b aufs4.5 origin/aufs4.5
+# git checkout -b aufs4.9 origin/aufs4.9
 # cat aufs4-kbuild.patch aufs4-base.patch aufs4-mmap.patch aufs4-standalone.patch > ~/rpm/packages/kernel/kernel-aufs4.patch
 # rm -rf linux && mkdir linux
 # cp -a Documentation fs include linux
-# diff -urN /usr/share/empty linux >> ~/rpm/packages/kernel/kernel-aufs4.patch
-# drop hunk at the end of patch (hunk is patching include/linux/Kbuild with single line change)
+# diff -urN /usr/share/empty linux | filterdiff -x linux/include/uapi/linux/Kbuild >> ~/rpm/packages/kernel/kernel-aufs4.patch
 # cat aufs4-loopback.patch >> ~/rpm/packages/kernel/kernel-aufs4.patch
 #
 Patch145:      kernel-aufs4.patch
 Patch146:      kernel-aufs4+vserver.patch
 
-%define uksm_major_version 0.1.2.3
-%define uksm_version %{uksm_major_version}-for-v3.18
-Patch150:      http://kerneldedup.org/download/uksm/%{uksm_major_version}/uksm-%{uksm_version}.patch
-# Patch150-md5:        b6a2b2aae9c2844d0c74690632d7019e
-
 # Show normal colors in menuconfig with ncurses ABI 6
 Patch250:      kernel-fix_256colors_menuconfig.patch
 
+# https://rt.wiki.kernel.org/
+# https://www.kernel.org/pub/linux/kernel/projects/rt/4.9/patch-4.9.6-rt4.patch.xz
+Patch500:      kernel-rt.patch
+
 Patch2000:     kernel-small_fixes.patch
 Patch2001:     kernel-pwc-uncompress.patch
 Patch2003:     kernel-regressions.patch
 Patch2004:     kernel-libata-ahci-pm.patch
 
 # git://git.kernel.org/pub/scm/linux/kernel/git/jj/linux-apparmor
-# branch v4.2-aa2.8-out-of-tree
+# branch v4.7-aa2.8-out-of-tree
 Patch5000:     kernel-apparmor.patch
 
 # for rescuecd
@@ -248,6 +245,7 @@ BuildRequires:      elfutils-devel
 BuildRequires: gcc >= 5:3.2
 BuildRequires: hostname
 BuildRequires: kmod >= 12-2
+BuildRequires: openssl-devel
 BuildRequires: perl-base
 BuildRequires: rpm-build >= 4.5-24
 BuildRequires: rpmbuild(macros) >= 1.707
@@ -395,6 +393,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %{?with_fbcondecor:Fbsplash/fbcondecor - enabled }\
 %{?with_nfsroot:Root on NFS - enabled}\
 %{?with_vserver:Linux-VServer - %{vserver_patch}}\
+%{?with_rt:CONFIG_PREEMPT_RT - enabled}\
 
 %define Features %(echo "%{__features}" | sed '/^$/d')
 
@@ -675,16 +674,8 @@ cd linux-%{basever}
 ##
 # end of netfilter
 
-# zph
-%patch49 -p1
-
 %if %{with imq}
-%patch50 -p1
-%endif
-
-# esfq
-%if %{with esfq}
-%patch53 -p1
+#%patch50 -p1
 %endif
 
 %patch55 -p1
@@ -702,21 +693,23 @@ cd linux-%{basever}
 %patch101 -p1
 %endif
 
-# aufs3
+%if %{with aufs}
+# aufs4
 %patch145 -p1
 %if %{with vserver}
 %patch146 -p1
 %endif
-
-# UKSM
-%if %{with uksm}
-%patch150 -p1
 %endif
 
 %if %{with rescuecd}
 %patch7000 -p1
 %endif
 
+%if %{with rt}
+%patch500 -p1
+rm -f localversion-rt
+%endif
+
 # apparmor
 %patch5000 -p1
 
@@ -755,7 +748,6 @@ EOF
 
 RescueConfig() {
        set -x
-       cat <<-EOCONFIG > $1
                # CONFIG_SOUND is not set
                # CONFIG_AUDIT is not set
                # CONFIG_TR is not set
@@ -918,11 +910,11 @@ EOCONFIG
 %if %{with imq}
                %{SOURCE55} \
 %endif
-%if %{with uksm}
-               %{SOURCE56} \
-%endif
 %if %{with vserver}
                %{SOURCE43} \
+%endif
+%if %{with rt}
+               %{SOURCE44} \
 %endif
                %{SOURCE41} %{?0:patches} \
 %endif
@@ -1048,11 +1040,6 @@ for dir in $(cd %{objdir} && find arch -name generated -type d); do
        find $RPM_BUILD_ROOT%{_kernelsrcdir}/$dir -name '.*.cmd' -exec rm "{}" ";"
 done
 
-# Needed for CONFIG_STACK_VALIDATION enabled builds
-install -d $RPM_BUILD_ROOT%{_kernelsrcdir}/tools/objtool
-cp -a %{objdir}/tools/objtool/fixdep $RPM_BUILD_ROOT%{_kernelsrcdir}/tools/objtool
-cp -a %{objdir}/tools/objtool/objtool $RPM_BUILD_ROOT%{_kernelsrcdir}/tools/objtool
-
 # version.h location changed in 3.7, but a lot of external modules don't know about it
 # add a compatibility symlink
 ln -s ../generated/uapi/linux/version.h $RPM_BUILD_ROOT%{_kernelsrcdir}/include/linux/version.h
@@ -1473,8 +1460,6 @@ fi
 %{_kernelsrcdir}/scripts/selinux/mdp/*.c
 %exclude %dir %{_kernelsrcdir}/security
 %exclude %dir %{_kernelsrcdir}/security/selinux
-%attr(755,root,root) %{_kernelsrcdir}/tools/objtool/fixdep
-%attr(755,root,root) %{_kernelsrcdir}/tools/objtool/objtool
 
 %if %{with doc}
 %files doc
@@ -1485,9 +1470,6 @@ fi
 %{_docdir}/%{name}-%{version}/[jkz]*.txt
 %{_docdir}/%{name}-%{version}/kbuild
 %{_docdir}/%{name}-%{version}/kdump
-%lang(ja) %{_docdir}/%{name}-%{version}/ja_JP
-%lang(ko) %{_docdir}/%{name}-%{version}/ko_KR
-%lang(zh_CN) %{_docdir}/%{name}-%{version}/zh_CN
 %endif
 
 %if %{with source}
@@ -1554,12 +1536,9 @@ fi
 %{_kernelsrcdir}/security
 %exclude %{_kernelsrcdir}/security/selinux/include
 %{_kernelsrcdir}/tools/*
-%exclude %{_kernelsrcdir}/tools/objtool/fixdep
-%exclude %{_kernelsrcdir}/tools/objtool/objtool
 %{_kernelsrcdir}/usr
 %{_kernelsrcdir}/COPYING
 %{_kernelsrcdir}/CREDITS
 %{_kernelsrcdir}/MAINTAINERS
 %{_kernelsrcdir}/README
-%{_kernelsrcdir}/REPORTING-BUGS
 %endif
This page took 0.043929 seconds and 4 git commands to generate.