]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
- rel 2; this kernel supports vserver now
[packages/kernel.git] / kernel.spec
index 98cddfe3d7c57b7409a3f474ff4e4a2671d6966e..a820a477d162004a2c965ff75156464f4d13085d 100644 (file)
 %bcond_with    fbcondecor      # build fbcondecor (disable FB_TILEBLITTING and affected fb modules)
 %bcond_without pae             # build PAE (HIGHMEM64G) support on 32bit i686 athlon pentium3 pentium4
 %bcond_with    nfsroot         # build with root on NFS support
-%bcond_with    uksm            # build with UKSM patch, http://kerneldedup.org/projects/uksm/
 
 %bcond_without imq             # imq support
 %bcond_without esfq            # esfq support
 %bcond_without ipv6            # ipv6 support
 
-%bcond_with    vserver         # support for VServer
+%bcond_without vserver         # support for VServer
+
+%bcond_with    rt              # real-time kernel (CONFIG_PREEMPT_RT) for low latencies
 
 %bcond_with    vanilla         # don't include any patches
 %bcond_with    rescuecd        # build kernel for our rescue
 
 %define                rel             2
 %define                basever         4.4
-%define                postver         .1
+%define                postver         .111
 
 # define this to '-%{basever}' for longterm branch
-%define                versuffix       %{nil}
+%define                versuffix       -%{basever}
 
 # __alt_kernel is list of features, empty string if none set
 # _alt kernel is defined as: %{nil}%{?alt_kernel:-%{?alt_kernel}} (defined in rpm.macros)
@@ -98,6 +99,9 @@
 %if %{without pae}
 %define                alt_kernel      nopae
 %endif
+%if %{with rt}
+%define                alt_kernel      rt
+%endif
 
 # kernel release (used in filesystem and eventually in uname -r)
 # modules will be looked from /lib/modules/%{kernel_release}
@@ -120,7 +124,7 @@ Source0:    http://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
 # Source0-md5: 9a78fa2eb6c68ca5a40ed5af08142599
 %if "%{postver}" != ".0"
 Patch0:                http://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  d9e951895c8c249f0bf52d85f3e63bce
+# Patch0-md5:  d23387c591d45b0472bef1488bb4e949
 %endif
 Source1:       kernel.sysconfig
 
@@ -142,9 +146,9 @@ Source25:   kernel-ia64.config
 
 Source41:      kernel-patches.config
 Source43:      kernel-vserver.config
+Source44:      kernel-rt.config
 
 Source55:      kernel-imq.config
-Source56:      kernel-uksm.config
 
 Source58:      kernel-inittmpfs.config
 
@@ -188,8 +192,8 @@ Patch59:    kernel-rndis_host-wm5.patch
 # http://patches.aircrack-ng.org/hostap-kernel-2.6.18.patch
 Patch85:       kernel-hostap.patch
 
-%define        vserver_patch 3.18.5-vs2.3.7.3
-# http://vserver.13thfloor.at/Experimental/patch-3.18.5-vs2.3.7.3.diff
+%define        vserver_patch 4.4.111-vs2.3.9.5
+# http://vserver.13thfloor.at/Experimental/patch-4.4.111-vs2.3.9.5.diff
 # note there are additional patches from above url:
 # - *fix* are real fixes (we want these)
 # - *feat* are new features/tests (we don't want these)
@@ -211,17 +215,16 @@ Patch101: kernel-vserver-fixes.patch
 Patch145:      kernel-aufs4.patch
 Patch146:      kernel-aufs4+vserver.patch
 
-%define uksm_major_version 0.1.2.3
-%define uksm_version %{uksm_major_version}-for-v3.18
-Patch150:      http://kerneldedup.org/download/uksm/%{uksm_major_version}/uksm-%{uksm_version}.patch
-# Patch150-md5:        b6a2b2aae9c2844d0c74690632d7019e
-
 # Show normal colors in menuconfig with ncurses ABI 6
 Patch250:      kernel-fix_256colors_menuconfig.patch
 
 # https://patchwork.kernel.org/patch/236261/
 Patch400:      kernel-virtio-gl-accel.patch
 
+# https://rt.wiki.kernel.org/
+# https://www.kernel.org/pub/linux/kernel/projects/rt/4.4/patch-4.4.30-rt41.patch.xz
+Patch500:      kernel-rt.patch
+
 Patch2000:     kernel-small_fixes.patch
 Patch2001:     kernel-pwc-uncompress.patch
 Patch2003:     kernel-regressions.patch
@@ -313,7 +316,7 @@ Conflicts:  reiserfsprogs < 3.6.3
 Conflicts:     rpm < 4.4.2-0.2
 Conflicts:     udev < 1:081
 Conflicts:     util-linux < 2.10o
-Conflicts:     util-vserver < 0.30.216
+Conflicts:     util-vserver < 0.30.216-1.pre3126.3
 Conflicts:     xfsprogs < 2.6.0
 %if %{without pae}
 ExclusiveArch: i686 pentium3 pentium4 athlon
@@ -397,6 +400,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %{?with_fbcondecor:Fbsplash/fbcondecor - enabled }\
 %{?with_nfsroot:Root on NFS - enabled}\
 %{?with_vserver:Linux-VServer - %{vserver_patch}}\
+%{?with_rt:CONFIG_PREEMPT_RT - enabled}\
 
 %define Features %(echo "%{__features}" | sed '/^$/d')
 
@@ -663,7 +667,10 @@ cd linux-%{basever}
 #
 
 # kernel-pom-ng-IPV4OPTSSTRIP.patch
+%if %{without rt}
+# fails on -Werror=incompatible-pointer-types
 %patch10 -p1
+%endif
 
 # kernel-owner-xid.patch
 %if %{with vserver}
@@ -688,8 +695,11 @@ cd linux-%{basever}
 %patch53 -p1
 %endif
 
+%if %{without rt}
+# fails on -Werror=incompatible-pointer-types
 %patch55 -p1
 %patch56 -p1
+%endif
 
 # kernel-rndis_host-wm5.patch
 %patch59 -p1
@@ -709,22 +719,25 @@ cd linux-%{basever}
 %patch146 -p1
 %endif
 
-# UKSM
-%if %{with uksm}
-%patch150 -p1
-%endif
-
 %if %{with rescuecd}
 %patch7000 -p1
 %endif
 
+%if %{with rt}
+%patch500 -p1
+rm -f localversion-rt
+%endif
+
 # apparmor
 %patch5000 -p1
 
 %patch250 -p1
 
 # virtio-gl
+%if %{without rt}
+# fails on -Werror=incompatible-pointer-types
 %patch400 -p1
+%endif
 
 %endif # vanilla
 
@@ -922,11 +935,11 @@ EOCONFIG
 %if %{with imq}
                %{SOURCE55} \
 %endif
-%if %{with uksm}
-               %{SOURCE56} \
-%endif
 %if %{with vserver}
                %{SOURCE43} \
+%endif
+%if %{with rt}
+               %{SOURCE44} \
 %endif
                %{SOURCE41} %{?0:patches} \
 %endif
This page took 0.038689 seconds and 4 git commands to generate.