]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
RT patch updated
[packages/kernel.git] / kernel.spec
index b8d64dce05262eec7dbc5ac8574a2d75408ec81b..a2ea8ca6999f78afbdd56cb9c665792df49440a5 100644 (file)
 %bcond_with    nfsroot         # build with root on NFS support
 
 %bcond_without imq             # imq support
-%bcond_without esfq            # esfq support
 %bcond_without ipv6            # ipv6 support
 
+%bcond_without aufs            # aufs4 support
+
 %bcond_with    vserver         # support for VServer
 
+%bcond_with    rt              # real-time kernel (CONFIG_PREEMPT_RT) for low latencies
+
 %bcond_with    vanilla         # don't include any patches
 %bcond_with    rescuecd        # build kernel for our rescue
 %bcond_with    myown           # build with your own config (kernel-myown.config)
@@ -69,8 +72,8 @@
 %endif
 
 %define                rel             1
-%define                basever         4.7
-%define                postver         .0
+%define                basever         4.9
+%define                postver         .7
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       %{nil}
 %if %{without pae}
 %define                alt_kernel      nopae
 %endif
+%if %{with rt}
+%define                alt_kernel      rt
+%endif
 
 # kernel release (used in filesystem and eventually in uname -r)
 # modules will be looked from /lib/modules/%{kernel_release}
@@ -116,10 +122,10 @@ Epoch:            3
 License:       GPL v2
 Group:         Base/Kernel
 Source0:       https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
-# Source0-md5: 5276563eb1f39a048e4a8a887408c031
+# Source0-md5: 0a68ef3615c64bd5ee54a3320e46667d
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  c8ff415734155965ae7a2a85ef9c9e03
+# Patch0-md5:  e1f02eaa546e2f2c46b4c89b2b3c282f
 %endif
 Source1:       kernel.sysconfig
 
@@ -141,6 +147,7 @@ Source25:   kernel-ia64.config
 
 Source41:      kernel-patches.config
 Source43:      kernel-vserver.config
+Source44:      kernel-rt.config
 
 Source55:      kernel-imq.config
 
@@ -168,9 +175,6 @@ Patch40:    kernel-layer7.patch
 # http://www.linuximq.net
 Patch50:       kernel-imq.patch
 
-# http://fatooh.org/esfq-2.6/sfq-2.6.24.1.tar.bz2
-Patch53:       kernel-esfq.patch
-
 # by Baggins request:
 # derived from ftp://ftp.cmf.nrl.navy.mil/pub/chas/linux-atm/vbr/vbr-kernel-diffs
 Patch55:       kernel-atm-vbr.patch
@@ -195,12 +199,11 @@ Patch101: kernel-vserver-fixes.patch
 # Patch creation:
 # git clone git://github.com/sfjro/aufs4-standalone.git
 # cd aufs4-standalone
-# git checkout -b aufs4.7 origin/aufs4.7
+# git checkout -b aufs4.9 origin/aufs4.9
 # cat aufs4-kbuild.patch aufs4-base.patch aufs4-mmap.patch aufs4-standalone.patch > ~/rpm/packages/kernel/kernel-aufs4.patch
 # rm -rf linux && mkdir linux
 # cp -a Documentation fs include linux
-# diff -urN /usr/share/empty linux >> ~/rpm/packages/kernel/kernel-aufs4.patch
-# drop hunk at the end of patch (hunk is patching include/linux/Kbuild with single line change)
+# diff -urN /usr/share/empty linux | filterdiff -x linux/include/uapi/linux/Kbuild >> ~/rpm/packages/kernel/kernel-aufs4.patch
 # cat aufs4-loopback.patch >> ~/rpm/packages/kernel/kernel-aufs4.patch
 #
 Patch145:      kernel-aufs4.patch
@@ -209,6 +212,10 @@ Patch146:  kernel-aufs4+vserver.patch
 # Show normal colors in menuconfig with ncurses ABI 6
 Patch250:      kernel-fix_256colors_menuconfig.patch
 
+# https://rt.wiki.kernel.org/
+# https://www.kernel.org/pub/linux/kernel/projects/rt/4.9/patch-4.9.6-rt4.patch.xz
+Patch500:      kernel-rt.patch
+
 Patch2000:     kernel-small_fixes.patch
 Patch2001:     kernel-pwc-uncompress.patch
 Patch2003:     kernel-regressions.patch
@@ -386,6 +393,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %{?with_fbcondecor:Fbsplash/fbcondecor - enabled }\
 %{?with_nfsroot:Root on NFS - enabled}\
 %{?with_vserver:Linux-VServer - %{vserver_patch}}\
+%{?with_rt:CONFIG_PREEMPT_RT - enabled}\
 
 %define Features %(echo "%{__features}" | sed '/^$/d')
 
@@ -670,11 +678,6 @@ cd linux-%{basever}
 %patch50 -p1
 %endif
 
-# esfq
-%if %{with esfq}
-%patch53 -p1
-%endif
-
 %patch55 -p1
 %patch56 -p1
 
@@ -690,18 +693,24 @@ cd linux-%{basever}
 %patch101 -p1
 %endif
 
-# aufs3
+%if %{with aufs}
+# aufs4
 %patch145 -p1
 %if %{with vserver}
 %patch146 -p1
 %endif
+%endif
 
 %if %{with rescuecd}
 %patch7000 -p1
 %endif
 
+%if %{with rt}
+%patch500 -p1
+rm -f localversion-rt
+%endif
+
 # apparmor
-# FIME
 %patch5000 -p1
 
 %patch250 -p1
@@ -739,7 +748,6 @@ EOF
 
 RescueConfig() {
        set -x
-       cat <<-EOCONFIG > $1
                # CONFIG_SOUND is not set
                # CONFIG_AUDIT is not set
                # CONFIG_TR is not set
@@ -904,6 +912,9 @@ EOCONFIG
 %endif
 %if %{with vserver}
                %{SOURCE43} \
+%endif
+%if %{with rt}
+               %{SOURCE44} \
 %endif
                %{SOURCE41} %{?0:patches} \
 %endif
This page took 0.035508 seconds and 4 git commands to generate.