]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
up to 5.19.4
[packages/kernel.git] / kernel.spec
index 584b4983c0a3f84c15dc11f160bc37e230d986c6..7dcc689d119f731168ec2d58aa567700a2d47a69 100644 (file)
@@ -66,8 +66,8 @@
 %endif
 
 %define                rel             1
-%define                basever         5.15
-%define                postver         .7
+%define                basever         5.19
+%define                postver         .4
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       %{nil}
@@ -118,10 +118,10 @@ Epoch:            3
 License:       GPL v2
 Group:         Base/Kernel
 Source0:       https://www.kernel.org/pub/linux/kernel/v5.x/linux-%{basever}.tar.xz
-# Source0-md5: 071d49ff4e020d58c04f9f3f76d3b594
+# Source0-md5: f91bfe133d2cb1692f705947282e123a
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v5.x/patch-%{version}.xz
-# Patch0-md5:  e9f7de256af2461d2585d12b5d3e5fff
+# Patch0-md5:  d89c87a448cca0f1192666e538984761
 %endif
 Source1:       kernel.sysconfig
 
@@ -205,14 +205,13 @@ Patch500: kernel-rt.patch
 Patch2000:     kernel-small_fixes.patch
 Patch2001:     kernel-pwc-uncompress.patch
 Patch2003:     kernel-regressions.patch
-Patch2004:     Revert-ath-add-support-for-special-0x0-regulatory-domain.patch
 
 # for rescuecd
 # based on ftp://ftp.leg.uct.ac.za/pub/linux/rip/tmpfs_root-2.6.30.diff.gz
 Patch7000:     kernel-inittmpfs.patch
 
 # ARM only
-Patch8000:     rpi-wm8804.patch
+Patch8000:     rpi-sound.patch
 Patch8001:     kernel-pinebook-pro.patch
 Patch8002:     atheros-disallow-retrain-nongen1-pcie.patch
 
@@ -223,30 +222,32 @@ Patch8002:        atheros-disallow-retrain-nongen1-pcie.patch
 URL:           https://www.kernel.org/
 AutoReqProv:   no
 BuildRequires: /sbin/depmod
-BuildRequires: bc
-BuildRequires: binutils >= 3:2.18
-BuildRequires: bison
+BuildRequires: bc >= 1.06.95
+BuildRequires: binutils >= 3:2.23
+BuildRequires: bison >= 2.0
 %ifarch sparc sparc64
 BuildRequires: elftoaout
 %endif
 BuildRequires: elfutils-devel
-BuildRequires: flex
+BuildRequires: flex >= 2.5.35
 BuildRequires: gcc >= 6:7.2.0-6
 BuildRequires: gcc-c++
 BuildRequires: gcc-plugin-devel
 BuildRequires: hostname
 BuildRequires: kmod >= %{kmod_ver}
 BuildRequires: libstdc++-devel
-BuildRequires: openssl-devel
-BuildRequires: openssl-tools
-BuildRequires: perl-base
+BuildRequires: make >= 1:3.81
+BuildRequires: openssl-devel >= 1.0.0
+BuildRequires: openssl-tools >= 1.0.0
+BuildRequires: perl-base >= 5
 BuildRequires: rpm-build >= 4.5-24
-BuildRequires: rpmbuild(macros) >= 1.752
+BuildRequires: rpmbuild(macros) >= 2.019
 BuildRequires: tar >= 1:1.22
 %ifarch ppc
 BuildRequires: uboot-mkimage
 %endif
 BuildRequires: xz >= 1:4.999.7
+BuildConflicts:        dwarves < 1.16
 Requires(post):        coreutils
 Requires(post):        geninitrd >= 12787-6
 Requires(post):        kmod >= %{kmod_ver}
@@ -530,7 +531,7 @@ Group:              Development/Building
 Requires:      %{name}-headers = %{epoch}:%{version}-%{release}
 Requires:      elfutils-devel
 Requires:      make
-Conflicts:     rpmbuild(macros) < 1.704
+Conflicts:     rpmbuild(macros) < 2.019
 AutoReqProv:   no
 
 %description module-build
@@ -681,7 +682,6 @@ rm -f localversion-rt
 %patch2000 -p1
 %patch2001 -p1
 #%patch2003 -p1
-%patch2004 -p1
 
 # Do not remove this, please!
 #%%patch50000 -p1
@@ -709,7 +709,7 @@ find -name '*.py' -print0 | \
        scripts/show_delta \
        tools/hv/vmbus_testing \
        tools/kvm/kvm_stat/kvm_stat \
-       tools/testing/selftests/exec/binfmt_script
+       tools/testing/selftests/exec/binfmt_script.py
 
 find -name '*.pl' -print0 | \
        xargs -0 %{__sed} -i -e '1s,/usr/bin/env perl,%{__perl},' \
@@ -726,7 +726,8 @@ find -name '*.pl' -print0 | \
 
 %{__sed} -i -e '1s,/usr/bin/env bash,%{__bash},' \
        tools/testing/selftests/powerpc/security/mitigation-patching.sh \
-       scripts/config
+       scripts/config \
+       scripts/check-local-export
 
 %build
 install -d %{objdir}
@@ -890,6 +891,12 @@ BuildConfig() {
 %ifarch x32
                CONFIG_BPF_PRELOAD=n
 %endif
+%if %{_ver_ge %(rpm -q --qf='%%{VERSION}' gcc) 12}
+               CONFIG_INIT_STACK_ALL_ZERO=y
+               CONFIG_GCC_PLUGIN_STRUCTLEAK_BYREF_ALL=n
+%else
+               CONFIG_GCC_PLUGIN_STRUCTLEAK_BYREF_ALL=y
+%endif
 EOCONFIG
 
 %if %{with rescuecd}
@@ -935,8 +942,14 @@ cd -
 
 %{__awk} %{?debug:-v dieOnError=1} -v infile=%{objdir}/%{defconfig} -f %{SOURCE8} %{objdir}/.config
 
+%{__make} \
+       TARGETOBJ=%{targetobj} \
+       %{?with_verbose:V=1} \
+       scripts
+
 # build kernel
 export DTC_FLAGS=-@
+ICECC_EXTRAFILES="${ICECC_EXTRAFILES:+$ICECC_EXTRAFILES:}$(test -d %{objdir}/scripts/gcc-plugins && find %{objdir}/scripts/gcc-plugins -name '*.so' | paste -s -d :)"
 %{__make} \
        TARGETOBJ=%{targetobj} \
        %{?with_verbose:V=1} \
@@ -944,7 +957,7 @@ export DTC_FLAGS=-@
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} %{MakeOpts} -j1 %{!?with_verbose:-s} modules_install \
+%{__make} %{MakeOpts} %{!?with_verbose:-s} modules_install \
        -C %{objdir} \
        %{?with_verbose:V=1} \
        DEPMOD=%{DepMod} \
@@ -1119,7 +1132,8 @@ if [[ "$CREATE_SYMLINKS" != [Nn][Oo] ]]; then
        ln -sf vmlinuz-%{kernel_release} /boot/vmlinuz
        ln -sf System.map-%{kernel_release} /boot/System.map
 %ifarch %{arm} aarch64
-       mv -f /boot/dtb{,.old} 2> /dev/null
+       test -L /boot/dtb.old && rm /boot/dtb.old
+       test ! -e /boot/dtb.old && mv -f /boot/dtb{,.old} 2> /dev/null
        ln -sf dtb-%{kernel_release} /boot/dtb
 %endif
 %if 0%{?alt_kernel:1}
@@ -1409,6 +1423,8 @@ fi
 %dir %{_kernelsrcdir}/security
 %dir %{_kernelsrcdir}/security/selinux
 %{_kernelsrcdir}/security/selinux/include
+%dir %{_kernelsrcdir}/tools
+%{_kernelsrcdir}/tools/include
 %dir %{_kernelsrcdir}/usr
 %dir %{_kernelsrcdir}/usr/include
 %{_kernelsrcdir}/.config
@@ -1442,6 +1458,7 @@ fi
 %{_kernelsrcdir}/scripts/kconfig/lxdialog
 %{_kernelsrcdir}/scripts/mod/*.c
 %{_kernelsrcdir}/scripts/mod/modpost.h
+%attr(755,root,root) %{_kernelsrcdir}/scripts/check-local-export
 %attr(755,root,root) %{_kernelsrcdir}/scripts/mkcompile_h
 %attr(755,root,root) %{_kernelsrcdir}/scripts/setlocalversion
 %{_kernelsrcdir}/scripts/subarch.include
@@ -1480,6 +1497,7 @@ fi
 %{_kernelsrcdir}/arch/x86/ia32/[!M]*
 %{_kernelsrcdir}/arch/powerpc/kexec
 %{_kernelsrcdir}/arch/powerpc/kvm
+%{_kernelsrcdir}/arch/riscv/kvm
 %ifarch ppc ppc64
 %exclude %{_kernelsrcdir}/arch/powerpc/lib/crtsavres.*
 %endif
@@ -1508,6 +1526,7 @@ fi
 %exclude %{_kernelsrcdir}/scripts/Kbuild.include
 %exclude %{_kernelsrcdir}/scripts/Makefile*
 %exclude %{_kernelsrcdir}/scripts/basic
+%exclude %{_kernelsrcdir}/scripts/check-local-export
 %exclude %{_kernelsrcdir}/scripts/kconfig
 %exclude %{_kernelsrcdir}/scripts/mkcompile_h
 %exclude %{_kernelsrcdir}/scripts/mod
@@ -1528,6 +1547,7 @@ fi
 %{_kernelsrcdir}/security
 %exclude %{_kernelsrcdir}/security/selinux/include
 %{_kernelsrcdir}/tools/*
+%exclude %{_kernelsrcdir}/tools/include
 %ifarch %{x8664} x32
 %exclude %{_kernelsrcdir}/tools/objtool/fixdep
 %exclude %{_kernelsrcdir}/tools/objtool/objtool
This page took 0.406723 seconds and 4 git commands to generate.