]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
- keep 4.19 behaviour stable (so disable mq after all) and only enable mq in newer...
[packages/kernel.git] / kernel.spec
index a42b35d52332f985549c53457b7dc71be02b7fe9..3c7350ab80edb7bd4a94cd8dee6d6e51ecd37fee 100644 (file)
@@ -16,8 +16,9 @@
 #
 # Conditional build:
 %bcond_without source          # don't build kernel-source package
-%bcond_without doc                     # don't build kernel-doc package
+%bcond_without doc             # don't build kernel-doc package
 %bcond_without pcmcia          # don't build pcmcia
+%bcond_without debuginfo       # debug info files
 
 %bcond_with    verbose         # verbose build (V=1)
 
 %define                have_pcmcia     0
 %endif
 
-%define                rel             3
-%define                basever         4.17
-%define                postver         .9
+%define                rel             1
+%define                basever         4.19
+%define                postver         .19
 
 # define this to '-%{basever}' for longterm branch
-%define                versuffix       %{nil}
+%define                versuffix       -%{basever}
 
 # __alt_kernel is list of features, empty string if none set
 # _alt kernel is defined as: %{nil}%{?alt_kernel:-%{?alt_kernel}} (defined in rpm.macros)
@@ -118,10 +119,10 @@ Epoch:            3
 License:       GPL v2
 Group:         Base/Kernel
 Source0:       https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
-# Source0-md5: 5bb13a03274b66b56c85b26682e407d7
+# Source0-md5: 740a90cf810c2105df8ee12e5d0bb900
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  80546916d0682a101e8138843bd84f34
+# Patch0-md5:  687b992be5e0514397acc6713ea121c0
 %endif
 Source1:       kernel.sysconfig
 
@@ -195,7 +196,7 @@ Patch101:   kernel-vserver-fixes.patch
 # Patch creation:
 # git clone git://github.com/sfjro/aufs4-standalone.git
 # cd aufs4-standalone
-# git checkout -b aufs4.17 origin/aufs4.17
+# git checkout -b aufs4.19 origin/aufs4.19
 # cat aufs4-kbuild.patch aufs4-base.patch aufs4-mmap.patch aufs4-standalone.patch > ~/rpm/packages/kernel/kernel-aufs4.patch
 # rm -rf linux && mkdir linux; cp -a Documentation fs include linux
 # diff -urN /usr/share/empty linux | filterdiff -x linux/include/uapi/linux/Kbuild >> ~/rpm/packages/kernel/kernel-aufs4.patch
@@ -213,10 +214,9 @@ Patch500:  kernel-rt.patch
 
 Patch2000:     kernel-small_fixes.patch
 Patch2001:     kernel-pwc-uncompress.patch
+Patch2002:     xfs-reclaim-hack.patch
 Patch2003:     kernel-regressions.patch
 
-Patch2004:     tcp-ooo.patch
-
 # for rescuecd
 # based on ftp://ftp.leg.uct.ac.za/pub/linux/rip/tmpfs_root-2.6.30.diff.gz
 Patch7000:     kernel-inittmpfs.patch
@@ -686,8 +686,8 @@ rm -f localversion-rt
 # Small fixes:
 %patch2000 -p1
 %patch2001 -p1
+%patch2002 -p1
 #%patch2003 -p1
-%patch2004 -p1
 
 # Do not remove this, please!
 #%%patch50000 -p1
@@ -839,6 +839,7 @@ BuildConfig() {
                CONFIG_HIGHMEM64G=y
                CONFIG_X86_PAE=y
                CONFIG_NUMA=n
+               CONFIG_PAGE_TABLE_ISOLATION=y
        %endif
 %endif
 
@@ -892,7 +893,7 @@ EOCONFIG
 
 cd %{objdir}
 install -d arch/%{target_arch_dir}
-BuildConfig > %{defconfig}
+BuildConfig %{!?with_debuginfo:| %{__sed} -e 's/CONFIG_DEBUG_INFO=y/# CONFIG_DEBUG_INFO is not set/'} > %{defconfig}
 ln -sf %{defconfig} .config
 cd -
 
@@ -998,6 +999,7 @@ if cp -al %{srcdir}/COPYING $RPM_BUILD_ROOT/COPYING 2>/dev/null; then
 fi
 
 cp -a$l %{srcdir}/* $RPM_BUILD_ROOT%{_kernelsrcdir}
+%{__rm} -r $RPM_BUILD_ROOT%{_kernelsrcdir}/scripts/kconfig/tests
 cp -a %{objdir}/Module.symvers $RPM_BUILD_ROOT%{_kernelsrcdir}
 cp -aL %{objdir}/.config $RPM_BUILD_ROOT%{_kernelsrcdir}
 cp -a %{objdir}/include $RPM_BUILD_ROOT%{_kernelsrcdir}
@@ -1042,7 +1044,7 @@ done
 %if %{with doc}
 # move to %{_docdir} so we wouldn't depend on any kernel package for dirs
 install -d $RPM_BUILD_ROOT%{_docdir}
-mv $RPM_BUILD_ROOT{%{_kernelsrcdir}/Documentation,%{_docdir}/%{name}-%{version}}
+%{__mv} $RPM_BUILD_ROOT{%{_kernelsrcdir}/Documentation,%{_docdir}/%{name}-%{version}}
 
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/dontdiff
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/Makefile
@@ -1389,7 +1391,6 @@ fi
 %{_kernelsrcdir}/kernel/bounds.c
 %{_kernelsrcdir}/scripts/basic/*.c
 %attr(755,root,root) %{_kernelsrcdir}/scripts/kconfig/*.sh
-%{_kernelsrcdir}/scripts/kconfig/*.in
 %{_kernelsrcdir}/scripts/kconfig/*.pl
 %{_kernelsrcdir}/scripts/kconfig/*.glade
 %{_kernelsrcdir}/scripts/kconfig/*.cc
@@ -1407,6 +1408,7 @@ fi
 %{_kernelsrcdir}/scripts/mkmakefile
 %{_kernelsrcdir}/scripts/module-common.lds
 %attr(755,root,root) %{_kernelsrcdir}/scripts/setlocalversion
+%{_kernelsrcdir}/scripts/subarch.include
 %{_kernelsrcdir}/scripts/*.c
 %{_kernelsrcdir}/scripts/*.h
 %attr(755,root,root) %{_kernelsrcdir}/scripts/*.sh
@@ -1479,6 +1481,7 @@ fi
 %exclude %{_kernelsrcdir}/scripts/mod
 %exclude %{_kernelsrcdir}/scripts/module-common.lds
 %exclude %{_kernelsrcdir}/scripts/setlocalversion
+%exclude %{_kernelsrcdir}/scripts/subarch.include
 %exclude %{_kernelsrcdir}/scripts/*.c
 %exclude %{_kernelsrcdir}/scripts/*.h
 %exclude %{_kernelsrcdir}/scripts/*.sh
This page took 0.042293 seconds and 4 git commands to generate.