]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
- up to 4.4.113; vserver updated to 2.3.9.6
[packages/kernel.git] / kernel.spec
index 01616544fa423d339a0cea2d56ed5bfe37492877..280b902fef845055a4c1e2b22c10cb5888b1557b 100644 (file)
@@ -30,7 +30,9 @@
 %bcond_without esfq            # esfq support
 %bcond_without ipv6            # ipv6 support
 
-%bcond_with    vserver         # support for VServer
+%bcond_without vserver         # support for VServer
+
+%bcond_with    rt              # real-time kernel (CONFIG_PREEMPT_RT) for low latencies
 
 %bcond_with    vanilla         # don't include any patches
 %bcond_with    rescuecd        # build kernel for our rescue
@@ -70,7 +72,7 @@
 
 %define                rel             1
 %define                basever         4.4
-%define                postver         .26
+%define                postver         .113
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       -%{basever}
@@ -97,6 +99,9 @@
 %if %{without pae}
 %define                alt_kernel      nopae
 %endif
+%if %{with rt}
+%define                alt_kernel      rt
+%endif
 
 # kernel release (used in filesystem and eventually in uname -r)
 # modules will be looked from /lib/modules/%{kernel_release}
@@ -119,7 +124,7 @@ Source0:    http://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
 # Source0-md5: 9a78fa2eb6c68ca5a40ed5af08142599
 %if "%{postver}" != ".0"
 Patch0:                http://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  7d7a6ecef54f8ed944309627d9ba3fd4
+# Patch0-md5:  b480cea7675b9f0394ecb99061bb0793
 %endif
 Source1:       kernel.sysconfig
 
@@ -141,6 +146,7 @@ Source25:   kernel-ia64.config
 
 Source41:      kernel-patches.config
 Source43:      kernel-vserver.config
+Source44:      kernel-rt.config
 
 Source55:      kernel-imq.config
 
@@ -186,8 +192,8 @@ Patch59:    kernel-rndis_host-wm5.patch
 # http://patches.aircrack-ng.org/hostap-kernel-2.6.18.patch
 Patch85:       kernel-hostap.patch
 
-%define        vserver_patch 3.18.5-vs2.3.7.3
-# http://vserver.13thfloor.at/Experimental/patch-3.18.5-vs2.3.7.3.diff
+%define        vserver_patch 4.4.111-vs2.3.9.6
+# http://vserver.13thfloor.at/Experimental/patch-4.4.113-vs2.3.9.6.diff
 # note there are additional patches from above url:
 # - *fix* are real fixes (we want these)
 # - *feat* are new features/tests (we don't want these)
@@ -215,6 +221,10 @@ Patch250:  kernel-fix_256colors_menuconfig.patch
 # https://patchwork.kernel.org/patch/236261/
 Patch400:      kernel-virtio-gl-accel.patch
 
+# https://rt.wiki.kernel.org/
+# https://www.kernel.org/pub/linux/kernel/projects/rt/4.4/patch-4.4.30-rt41.patch.xz
+Patch500:      kernel-rt.patch
+
 Patch2000:     kernel-small_fixes.patch
 Patch2001:     kernel-pwc-uncompress.patch
 Patch2003:     kernel-regressions.patch
@@ -242,7 +252,7 @@ BuildRequires:      elftoaout
 BuildRequires: uboot-mkimage
 %endif
 BuildRequires: /sbin/depmod
-BuildRequires: gcc >= 5:3.2
+BuildRequires: gcc >= 6:7.2.0-6
 BuildRequires: xz >= 1:4.999.7
 AutoReqProv:   no
 BuildRequires: hostname
@@ -306,7 +316,7 @@ Conflicts:  reiserfsprogs < 3.6.3
 Conflicts:     rpm < 4.4.2-0.2
 Conflicts:     udev < 1:081
 Conflicts:     util-linux < 2.10o
-Conflicts:     util-vserver < 0.30.216
+Conflicts:     util-vserver < 0.30.216-1.pre3126.3
 Conflicts:     xfsprogs < 2.6.0
 %if %{without pae}
 ExclusiveArch: i686 pentium3 pentium4 athlon
@@ -390,6 +400,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %{?with_fbcondecor:Fbsplash/fbcondecor - enabled }\
 %{?with_nfsroot:Root on NFS - enabled}\
 %{?with_vserver:Linux-VServer - %{vserver_patch}}\
+%{?with_rt:CONFIG_PREEMPT_RT - enabled}\
 
 %define Features %(echo "%{__features}" | sed '/^$/d')
 
@@ -656,7 +667,10 @@ cd linux-%{basever}
 #
 
 # kernel-pom-ng-IPV4OPTSSTRIP.patch
+%if %{without rt}
+# fails on -Werror=incompatible-pointer-types
 %patch10 -p1
+%endif
 
 # kernel-owner-xid.patch
 %if %{with vserver}
@@ -681,8 +695,11 @@ cd linux-%{basever}
 %patch53 -p1
 %endif
 
+%if %{without rt}
+# fails on -Werror=incompatible-pointer-types
 %patch55 -p1
 %patch56 -p1
+%endif
 
 # kernel-rndis_host-wm5.patch
 %patch59 -p1
@@ -706,13 +723,21 @@ cd linux-%{basever}
 %patch7000 -p1
 %endif
 
+%if %{with rt}
+%patch500 -p1
+rm -f localversion-rt
+%endif
+
 # apparmor
 %patch5000 -p1
 
 %patch250 -p1
 
 # virtio-gl
+%if %{without rt}
+# fails on -Werror=incompatible-pointer-types
 %patch400 -p1
+%endif
 
 %endif # vanilla
 
@@ -912,6 +937,9 @@ EOCONFIG
 %endif
 %if %{with vserver}
                %{SOURCE43} \
+%endif
+%if %{with rt}
+               %{SOURCE44} \
 %endif
                %{SOURCE41} %{?0:patches} \
 %endif
This page took 0.090741 seconds and 4 git commands to generate.