]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
- up to 5.0.1
[packages/kernel.git] / kernel.spec
index 8490002f333cfa504fa2d307589f8896db0ce3ad..1d786ef2bb17530f8ef60d5535cb065ee656f137 100644 (file)
@@ -29,7 +29,6 @@
 %bcond_without ipv6            # ipv6 support
 
 %bcond_without aufs            # aufs4 support
-%bcond_without apparmor        # UBUNTU SAUCE apparmor patches
 
 %bcond_with    vserver         # support for VServer
 
@@ -68,9 +67,9 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             2
-%define                basever         4.14
-%define                postver         .13
+%define                rel             1
+%define                basever         5.0
+%define                postver         .1
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       %{nil}
@@ -118,11 +117,11 @@ Release:  %{rel}
 Epoch:         3
 License:       GPL v2
 Group:         Base/Kernel
-Source0:       https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
-# Source0-md5: bacdb9ffdcd922aa069a5e1520160e24
+Source0:       https://www.kernel.org/pub/linux/kernel/v5.x/linux-%{basever}.tar.xz
+# Source0-md5: 7381ce8aac80a01448e065ce795c19c0
 %if "%{postver}" != ".0"
-Patch0:                https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  9ec660112113d68ab28ed0cac4ea3e91
+Patch0:                https://www.kernel.org/pub/linux/kernel/v5.x/patch-%{version}.xz
+# Patch0-md5:  488f0f1b00a0861b4c3ddf578f1bd548
 %endif
 Source1:       kernel.sysconfig
 
@@ -196,7 +195,7 @@ Patch101:   kernel-vserver-fixes.patch
 # Patch creation:
 # git clone git://github.com/sfjro/aufs4-standalone.git
 # cd aufs4-standalone
-# git checkout -b aufs4.14 origin/aufs4.14
+# git checkout -b aufs4.17 origin/aufs4.17
 # cat aufs4-kbuild.patch aufs4-base.patch aufs4-mmap.patch aufs4-standalone.patch > ~/rpm/packages/kernel/kernel-aufs4.patch
 # rm -rf linux && mkdir linux; cp -a Documentation fs include linux
 # diff -urN /usr/share/empty linux | filterdiff -x linux/include/uapi/linux/Kbuild >> ~/rpm/packages/kernel/kernel-aufs4.patch
@@ -215,10 +214,7 @@ Patch500:  kernel-rt.patch
 Patch2000:     kernel-small_fixes.patch
 Patch2001:     kernel-pwc-uncompress.patch
 Patch2003:     kernel-regressions.patch
-
-# https://gitlab.com/apparmor/apparmor/tree/master/kernel-patches/v4.14
-Patch5001:     0012-apparmor-add-base-infastructure-for-socket-mediation.patch
-Patch5002:     0001-UBUNTU-SAUCE-apparmor-af_unix-mediation.patch
+Patch2004:     xfs-reclaim-hack.patch
 
 # for rescuecd
 # based on ftp://ftp.leg.uct.ac.za/pub/linux/rip/tmpfs_root-2.6.30.diff.gz
@@ -237,7 +233,7 @@ BuildRequires:      binutils >= 3:2.18
 BuildRequires: elftoaout
 %endif
 BuildRequires: elfutils-devel
-BuildRequires: gcc >= 5:3.2
+BuildRequires: gcc >= 6:7.2.0-6
 BuildRequires: gcc-plugin-devel
 BuildRequires: hostname
 BuildRequires: kmod >= 12-2
@@ -250,11 +246,11 @@ BuildRequires:    uboot-mkimage
 %endif
 BuildRequires: xz >= 1:4.999.7
 Requires(post):        coreutils
-Requires(post):        geninitrd >= 12749
+Requires(post):        geninitrd >= 12757-8
 Requires(post):        kmod >= 12-2
 Requires:      /sbin/depmod
 Requires:      coreutils
-Requires:      geninitrd >= 12749
+Requires:      geninitrd >= 12757-8
 Requires:      kmod >= 12-2
 %if %{with pae}
 %ifarch i686 athlon pentium3 pentium4
@@ -682,12 +678,6 @@ cd linux-%{basever}
 rm -f localversion-rt
 %endif
 
-# apparmor
-%if %{with apparmor}
-%patch5001 -p1
-%patch5002 -p1
-%endif
-
 %patch250 -p1
 
 %endif # vanilla
@@ -696,6 +686,7 @@ rm -f localversion-rt
 %patch2000 -p1
 %patch2001 -p1
 #%patch2003 -p1
+%patch2004 -p1
 
 # Do not remove this, please!
 #%%patch50000 -p1
@@ -1397,8 +1388,6 @@ fi
 %{_kernelsrcdir}/kernel/bounds.c
 %{_kernelsrcdir}/scripts/basic/*.c
 %attr(755,root,root) %{_kernelsrcdir}/scripts/kconfig/*.sh
-%{_kernelsrcdir}/scripts/kconfig/*.in
-%{_kernelsrcdir}/scripts/kconfig/*_shipped
 %{_kernelsrcdir}/scripts/kconfig/*.pl
 %{_kernelsrcdir}/scripts/kconfig/*.glade
 %{_kernelsrcdir}/scripts/kconfig/*.cc
@@ -1416,6 +1405,7 @@ fi
 %{_kernelsrcdir}/scripts/mkmakefile
 %{_kernelsrcdir}/scripts/module-common.lds
 %attr(755,root,root) %{_kernelsrcdir}/scripts/setlocalversion
+%{_kernelsrcdir}/scripts/subarch.include
 %{_kernelsrcdir}/scripts/*.c
 %{_kernelsrcdir}/scripts/*.h
 %attr(755,root,root) %{_kernelsrcdir}/scripts/*.sh
@@ -1488,6 +1478,7 @@ fi
 %exclude %{_kernelsrcdir}/scripts/mod
 %exclude %{_kernelsrcdir}/scripts/module-common.lds
 %exclude %{_kernelsrcdir}/scripts/setlocalversion
+%exclude %{_kernelsrcdir}/scripts/subarch.include
 %exclude %{_kernelsrcdir}/scripts/*.c
 %exclude %{_kernelsrcdir}/scripts/*.h
 %exclude %{_kernelsrcdir}/scripts/*.sh
This page took 0.036133 seconds and 4 git commands to generate.