]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
- rel 3 (with reclaim xfs hack)
[packages/kernel.git] / kernel.spec
index b70ff2e83050b3e1c4e2430d4242731ab5795d37..1630ab58d8cde7c942ff28222e4f730c74f6e810 100644 (file)
@@ -29,7 +29,6 @@
 %bcond_without ipv6            # ipv6 support
 
 %bcond_without aufs            # aufs4 support
-%bcond_without apparmor        # UBUNTU SAUCE apparmor patches
 
 %bcond_with    vserver         # support for VServer
 
@@ -68,8 +67,8 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             0.1
-%define                basever         4.14
+%define                rel             3
+%define                basever         4.20
 %define                postver         .0
 
 # define this to '-%{basever}' for longterm branch
@@ -119,10 +118,10 @@ Epoch:            3
 License:       GPL v2
 Group:         Base/Kernel
 Source0:       https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
-# Source0-md5: bacdb9ffdcd922aa069a5e1520160e24
+# Source0-md5: d39dd4ba2d5861c54b90d49be19eaf31
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  665b55e1f24ec56de55f7d0302d7c4f5
+# Patch0-md5:  1e33e1e7f80f8dbe4a0274ba274626b4
 %endif
 Source1:       kernel.sysconfig
 
@@ -196,7 +195,7 @@ Patch101:   kernel-vserver-fixes.patch
 # Patch creation:
 # git clone git://github.com/sfjro/aufs4-standalone.git
 # cd aufs4-standalone
-# git checkout -b aufs4.14 origin/aufs4.14
+# git checkout -b aufs4.17 origin/aufs4.17
 # cat aufs4-kbuild.patch aufs4-base.patch aufs4-mmap.patch aufs4-standalone.patch > ~/rpm/packages/kernel/kernel-aufs4.patch
 # rm -rf linux && mkdir linux; cp -a Documentation fs include linux
 # diff -urN /usr/share/empty linux | filterdiff -x linux/include/uapi/linux/Kbuild >> ~/rpm/packages/kernel/kernel-aufs4.patch
@@ -215,10 +214,7 @@ Patch500:  kernel-rt.patch
 Patch2000:     kernel-small_fixes.patch
 Patch2001:     kernel-pwc-uncompress.patch
 Patch2003:     kernel-regressions.patch
-
-# https://gitlab.com/apparmor/apparmor/tree/master/kernel-patches/v4.14
-Patch5001:     0012-apparmor-add-base-infastructure-for-socket-mediation.patch
-Patch5002:     0001-UBUNTU-SAUCE-apparmor-af_unix-mediation.patch
+Patch2004:     xfs-reclaim-hack.patch
 
 # for rescuecd
 # based on ftp://ftp.leg.uct.ac.za/pub/linux/rip/tmpfs_root-2.6.30.diff.gz
@@ -237,7 +233,7 @@ BuildRequires:      binutils >= 3:2.18
 BuildRequires: elftoaout
 %endif
 BuildRequires: elfutils-devel
-BuildRequires: gcc >= 5:3.2
+BuildRequires: gcc >= 6:7.2.0-6
 BuildRequires: gcc-plugin-devel
 BuildRequires: hostname
 BuildRequires: kmod >= 12-2
@@ -250,11 +246,11 @@ BuildRequires:    uboot-mkimage
 %endif
 BuildRequires: xz >= 1:4.999.7
 Requires(post):        coreutils
-Requires(post):        geninitrd >= 12749
+Requires(post):        geninitrd >= 12757-8
 Requires(post):        kmod >= 12-2
 Requires:      /sbin/depmod
 Requires:      coreutils
-Requires:      geninitrd >= 12749
+Requires:      geninitrd >= 12757-8
 Requires:      kmod >= 12-2
 %if %{with pae}
 %ifarch i686 athlon pentium3 pentium4
@@ -682,12 +678,6 @@ cd linux-%{basever}
 rm -f localversion-rt
 %endif
 
-# apparmor
-%if %{with apparmor}
-%patch5001 -p1
-%patch5002 -p1
-%endif
-
 %patch250 -p1
 
 %endif # vanilla
@@ -696,10 +686,13 @@ rm -f localversion-rt
 %patch2000 -p1
 %patch2001 -p1
 #%patch2003 -p1
+%patch2004 -p1
 
 # Do not remove this, please!
 #%%patch50000 -p1
 
+chmod 755 tools/objtool/sync-check.sh
+
 # Fix EXTRAVERSION in main Makefile
 sed -i 's#EXTRAVERSION =.*#EXTRAVERSION = %{?alt_kernel:.%{alt_kernel}}#g' Makefile
 
@@ -1013,6 +1006,13 @@ for dir in $(cd %{objdir} && find arch -name generated -type d); do
        find $RPM_BUILD_ROOT%{_kernelsrcdir}/$dir -name '.*.cmd' -exec rm "{}" ";"
 done
 
+%ifarch %{x8664} x32
+# Needed for CONFIG_STACK_VALIDATION / ORC_UNWINDER enabled builds
+install -d $RPM_BUILD_ROOT%{_kernelsrcdir}/tools/objtool
+cp -a %{objdir}/tools/objtool/fixdep $RPM_BUILD_ROOT%{_kernelsrcdir}/tools/objtool
+cp -a %{objdir}/tools/objtool/objtool $RPM_BUILD_ROOT%{_kernelsrcdir}/tools/objtool
+%endif
+
 # version.h location changed in 3.7, but a lot of external modules don't know about it
 # add a compatibility symlink
 ln -s ../generated/uapi/linux/version.h $RPM_BUILD_ROOT%{_kernelsrcdir}/include/linux/version.h
@@ -1388,8 +1388,6 @@ fi
 %{_kernelsrcdir}/kernel/bounds.c
 %{_kernelsrcdir}/scripts/basic/*.c
 %attr(755,root,root) %{_kernelsrcdir}/scripts/kconfig/*.sh
-%{_kernelsrcdir}/scripts/kconfig/*.in
-%{_kernelsrcdir}/scripts/kconfig/*_shipped
 %{_kernelsrcdir}/scripts/kconfig/*.pl
 %{_kernelsrcdir}/scripts/kconfig/*.glade
 %{_kernelsrcdir}/scripts/kconfig/*.cc
@@ -1407,6 +1405,7 @@ fi
 %{_kernelsrcdir}/scripts/mkmakefile
 %{_kernelsrcdir}/scripts/module-common.lds
 %attr(755,root,root) %{_kernelsrcdir}/scripts/setlocalversion
+%{_kernelsrcdir}/scripts/subarch.include
 %{_kernelsrcdir}/scripts/*.c
 %{_kernelsrcdir}/scripts/*.h
 %attr(755,root,root) %{_kernelsrcdir}/scripts/*.sh
@@ -1414,6 +1413,10 @@ fi
 %{_kernelsrcdir}/scripts/selinux/mdp/*.c
 %exclude %dir %{_kernelsrcdir}/security
 %exclude %dir %{_kernelsrcdir}/security/selinux
+%ifarch %{x8664} x32
+%attr(755,root,root) %{_kernelsrcdir}/tools/objtool/fixdep
+%attr(755,root,root) %{_kernelsrcdir}/tools/objtool/objtool
+%endif
 
 %if %{with doc}
 %files doc
@@ -1475,6 +1478,7 @@ fi
 %exclude %{_kernelsrcdir}/scripts/mod
 %exclude %{_kernelsrcdir}/scripts/module-common.lds
 %exclude %{_kernelsrcdir}/scripts/setlocalversion
+%exclude %{_kernelsrcdir}/scripts/subarch.include
 %exclude %{_kernelsrcdir}/scripts/*.c
 %exclude %{_kernelsrcdir}/scripts/*.h
 %exclude %{_kernelsrcdir}/scripts/*.sh
@@ -1490,6 +1494,10 @@ fi
 %{_kernelsrcdir}/security
 %exclude %{_kernelsrcdir}/security/selinux/include
 %{_kernelsrcdir}/tools/*
+%ifarch %{x8664} x32
+%exclude %{_kernelsrcdir}/tools/objtool/fixdep
+%exclude %{_kernelsrcdir}/tools/objtool/objtool
+%endif
 %{_kernelsrcdir}/usr
 %{_kernelsrcdir}/COPYING
 %{_kernelsrcdir}/CREDITS
This page took 0.703392 seconds and 4 git commands to generate.