]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
- up to 4.9.236
[packages/kernel.git] / kernel.spec
index b6ec6598424ee51aa01f751c8129bbe4e6565985..1609759d637fa6e3d751150b8ce083a22ef40086 100644 (file)
@@ -73,7 +73,7 @@
 
 %define                rel             1
 %define                basever         4.9
-%define                postver         .189
+%define                postver         .236
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       -%{basever}
@@ -125,7 +125,7 @@ Source0:    https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
 # Source0-md5: 0a68ef3615c64bd5ee54a3320e46667d
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  d3c9a5962cd263626c6cfc3d83d8f13d
+# Patch0-md5:  a3c40df83978ac99305db79c2b76719d
 %endif
 Source1:       kernel.sysconfig
 
@@ -187,8 +187,8 @@ Patch59:    kernel-rndis_host-wm5.patch
 # http://patches.aircrack-ng.org/hostap-kernel-2.6.18.patch
 Patch85:       kernel-hostap.patch
 
-%define        vserver_patch 4.9.135-vs2.3.9.8
-# http://vserver.13thfloor.at/Experimental/patch-4.9.135-vs2.3.9.8.diff
+%define        vserver_patch 4.9.217-vs2.3.9.12
+# http://vserver.13thfloor.at/Experimental/patch-4.9.217-vs2.3.9.12.diff
 # note there are additional patches from above url:
 # - *fix* are real fixes (we want these)
 # - *feat* are new features/tests (we don't want these)
@@ -254,11 +254,11 @@ BuildRequires:    uboot-mkimage
 %endif
 BuildRequires: xz >= 1:4.999.7
 Requires(post):        coreutils
-Requires(post):        geninitrd >= 12749
+Requires(post):        geninitrd >= 12787-6
 Requires(post):        kmod >= 12-2
 Requires:      /sbin/depmod
 Requires:      coreutils
-Requires:      geninitrd >= 12749
+Requires:      geninitrd >= 12787-6
 Requires:      kmod >= 12-2
 %if %{with pae}
 %ifarch i686 athlon pentium3 pentium4
@@ -732,6 +732,31 @@ sed -i 's#EXTRAVERSION =.*#EXTRAVERSION = %{?alt_kernel:.%{alt_kernel}}#g' Makef
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' -o -name '.gitignore' ')' -print0 | xargs -0 -r -l512 rm -f
 
+find -name '*.py' -print0 | \
+       xargs -0 %{__sed} -i -e '1s,/usr/bin/python,%{__python},' \
+                            -e '1s,/usr/bin/env python,%{__python},' \
+                            -e '1s,/usr/bin/env python3,%{__python3},'
+
+%{__sed} -i -e '1s,/usr/bin/python,%{__python},' \
+           -e '1s,/usr/bin/env python,%{__python},' \
+           -e '1s,/usr/bin/env python3,%{__python3},' \
+       drivers/staging/greybus/tools/lbtest \
+       scripts/bloat-o-meter \
+       scripts/diffconfig \
+       scripts/show_delta \
+       tools/kvm/kvm_stat/kvm_stat
+
+find -name '*.pl' -print0 | \
+       xargs -0 %{__sed} -i -e '1s,/usr/bin/env perl,%{__perl},' \
+
+%{__sed} -i -e '1s,/usr/bin/env perl,%{__perl},' \
+       scripts/dtc/dt_to_config \
+       scripts/cleanfile \
+       scripts/cleanpatch \
+       scripts/get_dvb_firmware \
+       scripts/kernel-doc \
+       scripts/stackdelta
+
 %build
 install -d %{objdir}
 cat > %{targetobj}.mk <<'EOF'
This page took 0.030189 seconds and 4 git commands to generate.