]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel-virtio-gl-accel.patch
- 3.1.101
[packages/kernel.git] / kernel-virtio-gl-accel.patch
index 4748aca465bec5075dc7c29d1acc62604d8114a3..4a876161dc3734bc663664a78b544ff9f8049604 100644 (file)
@@ -4,8 +4,8 @@ index 30879df..35699a0 100644
 --- a/drivers/gpu/Makefile
 +++ b/drivers/gpu/Makefile
 @@ -1 +1 @@
--obj-y                 += drm/ vga/ stub/
-+obj-y                 += drm/ vga/ stub/ misc/
+-obj-y                 += drm/ vga/
++obj-y                 += drm/ vga/ misc/
 diff --git a/drivers/gpu/misc/Kconfig b/drivers/gpu/misc/Kconfig
 new file mode 100644
 index 0000000..50043d3
@@ -306,7 +306,7 @@ index 0000000..8882bda
 +      return 0;
 +}
 +
-+static void __devexit glmem_remove(struct virtio_device *vdev)
++static void glmem_remove(struct virtio_device *vdev)
 +{
 +      vdev->config->reset(vdev);
 +      misc_deregister(&glmem_dev);
@@ -325,7 +325,7 @@ index 0000000..8882bda
 +      },
 +      .id_table =     id_table,
 +      .probe =        glmem_probe,
-+      .remove =       __devexit_p(glmem_remove),
++      .remove =       glmem_remove,
 +};
 +
 +static int __init glmem_init(void)
@@ -357,17 +357,14 @@ index 3d94a14..9a9a6cc 100644
  
  config VGASTATE
         tristate
-diff --git a/include/linux/virtio_ids.h b/include/linux/virtio_ids.h
-index 06660c0..663b496 100644
---- a/include/linux/virtio_ids.h
-+++ b/include/linux/virtio_ids.h
-@@ -12,6 +12,7 @@
+--- linux-3.4/include/uapi/linux/virtio_ids.h~ 2012-05-21 08:42:02.000000000 +0200
++++ linux-3.4/include/uapi/linux/virtio_ids.h  2012-05-21 09:02:40.065957644 +0200
+@@ -34,6 +34,7 @@
  #define VIRTIO_ID_CONSOLE     3 /* virtio console */
  #define VIRTIO_ID_RNG         4 /* virtio ring */
  #define VIRTIO_ID_BALLOON     5 /* virtio balloon */
 +#define VIRTIO_ID_GL          6 /* virtio usermem */
+ #define VIRTIO_ID_RPMSG               7 /* virtio remote processor messaging */
+ #define VIRTIO_ID_SCSI                8 /* virtio scsi */
  #define VIRTIO_ID_9P          9 /* 9p virtio console */
- #endif /* _LINUX_VIRTIO_IDS_H */
-
 
This page took 0.079895 seconds and 4 git commands to generate.