]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel-pom-ng-IPV4OPTSSTRIP.patch
- 5.18.5
[packages/kernel.git] / kernel-pom-ng-IPV4OPTSSTRIP.patch
index cb970ec23126bb980256fcd03e239faf82ff378d..ae696e136e0c4aca3edea4d58fb14b0ba8fc6250 100644 (file)
@@ -1,9 +1,9 @@
-diff -NurpP --minimal linux-2.6.21.b/net/ipv4/netfilter/Kconfig linux-2.6.21.a/net/ipv4/netfilter/Kconfig
---- linux-2.6.21.b/net/ipv4/netfilter/Kconfig  2007-05-30 11:11:52.000000000 +0200
-+++ linux-2.6.21.a/net/ipv4/netfilter/Kconfig  2007-05-30 11:18:08.000000000 +0200
-@@ -668,5 +668,15 @@ config IP_NF_ARP_MANGLE
-         Allows altering the ARP packet payload: source and destination
-         hardware and network addresses.
+diff -ur linux-5.9/net/ipv4/netfilter.org/Kconfig linux-5.9/net/ipv4/netfilter/Kconfig
+--- linux-5.9/net/ipv4/netfilter.org/Kconfig   2020-10-11 23:15:50.000000000 +0200
++++ linux-5.9/net/ipv4/netfilter/Kconfig       2020-11-03 13:07:22.874511004 +0100
+@@ -356,5 +356,15 @@
+ endif # IP_NF_ARPTABLES
  
 +config IP_NF_TARGET_IPV4OPTSSTRIP
 +      tristate  'IPV4OPTSSTRIP target support'
@@ -17,9 +17,10 @@ diff -NurpP --minimal linux-2.6.21.b/net/ipv4/netfilter/Kconfig linux-2.6.21.a/n
 +
  endmenu
  
---- linux-5.2/net/ipv4/netfilter/Makefile~     2019-07-08 00:41:56.000000000 +0200
-+++ linux-5.2/net/ipv4/netfilter/Makefile      2019-07-08 09:01:35.241471623 +0200
-@@ -48,6 +48,7 @@ obj-$(CONFIG_IP_NF_MATCH_RPFILTER) += ip
+diff -ur linux-5.9/net/ipv4/netfilter.org/Makefile linux-5.9/net/ipv4/netfilter/Makefile
+--- linux-5.9/net/ipv4/netfilter.org/Makefile  2020-10-11 23:15:50.000000000 +0200
++++ linux-5.9/net/ipv4/netfilter/Makefile      2020-11-03 13:07:22.874511004 +0100
+@@ -48,6 +48,7 @@
  # targets
  obj-$(CONFIG_IP_NF_TARGET_CLUSTERIP) += ipt_CLUSTERIP.o
  obj-$(CONFIG_IP_NF_TARGET_ECN) += ipt_ECN.o
@@ -57,7 +58,7 @@ diff -NurpP --minimal linux-2.6.21.b/net/ipv4/netfilter/ipt_IPV4OPTSSTRIP.c linu
 +      unsigned char *optiph;
 +      int l;
 +      
-+      if (!skb_make_writable(skb, skb->len))
++      if (skb_ensure_writable(skb, skb->len))
 +              return NF_DROP;
 + 
 +      iph = ip_hdr(skb);
This page took 0.033788 seconds and 4 git commands to generate.