]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel-imq.patch
- up to 4.9.258; rediff all patches that didn't apply with --fuzz=0
[packages/kernel.git] / kernel-imq.patch
index 328828087084867192d75992ca53238062a8f39b..baf5f028586f3bacd16e855b1cc0fb0d7c53cc4c 100644 (file)
@@ -1,7 +1,6 @@
-diff --git a/drivers/net/Kconfig b/drivers/net/Kconfig
-index 95c32f2..93fada5 100644
---- a/drivers/net/Kconfig
-+++ b/drivers/net/Kconfig
+diff -urNp -x '*.orig' linux-4.9/drivers/net/Kconfig linux-4.9/drivers/net/Kconfig
+--- linux-4.9/drivers/net/Kconfig      2021-02-24 15:35:10.207508334 +0100
++++ linux-4.9/drivers/net/Kconfig      2021-02-24 15:35:24.097940603 +0100
 @@ -260,6 +260,125 @@ config RIONET_RX_SIZE
        depends on RIONET
        default "128"
@@ -128,10 +127,9 @@ index 95c32f2..93fada5 100644
  config TUN
        tristate "Universal TUN/TAP device driver support"
        depends on INET
-diff --git a/drivers/net/Makefile b/drivers/net/Makefile
-index 7336cbd..d6d7ad4 100644
---- a/drivers/net/Makefile
-+++ b/drivers/net/Makefile
+diff -urNp -x '*.orig' linux-4.9/drivers/net/Makefile linux-4.9/drivers/net/Makefile
+--- linux-4.9/drivers/net/Makefile     2016-12-11 20:17:54.000000000 +0100
++++ linux-4.9/drivers/net/Makefile     2021-02-24 15:35:24.097940603 +0100
 @@ -11,6 +11,7 @@ obj-$(CONFIG_DUMMY) += dummy.o
  obj-$(CONFIG_EQUALIZER) += eql.o
  obj-$(CONFIG_IFB) += ifb.o
@@ -140,11 +138,9 @@ index 7336cbd..d6d7ad4 100644
  obj-$(CONFIG_MACVLAN) += macvlan.o
  obj-$(CONFIG_MACVTAP) += macvtap.o
  obj-$(CONFIG_MII) += mii.o
-diff --git a/drivers/net/imq.c b/drivers/net/imq.c
-new file mode 100644
-index 0000000..bc3b997
---- /dev/null
-+++ b/drivers/net/imq.c
+diff -urNp -x '*.orig' linux-4.9/drivers/net/imq.c linux-4.9/drivers/net/imq.c
+--- linux-4.9/drivers/net/imq.c        1970-01-01 01:00:00.000000000 +0100
++++ linux-4.9/drivers/net/imq.c        2021-02-24 15:35:24.097940603 +0100
 @@ -0,0 +1,907 @@
 +/*
 + *             Pseudo-driver for the intermediate queue device.
@@ -1053,11 +1049,9 @@ index 0000000..bc3b997
 +MODULE_DESCRIPTION("Pseudo-driver for the intermediate queue device. See https://github.com/imq/linuximq/wiki for more information.");
 +MODULE_LICENSE("GPL");
 +MODULE_ALIAS_RTNL_LINK("imq");
-diff --git a/include/linux/imq.h b/include/linux/imq.h
-new file mode 100644
-index 0000000..1babb09
---- /dev/null
-+++ b/include/linux/imq.h
+diff -urNp -x '*.orig' linux-4.9/include/linux/imq.h linux-4.9/include/linux/imq.h
+--- linux-4.9/include/linux/imq.h      1970-01-01 01:00:00.000000000 +0100
++++ linux-4.9/include/linux/imq.h      2021-02-24 15:35:24.097940603 +0100
 @@ -0,0 +1,13 @@
 +#ifndef _IMQ_H
 +#define _IMQ_H
@@ -1072,11 +1066,10 @@ index 0000000..1babb09
 +
 +#endif /* _IMQ_H */
 +
-diff --git a/include/linux/netdevice.h b/include/linux/netdevice.h
-index e16a2a9..4a1090a 100644
---- a/include/linux/netdevice.h
-+++ b/include/linux/netdevice.h
-@@ -3669,6 +3669,19 @@ static inline void netif_tx_unlock_bh(struct net_device *dev)
+diff -urNp -x '*.orig' linux-4.9/include/linux/netdevice.h linux-4.9/include/linux/netdevice.h
+--- linux-4.9/include/linux/netdevice.h        2021-02-24 15:35:11.047534473 +0100
++++ linux-4.9/include/linux/netdevice.h        2021-02-24 15:35:24.101274040 +0100
+@@ -3694,6 +3694,19 @@ static inline void netif_tx_unlock_bh(st
        }                                               \
  }
  
@@ -1096,11 +1089,9 @@ index e16a2a9..4a1090a 100644
  static inline void netif_tx_disable(struct net_device *dev)
  {
        unsigned int i;
-diff --git a/include/linux/netfilter/xt_IMQ.h b/include/linux/netfilter/xt_IMQ.h
-new file mode 100644
-index 0000000..9b07230
---- /dev/null
-+++ b/include/linux/netfilter/xt_IMQ.h
+diff -urNp -x '*.orig' linux-4.9/include/linux/netfilter/xt_IMQ.h linux-4.9/include/linux/netfilter/xt_IMQ.h
+--- linux-4.9/include/linux/netfilter/xt_IMQ.h 1970-01-01 01:00:00.000000000 +0100
++++ linux-4.9/include/linux/netfilter/xt_IMQ.h 2021-02-24 15:35:24.101274040 +0100
 @@ -0,0 +1,9 @@
 +#ifndef _XT_IMQ_H
 +#define _XT_IMQ_H
@@ -1111,11 +1102,9 @@ index 0000000..9b07230
 +
 +#endif /* _XT_IMQ_H */
 +
-diff --git a/include/linux/netfilter_ipv4/ipt_IMQ.h b/include/linux/netfilter_ipv4/ipt_IMQ.h
-new file mode 100644
-index 0000000..7af320f
---- /dev/null
-+++ b/include/linux/netfilter_ipv4/ipt_IMQ.h
+diff -urNp -x '*.orig' linux-4.9/include/linux/netfilter_ipv4/ipt_IMQ.h linux-4.9/include/linux/netfilter_ipv4/ipt_IMQ.h
+--- linux-4.9/include/linux/netfilter_ipv4/ipt_IMQ.h   1970-01-01 01:00:00.000000000 +0100
++++ linux-4.9/include/linux/netfilter_ipv4/ipt_IMQ.h   2021-02-24 15:35:24.101274040 +0100
 @@ -0,0 +1,10 @@
 +#ifndef _IPT_IMQ_H
 +#define _IPT_IMQ_H
@@ -1127,11 +1116,9 @@ index 0000000..7af320f
 +
 +#endif /* _IPT_IMQ_H */
 +
-diff --git a/include/linux/netfilter_ipv6/ip6t_IMQ.h b/include/linux/netfilter_ipv6/ip6t_IMQ.h
-new file mode 100644
-index 0000000..198ac01
---- /dev/null
-+++ b/include/linux/netfilter_ipv6/ip6t_IMQ.h
+diff -urNp -x '*.orig' linux-4.9/include/linux/netfilter_ipv6/ip6t_IMQ.h linux-4.9/include/linux/netfilter_ipv6/ip6t_IMQ.h
+--- linux-4.9/include/linux/netfilter_ipv6/ip6t_IMQ.h  1970-01-01 01:00:00.000000000 +0100
++++ linux-4.9/include/linux/netfilter_ipv6/ip6t_IMQ.h  2021-02-24 15:35:24.101274040 +0100
 @@ -0,0 +1,10 @@
 +#ifndef _IP6T_IMQ_H
 +#define _IP6T_IMQ_H
@@ -1143,10 +1130,9 @@ index 0000000..198ac01
 +
 +#endif /* _IP6T_IMQ_H */
 +
-diff --git a/include/linux/skbuff.h b/include/linux/skbuff.h
-index 32810f2..4ce1d0a 100644
---- a/include/linux/skbuff.h
-+++ b/include/linux/skbuff.h
+diff -urNp -x '*.orig' linux-4.9/include/linux/skbuff.h linux-4.9/include/linux/skbuff.h
+--- linux-4.9/include/linux/skbuff.h   2021-02-24 15:35:11.060868221 +0100
++++ linux-4.9/include/linux/skbuff.h   2021-02-24 15:35:24.101274040 +0100
 @@ -39,6 +39,10 @@
  #include <linux/in6.h>
  #include <linux/if_packet.h>
@@ -1158,7 +1144,7 @@ index 32810f2..4ce1d0a 100644
  
  /* The interface for checksum offload between the stack and networking drivers
   * is as follows...
-@@ -654,6 +658,9 @@ struct sk_buff {
+@@ -660,6 +664,9 @@ struct sk_buff {
         * first. This is owned by whoever has the skb queued ATM.
         */
        char                    cb[48] __aligned(8);
@@ -1168,7 +1154,7 @@ index 32810f2..4ce1d0a 100644
  
        unsigned long           _skb_refdst;
        void                    (*destructor)(struct sk_buff *skb);
-@@ -663,6 +670,9 @@ struct sk_buff {
+@@ -669,6 +676,9 @@ struct sk_buff {
  #if defined(CONFIG_NF_CONNTRACK) || defined(CONFIG_NF_CONNTRACK_MODULE)
        struct nf_conntrack     *nfct;
  #endif
@@ -1178,7 +1164,7 @@ index 32810f2..4ce1d0a 100644
  #if IS_ENABLED(CONFIG_BRIDGE_NETFILTER)
        struct nf_bridge_info   *nf_bridge;
  #endif
-@@ -743,6 +753,9 @@ struct sk_buff {
+@@ -748,6 +758,9 @@ struct sk_buff {
        __u8                    offload_fwd_mark:1;
  #endif
        /* 2, 4 or 5 bit hole */
@@ -1188,7 +1174,7 @@ index 32810f2..4ce1d0a 100644
  
  #ifdef CONFIG_NET_SCHED
        __u16                   tc_index;       /* traffic control index */
-@@ -903,6 +916,12 @@ void kfree_skb_list(struct sk_buff *segs);
+@@ -908,6 +921,12 @@ void kfree_skb_list(struct sk_buff *segs
  void skb_tx_error(struct sk_buff *skb);
  void consume_skb(struct sk_buff *skb);
  void  __kfree_skb(struct sk_buff *skb);
@@ -1201,7 +1187,7 @@ index 32810f2..4ce1d0a 100644
  extern struct kmem_cache *skbuff_head_cache;
  
  void kfree_skb_partial(struct sk_buff *skb, bool head_stolen);
-@@ -3594,6 +3613,10 @@ static inline void __nf_copy(struct sk_buff *dst, const struct sk_buff *src,
+@@ -3640,6 +3659,10 @@ static inline void __nf_copy(struct sk_b
        if (copy)
                dst->nfctinfo = src->nfctinfo;
  #endif
@@ -1212,10 +1198,9 @@ index 32810f2..4ce1d0a 100644
  #if IS_ENABLED(CONFIG_BRIDGE_NETFILTER)
        dst->nf_bridge  = src->nf_bridge;
        nf_bridge_get(src->nf_bridge);
-diff --git a/include/net/netfilter/nf_queue.h b/include/net/netfilter/nf_queue.h
-index 2280cfe..ec8fa51 100644
---- a/include/net/netfilter/nf_queue.h
-+++ b/include/net/netfilter/nf_queue.h
+diff -urNp -x '*.orig' linux-4.9/include/net/netfilter/nf_queue.h linux-4.9/include/net/netfilter/nf_queue.h
+--- linux-4.9/include/net/netfilter/nf_queue.h 2016-12-11 20:17:54.000000000 +0100
++++ linux-4.9/include/net/netfilter/nf_queue.h 2021-02-24 15:35:24.101274040 +0100
 @@ -30,6 +30,12 @@ struct nf_queue_handler {
  void nf_register_queue_handler(struct net *net, const struct nf_queue_handler *qh);
  void nf_unregister_queue_handler(struct net *net);
@@ -1229,11 +1214,10 @@ index 2280cfe..ec8fa51 100644
  
  void nf_queue_entry_get_refs(struct nf_queue_entry *entry);
  void nf_queue_entry_release_refs(struct nf_queue_entry *entry);
-diff --git a/include/net/pkt_sched.h b/include/net/pkt_sched.h
-index cd334c9..6757228 100644
---- a/include/net/pkt_sched.h
-+++ b/include/net/pkt_sched.h
-@@ -105,6 +105,8 @@ int sch_direct_xmit(struct sk_buff *skb, struct Qdisc *q,
+diff -urNp -x '*.orig' linux-4.9/include/net/pkt_sched.h linux-4.9/include/net/pkt_sched.h
+--- linux-4.9/include/net/pkt_sched.h  2016-12-11 20:17:54.000000000 +0100
++++ linux-4.9/include/net/pkt_sched.h  2021-02-24 15:35:24.101274040 +0100
+@@ -105,6 +105,8 @@ int sch_direct_xmit(struct sk_buff *skb,
  
  void __qdisc_run(struct Qdisc *q);
  
@@ -1242,11 +1226,10 @@ index cd334c9..6757228 100644
  static inline void qdisc_run(struct Qdisc *q)
  {
        if (qdisc_run_begin(q))
-diff --git a/include/net/sch_generic.h b/include/net/sch_generic.h
-index e6aa0a2..08b37dc 100644
---- a/include/net/sch_generic.h
-+++ b/include/net/sch_generic.h
-@@ -518,6 +518,13 @@ static inline int qdisc_enqueue(struct sk_buff *skb, struct Qdisc *sch,
+diff -urNp -x '*.orig' linux-4.9/include/net/sch_generic.h linux-4.9/include/net/sch_generic.h
+--- linux-4.9/include/net/sch_generic.h        2021-02-24 15:35:11.077535407 +0100
++++ linux-4.9/include/net/sch_generic.h        2021-02-24 15:35:24.101274040 +0100
+@@ -523,6 +523,13 @@ static inline int qdisc_enqueue(struct s
        return sch->enqueue(skb, sch, to_free);
  }
  
@@ -1260,10 +1243,9 @@ index e6aa0a2..08b37dc 100644
  static inline bool qdisc_is_percpu_stats(const struct Qdisc *q)
  {
        return q->flags & TCQ_F_CPUSTATS;
-diff --git a/include/uapi/linux/netfilter.h b/include/uapi/linux/netfilter.h
-index d93f949..23fb6d1 100644
---- a/include/uapi/linux/netfilter.h
-+++ b/include/uapi/linux/netfilter.h
+diff -urNp -x '*.orig' linux-4.9/include/uapi/linux/netfilter.h linux-4.9/include/uapi/linux/netfilter.h
+--- linux-4.9/include/uapi/linux/netfilter.h   2016-12-11 20:17:54.000000000 +0100
++++ linux-4.9/include/uapi/linux/netfilter.h   2021-02-24 15:35:24.101274040 +0100
 @@ -14,7 +14,8 @@
  #define NF_QUEUE 3
  #define NF_REPEAT 4
@@ -1274,11 +1256,10 @@ index d93f949..23fb6d1 100644
  
  /* we overload the higher bits for encoding auxiliary data such as the queue
   * number or errno values. Not nice, but better than additional function
-diff --git a/net/core/dev.c b/net/core/dev.c
-index 6666b28..3e12add 100644
---- a/net/core/dev.c
-+++ b/net/core/dev.c
-@@ -141,6 +141,9 @@
+diff -urNp -x '*.orig' linux-4.9/net/core/dev.c linux-4.9/net/core/dev.c
+--- linux-4.9/net/core/dev.c   2021-02-24 15:35:11.220873200 +0100
++++ linux-4.9/net/core/dev.c   2021-02-24 15:35:24.101274040 +0100
+@@ -142,6 +142,9 @@
  #include <linux/netfilter_ingress.h>
  #include <linux/sctp.h>
  #include <linux/crash_dump.h>
@@ -1288,7 +1269,7 @@ index 6666b28..3e12add 100644
  
  #include "net-sysfs.h"
  
-@@ -2906,7 +2909,12 @@ static int xmit_one(struct sk_buff *skb, struct net_device *dev,
+@@ -2965,7 +2968,12 @@ static int xmit_one(struct sk_buff *skb,
        unsigned int len;
        int rc;
  
@@ -1301,7 +1282,7 @@ index 6666b28..3e12add 100644
                dev_queue_xmit_nit(skb, dev);
  
        len = skb->len;
-@@ -2945,6 +2953,8 @@ struct sk_buff *dev_hard_start_xmit(struct sk_buff *first, struct net_device *de
+@@ -3004,6 +3012,8 @@ out:
        return skb;
  }
  
@@ -1310,11 +1291,10 @@ index 6666b28..3e12add 100644
  static struct sk_buff *validate_xmit_vlan(struct sk_buff *skb,
                                          netdev_features_t features)
  {
-diff --git a/net/core/skbuff.c b/net/core/skbuff.c
-index 1e3e008..379236e 100644
---- a/net/core/skbuff.c
-+++ b/net/core/skbuff.c
-@@ -82,6 +82,87 @@ struct kmem_cache *skbuff_head_cache __read_mostly;
+diff -urNp -x '*.orig' linux-4.9/net/core/skbuff.c linux-4.9/net/core/skbuff.c
+--- linux-4.9/net/core/skbuff.c        2021-02-24 15:35:11.224206637 +0100
++++ linux-4.9/net/core/skbuff.c        2021-02-24 15:35:24.104607477 +0100
+@@ -82,6 +82,87 @@ struct kmem_cache *skbuff_head_cache __r
  static struct kmem_cache *skbuff_fclone_cache __read_mostly;
  int sysctl_max_skb_frags __read_mostly = MAX_SKB_FRAGS;
  EXPORT_SYMBOL(sysctl_max_skb_frags);
@@ -1402,7 +1382,7 @@ index 1e3e008..379236e 100644
  
  /**
   *    skb_panic - private function for out-of-line support
-@@ -654,6 +735,28 @@ static void skb_release_head_state(struct sk_buff *skb)
+@@ -667,6 +748,28 @@ static void skb_release_head_state(struc
                WARN_ON(in_irq());
                skb->destructor(skb);
        }
@@ -1431,7 +1411,7 @@ index 1e3e008..379236e 100644
  #if IS_ENABLED(CONFIG_NF_CONNTRACK)
        nf_conntrack_put(skb->nfct);
  #endif
-@@ -843,6 +946,10 @@ static void __copy_skb_header(struct sk_buff *new, const struct sk_buff *old)
+@@ -856,6 +959,10 @@ static void __copy_skb_header(struct sk_
        new->sp                 = secpath_get(old->sp);
  #endif
        __nf_copy(new, old, false);
@@ -1442,7 +1422,7 @@ index 1e3e008..379236e 100644
  
        /* Note : this field could be in headers_start/headers_end section
         * It is not yet because we do not want to have a 16 bit hole
-@@ -3463,6 +3570,13 @@ void __init skb_init(void)
+@@ -3536,6 +3643,13 @@ void __init skb_init(void)
                                                0,
                                                SLAB_HWCACHE_ALIGN|SLAB_PANIC,
                                                NULL);
@@ -1455,12 +1435,11 @@ index 1e3e008..379236e 100644
 +#endif
  }
  
- /**
-diff --git a/net/ipv6/ip6_output.c b/net/ipv6/ip6_output.c
-index 59eb4ed..8020b07 100644
---- a/net/ipv6/ip6_output.c
-+++ b/net/ipv6/ip6_output.c
-@@ -66,9 +66,6 @@ static int ip6_finish_output2(struct net *net, struct sock *sk, struct sk_buff *
+ static int
+diff -urNp -x '*.orig' linux-4.9/net/ipv6/ip6_output.c linux-4.9/net/ipv6/ip6_output.c
+--- linux-4.9/net/ipv6/ip6_output.c    2021-02-24 15:35:11.257541008 +0100
++++ linux-4.9/net/ipv6/ip6_output.c    2021-02-24 15:35:24.104607477 +0100
+@@ -66,9 +66,6 @@ static int ip6_finish_output2(struct net
        struct in6_addr *nexthop;
        int ret;
  
@@ -1470,7 +1449,7 @@ index 59eb4ed..8020b07 100644
        if (ipv6_addr_is_multicast(&ipv6_hdr(skb)->daddr)) {
                struct inet6_dev *idev = ip6_dst_idev(skb_dst(skb));
  
-@@ -150,6 +147,13 @@ int ip6_output(struct net *net, struct sock *sk, struct sk_buff *skb)
+@@ -150,6 +147,13 @@ int ip6_output(struct net *net, struct s
                return 0;
        }
  
@@ -1484,10 +1463,9 @@ index 59eb4ed..8020b07 100644
        return NF_HOOK_COND(NFPROTO_IPV6, NF_INET_POST_ROUTING,
                            net, sk, skb, NULL, dev,
                            ip6_finish_output,
-diff --git a/net/netfilter/Kconfig b/net/netfilter/Kconfig
-index e8d56d9..1ed3468 100644
---- a/net/netfilter/Kconfig
-+++ b/net/netfilter/Kconfig
+diff -urNp -x '*.orig' linux-4.9/net/netfilter/Kconfig linux-4.9/net/netfilter/Kconfig
+--- linux-4.9/net/netfilter/Kconfig    2021-02-24 15:35:11.727555634 +0100
++++ linux-4.9/net/netfilter/Kconfig    2021-02-24 15:35:24.104607477 +0100
 @@ -823,6 +823,18 @@ config NETFILTER_XT_TARGET_LOG
  
          To compile it as a module, choose M here.  If unsure, say N.
@@ -1507,11 +1485,10 @@ index e8d56d9..1ed3468 100644
  config NETFILTER_XT_TARGET_MARK
        tristate '"MARK" target support'
        depends on NETFILTER_ADVANCED
-diff --git a/net/netfilter/Makefile b/net/netfilter/Makefile
-index c23c3c8..99911ef 100644
---- a/net/netfilter/Makefile
-+++ b/net/netfilter/Makefile
-@@ -119,6 +119,7 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_CT) += xt_CT.o
+diff -urNp -x '*.orig' linux-4.9/net/netfilter/Makefile linux-4.9/net/netfilter/Makefile
+--- linux-4.9/net/netfilter/Makefile   2021-02-24 15:35:11.727555634 +0100
++++ linux-4.9/net/netfilter/Makefile   2021-02-24 15:35:24.104607477 +0100
+@@ -119,6 +119,7 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_CT) +=
  obj-$(CONFIG_NETFILTER_XT_TARGET_DSCP) += xt_DSCP.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_HL) += xt_HL.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_HMARK) += xt_HMARK.o
@@ -1519,11 +1496,10 @@ index c23c3c8..99911ef 100644
  obj-$(CONFIG_NETFILTER_XT_TARGET_LED) += xt_LED.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_LOG) += xt_LOG.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_NETMAP) += xt_NETMAP.o
-diff --git a/net/netfilter/core.c b/net/netfilter/core.c
-index 004af03..768a08b 100644
---- a/net/netfilter/core.c
-+++ b/net/netfilter/core.c
-@@ -360,8 +360,11 @@ int nf_hook_slow(struct sk_buff *skb, struct nf_hook_state *state)
+diff -urNp -x '*.orig' linux-4.9/net/netfilter/core.c linux-4.9/net/netfilter/core.c
+--- linux-4.9/net/netfilter/core.c     2021-02-24 15:35:11.287541941 +0100
++++ linux-4.9/net/netfilter/core.c     2021-02-24 15:35:24.104607477 +0100
+@@ -360,8 +360,11 @@ next_hook:
                ret = NF_DROP_GETERR(verdict);
                if (ret == 0)
                        ret = -EPERM;
@@ -1535,11 +1511,10 @@ index 004af03..768a08b 100644
 +                      goto next_hook;
                if (ret == 1 && entry)
                        goto next_hook;
-       }
-diff --git a/net/netfilter/nf_queue.c b/net/netfilter/nf_queue.c
-index 8f08d75..8d362c0 100644
---- a/net/netfilter/nf_queue.c
-+++ b/net/netfilter/nf_queue.c
+       } else {
+diff -urNp -x '*.orig' linux-4.9/net/netfilter/nf_queue.c linux-4.9/net/netfilter/nf_queue.c
+--- linux-4.9/net/netfilter/nf_queue.c 2016-12-11 20:17:54.000000000 +0100
++++ linux-4.9/net/netfilter/nf_queue.c 2021-02-24 15:35:24.104607477 +0100
 @@ -27,6 +27,23 @@
   * receives, no matter what.
   */
@@ -1564,7 +1539,7 @@ index 8f08d75..8d362c0 100644
  /* return EBUSY when somebody else is registered, return EEXIST if the
   * same handler is registered, return 0 in case of success. */
  void nf_register_queue_handler(struct net *net, const struct nf_queue_handler *qh)
-@@ -108,16 +125,28 @@ void nf_queue_nf_hook_drop(struct net *net, const struct nf_hook_entry *entry)
+@@ -108,16 +125,28 @@ void nf_queue_nf_hook_drop(struct net *n
  }
  
  static int __nf_queue(struct sk_buff *skb, const struct nf_hook_state *state,
@@ -1595,7 +1570,7 @@ index 8f08d75..8d362c0 100644
        if (!qh) {
                status = -ESRCH;
                goto err;
-@@ -218,6 +247,7 @@ void nf_reinject(struct nf_queue_entry *entry, unsigned int verdict)
+@@ -218,6 +247,7 @@ okfn:
                local_bh_enable();
                break;
        case NF_QUEUE:
@@ -1603,11 +1578,9 @@ index 8f08d75..8d362c0 100644
                err = nf_queue(skb, &entry->state, &hook_entry, verdict);
                if (err == 1) {
                        if (hook_entry)
-diff --git a/net/netfilter/xt_IMQ.c b/net/netfilter/xt_IMQ.c
-new file mode 100644
-index 0000000..f9c5817
---- /dev/null
-+++ b/net/netfilter/xt_IMQ.c
+diff -urNp -x '*.orig' linux-4.9/net/netfilter/xt_IMQ.c linux-4.9/net/netfilter/xt_IMQ.c
+--- linux-4.9/net/netfilter/xt_IMQ.c   1970-01-01 01:00:00.000000000 +0100
++++ linux-4.9/net/netfilter/xt_IMQ.c   2021-02-24 15:35:24.104607477 +0100
 @@ -0,0 +1,72 @@
 +/*
 + * This target marks packets to be enqueued to an imq device
@@ -1681,11 +1654,10 @@ index 0000000..f9c5817
 +MODULE_ALIAS("ipt_IMQ");
 +MODULE_ALIAS("ip6t_IMQ");
 +
-diff --git a/net/sched/sch_generic.c b/net/sched/sch_generic.c
-index 6cfb6e9..4c675e9 100644
---- a/net/sched/sch_generic.c
-+++ b/net/sched/sch_generic.c
-@@ -154,6 +154,14 @@ static struct sk_buff *dequeue_skb(struct Qdisc *q, bool *validate,
+diff -urNp -x '*.orig' linux-4.9/net/sched/sch_generic.c linux-4.9/net/sched/sch_generic.c
+--- linux-4.9/net/sched/sch_generic.c  2021-02-24 15:35:11.317542875 +0100
++++ linux-4.9/net/sched/sch_generic.c  2021-02-24 15:35:24.104607477 +0100
+@@ -154,6 +154,14 @@ bulk:
        return skb;
  }
  
This page took 0.043875 seconds and 4 git commands to generate.