]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel-atmdd.patch
- up to 5.11.11
[packages/kernel.git] / kernel-atmdd.patch
index 85424c3022f27374dffa5d85b33f88aefe212cef..c0b9a3611047ce52e10508878a46e7343332e1b4 100644 (file)
@@ -1,35 +1,6 @@
-diff -urN linux-2.4.25/drivers/atm/Makefile linux-2.4.25-atmdd/drivers/atm/Makefile
---- linux-2.4.25/drivers/atm/Makefile  2004-02-23 15:18:29.000000000 +0100
-+++ linux-2.4.25-atmdd/drivers/atm/Makefile    2004-02-29 22:51:26.000000000 +0100
-@@ -31,6 +31,7 @@
- endif
- obj-$(CONFIG_ATM_DUMMY)               += adummy.o
-+obj-$(CONFIG_ATM_DD)          += atmdd.o
- obj-$(CONFIG_ATM_TCP)         += atmtcp.o
- obj-$(CONFIG_ATM_FIRESTREAM)  += firestream.o
- obj-$(CONFIG_ATM_LANAI)               += lanai.o
-diff -urN linux-2.4.25/drivers/atm/Kconfig linux-2.4.25-atmdd/drivers/atm/Kconfig
---- linux-2.4.25/drivers/atm/Kcnfig    2003-08-25 13:44:41.000000000 +0200
-+++ linux-2.4.25-atmdd/drivers/atm/Kconfig     2004-02-29 22:52:59.000000000 +0100
-@@ -4,6 +4,14 @@
-       default y
- if ATM_DRIVERS && NETDEVICES && ATM
-+
-+config ATM_DD
-+      tristate "ATM loopback"
-+      depends on INET && ATM
-+      help
-+        This is an example atm driver.  It does not require any actual ATM
-+        hardware.  It supports AAL5 and AAL0.  Frames are merely looped back
-+        to the sender on the same VC they were sent.
- config ATM_DUMMY
-       tristate "Dummy ATM driver"
-diff -urN linux-2.4.25/drivers/atm/atmdd.c linux-2.4.25-atmdd/drivers/atm/atmdd.c
---- linux-2.4.25/drivers/atm/atmdd.c   1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.4.25-atmdd/drivers/atm/atmdd.c     2004-02-29 22:58:11.000000000 +0100
+diff -urN linux-5.9/drivers.org/atm/atmdd.c linux-5.9/drivers/atm/atmdd.c
+--- linux-5.9/drivers.org/atm/atmdd.c  1970-01-01 01:00:00.000000000 +0100
++++ linux-5.9/drivers/atm/atmdd.c      2020-11-03 13:31:48.120071319 +0100
 @@ -0,0 +1,920 @@
 +/*
 +#######################################################################
@@ -951,3 +922,32 @@ diff -urN linux-2.4.25/drivers/atm/atmdd.c linux-2.4.25-atmdd/drivers/atm/atmdd.
 +module_exit(myatmdd_exit);
 +
 +#endif /* MODULE */
+diff -urN linux-5.9/drivers.org/atm/Kconfig linux-5.9/drivers/atm/Kconfig
+--- linux-5.9/drivers.org/atm/Kconfig  2020-10-11 23:15:50.000000000 +0200
++++ linux-5.9/drivers/atm/Kconfig      2020-11-03 13:31:48.120071319 +0100
+@@ -15,6 +15,14 @@
+ if ATM_DRIVERS && NETDEVICES && ATM
++config ATM_DD
++      tristate "ATM loopback"
++      depends on INET && ATM
++      help
++        This is an example atm driver.  It does not require any actual ATM
++        hardware.  It supports AAL5 and AAL0.  Frames are merely looped back
++        to the sender on the same VC they were sent.
++
+ config ATM_DUMMY
+       tristate "Dummy ATM driver"
+       help
+diff -urN linux-5.9/drivers.org/atm/Makefile linux-5.9/drivers/atm/Makefile
+--- linux-5.9/drivers.org/atm/Makefile 2020-10-11 23:15:50.000000000 +0200
++++ linux-5.9/drivers/atm/Makefile     2020-11-03 13:31:48.120071319 +0100
+@@ -26,6 +26,7 @@
+ endif
+ obj-$(CONFIG_ATM_DUMMY)               += adummy.o
++obj-$(CONFIG_ATM_DD)          += atmdd.o
+ obj-$(CONFIG_ATM_TCP)         += atmtcp.o
+ obj-$(CONFIG_ATM_FIRESTREAM)  += firestream.o
+ obj-$(CONFIG_ATM_LANAI)               += lanai.o
This page took 0.031854 seconds and 4 git commands to generate.