]> git.pld-linux.org Git - packages/kernel-tools.git/commitdiff
- updated to 5.10.1 auto/th/kernel-tools-5.10.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 17 Dec 2020 18:26:53 +0000 (19:26 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 17 Dec 2020 18:26:53 +0000 (19:26 +0100)
- updated perf-gtk2 patch (adjust also gtk2-infobar detection)
- added slang patch (fix slang include subdir detection)

kernel-tools-perf-gtk2.patch
kernel-tools-slang.patch [new file with mode: 0644]
kernel-tools.spec

index 0e95559ab7aae56eceb06008c4ef6afb748ffe2b..b31c4c7d54ef17ca87b3421d3cd0d380af8eee7a 100644 (file)
@@ -1,11 +1,12 @@
 gtk+2 uses glib APIs that are deprecated in 2.62.x
 --- linux-5.3/tools/perf/Makefile.config.orig  2019-09-25 05:32:27.522918998 +0200
 +++ linux-5.3/tools/perf/Makefile.config       2019-09-25 16:00:49.492003246 +0200
-@@ -169,6 +169,7 @@
+@@ -169,6 +169,8 @@
  FEATURE_CHECK_CFLAGS-libzstd := $(LIBZSTD_CFLAGS)
  FEATURE_CHECK_LDFLAGS-libzstd := $(LIBZSTD_LDFLAGS)
  
 +FEATURE_CHECK_CFLAGS-gtk2 := -Wno-deprecated-declarations
++FEATURE_CHECK_CFLAGS-gtk2-infobar := -Wno-deprecated-declarations
  FEATURE_CHECK_CFLAGS-bpf = -I. -I$(srctree)/tools/include -I$(srctree)/tools/arch/$(SRCARCH)/include/uapi -I$(srctree)/tools/include/uapi
  # include ARCH specific config
  -include $(src-perf)/arch/$(SRCARCH)/Makefile
diff --git a/kernel-tools-slang.patch b/kernel-tools-slang.patch
new file mode 100644 (file)
index 0000000..c20bf97
--- /dev/null
@@ -0,0 +1,12 @@
+Drop -I/usr/include/slang to allow detection of <slang.h> vs <slang/slang.h>
+--- linux-5.10/tools/build/feature/Makefile.orig       2020-12-13 23:41:30.000000000 +0100
++++ linux-5.10/tools/build/feature/Makefile    2020-12-17 06:28:25.229860807 +0100
+@@ -90,7 +90,7 @@
+ ###############################
+ $(OUTPUT)test-all.bin:
+-      $(BUILD) -fstack-protector-all -O2 -D_FORTIFY_SOURCE=2 -ldw -lelf -lnuma -lelf -I/usr/include/slang -lslang $(FLAGS_PERL_EMBED) $(FLAGS_PYTHON_EMBED) -DPACKAGE='"perf"' -lbfd -ldl -lz -llzma -lzstd
++      $(BUILD) -fstack-protector-all -O2 -D_FORTIFY_SOURCE=2 -ldw -lelf -lnuma -lelf -lslang $(FLAGS_PERL_EMBED) $(FLAGS_PYTHON_EMBED) -DPACKAGE='"perf"' -lbfd -ldl -lz -llzma -lzstd
+ $(OUTPUT)test-hello.bin:
+       $(BUILD)
index 5de3fc8c38af50dfe9c0a94f124015e187effdb2..7ec87c23871275af7c6b19dd5fced89086c64790 100644 (file)
@@ -19,8 +19,8 @@
 %undefine      with_multilib
 %endif
 
-%define                basever         5.9
-%define                postver         .0
+%define                basever         5.10
+%define                postver         .1
 Summary:       Assortment of tools for the Linux kernel
 Summary(pl.UTF-8):     Zestaw narzędzi dla jądra Linuksa
 Name:          kernel-tools
@@ -29,17 +29,18 @@ Release:    1
 License:       GPL v2
 Group:         Applications/System
 Source0:       https://www.kernel.org/pub/linux/kernel/v5.x/linux-%{basever}.tar.xz
-# Source0-md5: 0959d759fd19e146367221aff504ad91
+# Source0-md5: 753adc474bf799d569dec4f165ed92c3
 Source1:       cpupower.service
 Source2:       cpupower.config
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v5.x/patch-%{version}.xz
-# Patch0-md5:  7055ff82e7e6a557c04831a191ed14b3
+# Patch0-md5:  33c2cbab3e136939c065e397879a8087
 %endif
 Patch1:                x32.patch
 Patch2:                regex.patch
 Patch3:                %{name}-perf-update.patch
 Patch4:                %{name}-perf-gtk2.patch
+Patch5:                %{name}-slang.patch
 URL:           https://www.kernel.org/
 BuildRequires: bison
 BuildRequires: docutils
@@ -404,6 +405,7 @@ cd linux-%{basever}
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %{__sed} -i -e '/^CFLAGS = /s/ -g / $(OPTFLAGS) /' tools/hv/Makefile
 %{__sed} -i -e '/^CFLAGS+=/s/ -O1 / $(OPTFLAGS) /' tools/thermal/tmon/Makefile
@@ -480,10 +482,11 @@ CFLAGS="%{rpmcflags}" \
        IS_X86_64=1 \
        %{!?with_multilib:NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1} \
 %endif
-       %{!?with_gtk:NO_GTK2=1} \
+       %{?with_gtk:GTK2=1} \
        %{!?with_libunwind:NO_LIBUNWIND=1} \
        %{makeopts} \
        CFLAGS_OPTIMIZE="%{rpmcflags}" \
+       VF=1 \
        WERROR=0 \
        prefix=%{_prefix} \
        perfexecdir=%{_datadir}/perf-core \
@@ -585,7 +588,7 @@ install -p tools/power/cpupower/debug/x86_64/{centrino,powernow-k8}-decode $RPM_
        IS_X86_64=1 \
        %{!?with_multilib:NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1} \
 %endif
-       %{!?with_gtk:NO_GTK2=1} \
+       %{?with_gtk:GTK2=1} \
        %{!?with_libunwind:NO_LIBUNWIND=1} \
        CC="%{__cc}" \
        CFLAGS_OPTIMIZE="%{rpmcflags}" \
This page took 0.355123 seconds and 4 git commands to generate.