]> git.pld-linux.org Git - packages/kernel-tools.git/commitdiff
up to 5.8.0 auto/th/kernel-tools-5.8.0-1
authorJan Palus <atler@pld-linux.org>
Tue, 4 Aug 2020 17:51:09 +0000 (19:51 +0200)
committerJan Palus <atler@pld-linux.org>
Tue, 4 Aug 2020 17:56:52 +0000 (19:56 +0200)
kernel-tools-binutils2.35.patch [deleted file]
kernel-tools-bpf-hashmap-upstream.patch [deleted file]
kernel-tools-bpf-hashmap.patch [deleted file]
kernel-tools.spec

diff --git a/kernel-tools-binutils2.35.patch b/kernel-tools-binutils2.35.patch
deleted file mode 100644 (file)
index a225bf3..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- linux-5.7/tools/lib/traceevent/plugins/Makefile.orig       2020-06-01 01:49:15.000000000 +0200
-+++ linux-5.7/tools/lib/traceevent/plugins/Makefile    2020-07-27 17:00:03.592989940 +0200
-@@ -197,7 +197,7 @@
-       xargs echo "U w W" | tr 'w ' 'W\n' | sort -u | xargs echo`;\
-       if [ "$$symbol_type" = "U W" ];then                             \
-               (echo '{';                                              \
--              $(NM) -u -D $1 | awk 'NF>1 {print "\t"$$2";"}' | sort -u;\
-+              $(NM) -u -D $1 | awk 'NF>1 {gsub("@.*", "", $$2); print "\t"$$2";"}' | sort -u;\
-               echo '};';                                              \
-               ) > $2;                                                 \
-       else                                                            \
diff --git a/kernel-tools-bpf-hashmap-upstream.patch b/kernel-tools-bpf-hashmap-upstream.patch
deleted file mode 100644 (file)
index 22c53bb..0000000
+++ /dev/null
@@ -1,80 +0,0 @@
-From f516acd5397fdbb77ef0aad0798d9ef7c3001d72 Mon Sep 17 00:00:00 2001
-From: Ian Rogers <irogers@google.com>
-Date: Fri, 15 May 2020 09:50:02 -0700
-Subject: libbpf, hashmap: Remove unused #include
-
-Remove #include of libbpf_internal.h that is unused.
-
-Discussed in this thread:
-https://lore.kernel.org/lkml/CAEf4BzZRmiEds_8R8g4vaAeWvJzPb4xYLnpF0X2VNY8oTzkphQ@mail.gmail.com/
-
-Signed-off-by: Ian Rogers <irogers@google.com>
-Signed-off-by: Daniel Borkmann <daniel@iogearbox.net>
-Acked-by: Andrii Nakryiko <andriin@fb.com>
-Link: https://lore.kernel.org/bpf/20200515165007.217120-3-irogers@google.com
----
- tools/lib/bpf/hashmap.h | 1 -
- 1 file changed, 1 deletion(-)
-
-(limited to 'tools/lib/bpf/hashmap.h')
-
-diff --git a/tools/lib/bpf/hashmap.h b/tools/lib/bpf/hashmap.h
-index bae8879cdf58..e823b35e7371 100644
---- a/tools/lib/bpf/hashmap.h
-+++ b/tools/lib/bpf/hashmap.h
-@@ -15,7 +15,6 @@
- #else
- #include <bits/reg.h>
- #endif
--#include "libbpf_internal.h"
- static inline size_t hash_bits(size_t h, int bits)
- {
--- 
-cgit 1.2.3-1.el7
-
-From 8ca8d4a841730c02e77bf3c87bf658cc44f364b9 Mon Sep 17 00:00:00 2001
-From: Arnaldo Carvalho de Melo <acme@kernel.org>
-Date: Tue, 9 Jun 2020 18:16:53 -0300
-Subject: libbpf: Define __WORDSIZE if not available
-
-Some systems, such as Android, don't have a define for __WORDSIZE, do it
-in terms of __SIZEOF_LONG__, as done in perf since 2012:
-
-   http://git.kernel.org/torvalds/c/3f34f6c0233ae055b5
-
-For reference: https://gcc.gnu.org/onlinedocs/cpp/Common-Predefined-Macros.html
-
-I build tested it here and Andrii did some Travis CI build tests too.
-
-Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
-Signed-off-by: Daniel Borkmann <daniel@iogearbox.net>
-Acked-by: Andrii Nakryiko <andriin@fb.com>
-Link: https://lore.kernel.org/bpf/20200608161150.GA3073@kernel.org
----
- tools/lib/bpf/hashmap.h | 7 +++----
- 1 file changed, 3 insertions(+), 4 deletions(-)
-
-(limited to 'tools/lib/bpf/hashmap.h')
-
-diff --git a/tools/lib/bpf/hashmap.h b/tools/lib/bpf/hashmap.h
-index e823b35e7371..df59fd4fc95b 100644
---- a/tools/lib/bpf/hashmap.h
-+++ b/tools/lib/bpf/hashmap.h
-@@ -10,10 +10,9 @@
- #include <stdbool.h>
- #include <stddef.h>
--#ifdef __GLIBC__
--#include <bits/wordsize.h>
--#else
--#include <bits/reg.h>
-+#include <limits.h>
-+#ifndef __WORDSIZE
-+#define __WORDSIZE (__SIZEOF_LONG__ * 8)
- #endif
- static inline size_t hash_bits(size_t h, int bits)
--- 
-cgit 1.2.3-1.el7
-
diff --git a/kernel-tools-bpf-hashmap.patch b/kernel-tools-bpf-hashmap.patch
deleted file mode 100644 (file)
index 18334be..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-Fix libbpf hashmap on (I)LP32 architectures
-
-On ILP32, 64-bit result was shifted by value calculated for 32-bit long type
-and returned value was much outside hashmap capacity.
-As advised by Andrii Nakryiko, this patch uses different hashing variant for
-architectures with size_t shorter than long long.
-
---- linux-5.7/tools/lib/bpf/hashmap.h.orig     2020-06-01 01:49:15.000000000 +0200
-+++ linux-5.7/tools/lib/bpf/hashmap.h  2020-06-21 15:22:07.298466419 +0200
-@@ -11,14 +11,18 @@
- #include <stdbool.h>
- #include <stddef.h>
- #include <limits.h>
--#ifndef __WORDSIZE
--#define __WORDSIZE (__SIZEOF_LONG__ * 8)
--#endif
- static inline size_t hash_bits(size_t h, int bits)
- {
-       /* shuffle bits and return requested number of upper bits */
--      return (h * 11400714819323198485llu) >> (__WORDSIZE - bits);
-+#if (__SIZEOF_SIZE_T__ == __SIZEOF_LONG_LONG__)
-+      /* LP64 case */
-+      return (h * 11400714819323198485llu) >> (__SIZEOF_LONG_LONG__ * 8 - bits);
-+#elif (__SIZEOF_SIZE_T__ <= __SIZEOF_LONG__)
-+      return (h * 2654435769lu) >> (__SIZEOF_LONG__ * 8 - bits);
-+#else
-+#     error "Unsupported size_t size"
-+#endif
- }
- typedef size_t (*hashmap_hash_fn)(const void *key, void *ctx);
index 5decae46fd13dbd8268de828df94a1de05f709e2..70c15d36b19c03f23ba103126387d3280e47e7eb 100644 (file)
 %undefine      with_multilib
 %endif
 
 %undefine      with_multilib
 %endif
 
-%define                basever         5.7
+%define                basever         5.8
 %define                postver         .0
 Summary:       Assortment of tools for the Linux kernel
 Summary(pl.UTF-8):     Zestaw narzędzi dla jądra Linuksa
 Name:          kernel-tools
 Version:       %{basever}%{postver}
 %define                postver         .0
 Summary:       Assortment of tools for the Linux kernel
 Summary(pl.UTF-8):     Zestaw narzędzi dla jądra Linuksa
 Name:          kernel-tools
 Version:       %{basever}%{postver}
-Release:       5
+Release:       1
 License:       GPL v2
 Group:         Applications/System
 Source0:       https://www.kernel.org/pub/linux/kernel/v5.x/linux-%{basever}.tar.xz
 License:       GPL v2
 Group:         Applications/System
 Source0:       https://www.kernel.org/pub/linux/kernel/v5.x/linux-%{basever}.tar.xz
-# Source0-md5: f63ed18935914e1ee3e04c2a0ce1ba3b
+# Source0-md5: 0e5c4c15266218ef26c50fac0016095b
 Source1:       cpupower.service
 Source2:       cpupower.config
 %if "%{postver}" != ".0"
 Source1:       cpupower.service
 Source2:       cpupower.config
 %if "%{postver}" != ".0"
@@ -40,10 +40,7 @@ Patch1:              x32.patch
 Patch2:                regex.patch
 Patch3:                %{name}-perf-update.patch
 Patch4:                %{name}-perf-gtk2.patch
 Patch2:                regex.patch
 Patch3:                %{name}-perf-update.patch
 Patch4:                %{name}-perf-gtk2.patch
-Patch5:                %{name}-bpf-hashmap-upstream.patch
-Patch6:                %{name}-bpf-hashmap.patch
-Patch7:                %{name}-usbip-nocommon.patch
-Patch8:                %{name}-binutils2.35.patch
+Patch5:                %{name}-usbip-nocommon.patch
 URL:           https://www.kernel.org/
 BuildRequires: bison
 BuildRequires: docutils
 URL:           https://www.kernel.org/
 BuildRequires: bison
 BuildRequires: docutils
@@ -409,9 +406,6 @@ cd linux-%{basever}
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p1
-%patch7 -p1
-%patch8 -p1
 
 %{__sed} -i -e '/^CFLAGS = /s/ -g / $(OPTFLAGS) /' tools/hv/Makefile
 %{__sed} -i -e '/^CFLAGS+=/s/ -O1 / $(OPTFLAGS) /' tools/thermal/tmon/Makefile
 
 %{__sed} -i -e '/^CFLAGS = /s/ -g / $(OPTFLAGS) /' tools/hv/Makefile
 %{__sed} -i -e '/^CFLAGS+=/s/ -O1 / $(OPTFLAGS) /' tools/thermal/tmon/Makefile
This page took 0.160953 seconds and 4 git commands to generate.