]> git.pld-linux.org Git - packages/kernel-tools.git/commitdiff
- fix building with binutils 2.34 auto/th/kernel-tools-5.5.11-1
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 24 Mar 2020 21:34:34 +0000 (22:34 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 24 Mar 2020 21:34:34 +0000 (22:34 +0100)
binutils-2.34.patch [new file with mode: 0644]
kernel-tools.spec

diff --git a/binutils-2.34.patch b/binutils-2.34.patch
new file mode 100644 (file)
index 0000000..5d8ecd8
--- /dev/null
@@ -0,0 +1,18 @@
+--- linux-5.5/tools/perf/util/srcline.c~       2020-01-27 01:23:03.000000000 +0100
++++ linux-5.5/tools/perf/util/srcline.c        2020-03-24 22:05:05.941464830 +0100
+@@ -197,12 +197,12 @@
+       if (a2l->found)
+               return;
+-      if ((bfd_get_section_flags(abfd, section) & SEC_ALLOC) == 0)
++      if ((bfd_section_flags(section) & SEC_ALLOC) == 0)
+               return;
+       pc = a2l->addr;
+-      vma = bfd_get_section_vma(abfd, section);
+-      size = bfd_get_section_size(section);
++      vma = bfd_section_vma(section);
++      size = bfd_section_size(section);
+       if (pc < vma || pc >= vma + size)
+               return;
index 6cd16cd6341f6e7d0e47b5ee754d5b56a516732f..e668be699d1902a64da549cde03e6c1632897a4a 100644 (file)
@@ -38,6 +38,7 @@ Patch1:               x32.patch
 Patch2:                regex.patch
 Patch3:                %{name}-perf-update.patch
 Patch4:                %{name}-perf-gtk2.patch
 Patch2:                regex.patch
 Patch3:                %{name}-perf-update.patch
 Patch4:                %{name}-perf-gtk2.patch
+Patch5:                binutils-2.34.patch
 URL:           https://www.kernel.org/
 BuildRequires: bison
 BuildRequires: docutils
 URL:           https://www.kernel.org/
 BuildRequires: bison
 BuildRequires: docutils
@@ -400,6 +401,7 @@ cd linux-%{basever}
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %{__sed} -i -e '/^CFLAGS = /s/ -g / $(OPTFLAGS) /' tools/hv/Makefile
 %{__sed} -i -e '/^CFLAGS+=/s/ -O1 / $(OPTFLAGS) /' tools/thermal/tmon/Makefile
 
 %{__sed} -i -e '/^CFLAGS = /s/ -g / $(OPTFLAGS) /' tools/hv/Makefile
 %{__sed} -i -e '/^CFLAGS+=/s/ -O1 / $(OPTFLAGS) /' tools/thermal/tmon/Makefile
This page took 0.222115 seconds and 4 git commands to generate.