]> git.pld-linux.org Git - packages/kernel-tools.git/blobdiff - x32.patch
BR: ncurses-ext-devel for panel.h
[packages/kernel-tools.git] / x32.patch
index fddd823d6bf7d3ab3f87d6592b97d271778877e2..13017ff66e8df784dfb3ef0d9768075fe463216a 100644 (file)
--- a/x32.patch
+++ b/x32.patch
@@ -16,10 +16,10 @@ FIXME: regs_load.S need complete x32 ABI support; now it will just compile, but
 +else
 +  IS_X32_BIT := 0
 +endif
---- linux-3.19/tools/perf/config/Makefile~     2015-04-11 12:12:31.000000000 +0200
-+++ linux-3.19/tools/perf/config/Makefile      2015-04-11 12:19:05.011244885 +0200
-@@ -28,6 +28,9 @@
-     LIBUNWIND_LIBS = -lunwind -lunwind-x86
+--- linux-4.8/tools/perf/Makefile.config~      2015-04-11 12:12:31.000000000 +0200
++++ linux-4.8/tools/perf/Makefile.config       2015-04-11 12:19:05.011244885 +0200
+@@ -41,6 +41,9 @@
+     LIBUNWIND_LIBS = -lunwind-x86 -llzma -lunwind
    endif
    NO_PERF_REGS := 0
 +  ifeq (${IS_X32_BIT}, 1)
@@ -62,20 +62,20 @@ FIXME: regs_load.S need complete x32 ABI support; now it will just compile, but
 +#if defined(__x86_64__) && !defined(__ILP32__)
                printf(" %14s: %lu.%03lu [sec]\n", "Total time",
                       diff.tv_sec,
-                      (unsigned long) (diff.tv_usec/1000));
+                      (unsigned long) (diff.tv_usec / USEC_PER_MSEC));
 +#else
 +              printf(" %14s: %llu.%03llu [sec]\n", "Total time",
 +                     diff.tv_sec,
-+                     (unsigned long long) (diff.tv_usec/1000));
++                     (unsigned long long) (diff.tv_usec / USEC_PER_MSEC));
 +#endif
                break;
        case BENCH_FORMAT_SIMPLE:
 +#if defined(__x86_64__) && !defined(__ILP32__)
                printf("%lu.%03lu\n", diff.tv_sec,
-                      (unsigned long) (diff.tv_usec/1000));
+                      (unsigned long) (diff.tv_usec / USEC_PER_MSEC));
 +#else
 +              printf("%llu.%03llu\n", diff.tv_sec,
-+                     (unsigned long long) (diff.tv_usec/1000));
++                     (unsigned long long) (diff.tv_usec / USEC_PER_MSEC));
 +#endif
                break;
        default:
@@ -89,11 +89,11 @@ FIXME: regs_load.S need complete x32 ABI support; now it will just compile, but
 +#if defined(__x86_64__) && !defined(__ILP32__)
                printf(" %14s: %lu.%03lu [sec]\n\n", "Total time",
                       diff.tv_sec,
-                      (unsigned long) (diff.tv_usec/1000));
+                      (unsigned long) (diff.tv_usec / USEC_PER_MSEC));
 +#else
 +              printf(" %14s: %llu.%03llu [sec]\n\n", "Total time",
 +                     diff.tv_sec,
-+                     (unsigned long long) (diff.tv_usec/1000));
++                     (unsigned long long) (diff.tv_usec / USEC_PER_MSEC));
 +#endif
  
                printf(" %14lf usecs/op\n",
@@ -105,11 +105,11 @@ FIXME: regs_load.S need complete x32 ABI support; now it will just compile, but
 +#if defined(__x86_64__) && !defined(__ILP32__)
                printf("%lu.%03lu\n",
                       diff.tv_sec,
-                      (unsigned long) (diff.tv_usec / 1000));
+                      (unsigned long) (diff.tv_usec / USEC_PER_MSEC));
 +#else
 +              printf("%llu.%03llu\n",
 +                     diff.tv_sec,
-+                     (unsigned long long) (diff.tv_usec / 1000));
++                     (unsigned long long) (diff.tv_usec / USEC_PER_MSEC));
 +#endif
                break;
  
This page took 0.099065 seconds and 4 git commands to generate.