]> git.pld-linux.org Git - packages/kernel-tools.git/blobdiff - kernel-tools.spec
- typo, release 5
[packages/kernel-tools.git] / kernel-tools.spec
index c1b12dca3fd2ee081cc264374bf393566a9dc4e4..5decae46fd13dbd8268de828df94a1de05f709e2 100644 (file)
@@ -3,7 +3,8 @@
 # - add -n python-perf?
 # - add bcond to disable building docs (perf docs)
 # - install of perf links perf binary again
-
+# - build runqslower (needs vmlinux with BPF section)
+#
 # Conditional build:
 %bcond_without verbose         # verbose build (V=1)
 %bcond_without cpupower        # cpupower tools
 %bcond_without gtk             # GTK+ 2.x perf support
 %bcond_without libunwind       # libunwind perf support
 %bcond_without multilib        # multilib perf support
+%bcond_with    runqslower      # runqslower bpf tool
 %bcond_without usbip           # usbip utils
 
 %ifnarch %{x8664}
 %undefine      with_multilib
 %endif
 
-%define                basever         5.1
-%define                postver         .3
+%define                basever         5.7
+%define                postver         .0
 Summary:       Assortment of tools for the Linux kernel
 Summary(pl.UTF-8):     Zestaw narzędzi dla jądra Linuksa
 Name:          kernel-tools
 Version:       %{basever}%{postver}
-Release:       1
+Release:       5
 License:       GPL v2
 Group:         Applications/System
 Source0:       https://www.kernel.org/pub/linux/kernel/v5.x/linux-%{basever}.tar.xz
-# Source0-md5: 15fbdff95ff98483069ac6e215b9f4f9
+# Source0-md5: f63ed18935914e1ee3e04c2a0ce1ba3b
 Source1:       cpupower.service
 Source2:       cpupower.config
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v5.x/patch-%{version}.xz
-# Patch0-md5:  06ee36333ce2f480ae848320790cebc1
+# Patch0-md5:  7055ff82e7e6a557c04831a191ed14b3
 %endif
 Patch1:                x32.patch
 Patch2:                regex.patch
 Patch3:                %{name}-perf-update.patch
-URL:           http://www.kernel.org/
+Patch4:                %{name}-perf-gtk2.patch
+Patch5:                %{name}-bpf-hashmap-upstream.patch
+Patch6:                %{name}-bpf-hashmap.patch
+Patch7:                %{name}-usbip-nocommon.patch
+Patch8:                %{name}-binutils2.35.patch
+URL:           https://www.kernel.org/
 BuildRequires: bison
 BuildRequires: docutils
 BuildRequires: flex
@@ -55,21 +62,29 @@ BuildRequires:      xz
 %if %{with perf}
 BuildRequires: asciidoc
 BuildRequires: audit-libs-devel
+BuildRequires: babeltrace-devel
 BuildRequires: binutils-devel >= 4:2.29
 BuildRequires: docbook-dtd45-xml
 BuildRequires: docbook-style-xsl
-BuildRequires: elfutils-devel
+BuildRequires: elfutils-devel >= 0.158
 %if %{with multilib}
 BuildRequires: gcc-multilib-32
 BuildRequires: gcc-multilib-x32
 %endif
+# for `btftool btf dump file ... format c` - requires vmlinux with BPF section
+%{?with_runqslower:BuildRequires:      kernel-vmlinux >= 5.?}
 %{?with_libunwind:BuildRequires:       libunwind-devel >= 0.99}
 BuildRequires: numactl-devel
+BuildRequires: openssl-devel
 BuildRequires: perl-devel >= 5.1
 BuildRequires: python-devel
 BuildRequires: rpm-pythonprov
 BuildRequires: slang-devel
 BuildRequires: xmlto
+BuildRequires: xz-devel
+BuildRequires: zlib-devel
+BuildRequires: zstd-devel
+# openscd? (CORESIGHT=1 for %{arm}?)
 %if %{with gtk}
 BuildRequires: gtk+2-devel >= 2.0
 %endif
@@ -392,6 +407,11 @@ cd linux-%{basever}
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
 
 %{__sed} -i -e '/^CFLAGS = /s/ -g / $(OPTFLAGS) /' tools/hv/Makefile
 %{__sed} -i -e '/^CFLAGS+=/s/ -O1 / $(OPTFLAGS) /' tools/thermal/tmon/Makefile
@@ -400,7 +420,21 @@ cd linux-%{basever}
 # don't rebuild on make install
 %{__sed} -i -e '/^\$(LIBBPF): FORCE/ s/FORCE$//' tools/bpf/bpftool/Makefile
 
+%if %{without runqslower}
+%{__sed} -i -e '/^all: / s/ runqslower//' \
+       -e '/^install: / s/ runqslower_install//' \
+       tools/bpf/Makefile
+%endif
+
 %build
+Wstringop=""
+Waddressof=""
+%if "%{cc_version}" >= "8"
+Wstringop="-Wno-error=stringop-truncation"
+%endif
+%if "%{cc_version}" >= "9"
+Waddressof="-Wno-error=address-of-packed-member"
+%endif
 cd linux-%{basever}
 
 # Simple Disk Sleep Monitor
@@ -411,7 +445,7 @@ cd linux-%{basever}
 # tools common (used eg. by tools/vm)
 %{__make} -C tools/lib/api \
        %{makeopts} \
-       EXTRA_CFLAGS="%{rpmcflags}"
+       EXTRA_CFLAGS="%{rpmcflags} $Wstringop"
 
 # lsgpio
 CFLAGS="%{rpmcflags}" \
@@ -444,6 +478,7 @@ CFLAGS="%{rpmcflags}" \
 %{__make} -C tools/bpf \
        CC="%{__cc}" \
        EXTRA_CFLAGS="%{rpmcflags}" \
+       %{?with_runqslower:VMLINUX_BTF=$(rpm -ql kernel-vmlinux | head -n 1)} \
        %{?with_verbose:V=1}
 
 # perf
@@ -508,6 +543,7 @@ cd tools/usb/usbip
 %{__autoheader}
 %{__automake}
 %configure \
+       CFLAGS="%{rpmcflags} $Wstringop $Waddressof" \
        --disable-silent-rules \
        --with-usbids-dir=/lib/hwdata
 %{__make}
@@ -537,7 +573,7 @@ cd linux-%{basever}
        CPUFREQ_BENCH=false
 
 %find_lang cpupower
-mv cpupower.lang ..
+%{__mv} cpupower.lang ..
 
 install -d $RPM_BUILD_ROOT{/etc/sysconfig,%{systemdunitdir}}
 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/cpupower.service
@@ -627,7 +663,8 @@ install -d $RPM_BUILD_ROOT%{_mandir}/man8
 # gen_init_cpio
 install -p usr/gen_init_cpio $RPM_BUILD_ROOT%{_bindir}/gen_init_cpio
 
-rm -f $RPM_BUILD_ROOT%{_mandir}/man7/bpf-helpers.7*
+# packaged in man-pages (5.02)
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man7/bpf-helpers.7*
 
 %clean
 rm -rf $RPM_BUILD_ROOT
This page took 0.053935 seconds and 4 git commands to generate.