]> git.pld-linux.org Git - packages/kernel-tools.git/blobdiff - kernel-tools.spec
- fixed install
[packages/kernel-tools.git] / kernel-tools.spec
index f8794950f9382af455a53c1cc448ab08ad190eff..46a3ed0c43a213f96abf937c462856144ed8c76f 100644 (file)
@@ -15,8 +15,8 @@
 %undefine      with_libunwind
 %endif
 
-%define                basever         3.19
-%define                postver         .3
+%define                basever         4.1
+%define                postver         .6
 Summary:       Assortment of tools for the Linux kernel
 Summary(pl.UTF-8):     Zestaw narzędzi dla jądra Linuksa
 Name:          kernel-tools
@@ -24,18 +24,19 @@ Version:    %{basever}%{postver}
 Release:       2
 License:       GPL v2
 Group:         Applications/System
-Source0:       https://www.kernel.org/pub/linux/kernel/v3.x/linux-%{basever}.tar.xz
-# Source0-md5: d3fc8316d4d4d04b65cbc2d70799e763
+Source0:       https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
+# Source0-md5: fe9dc0f6729f36400ea81aa41d614c37
 Source1:       cpupower.service
 Source2:       cpupower.config
 %if "%{postver}" != ".0"
-Patch0:                https://www.kernel.org/pub/linux/kernel/v3.x/patch-%{version}.xz
-# Patch0-md5:  1fec75551b2f55fced43df8394b1fd9a
+Patch0:                https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
+# Patch0-md5:  7dea69f02c906206f88df48085069eb6
 %endif
 Patch1:                x32.patch
 URL:           http://www.kernel.org/
 %ifarch %{x8664}
-BuildRequries: gcc-multilib-x32
+BuildRequires: gcc-multilib-32
+BuildRequires: gcc-multilib-x32
 %endif
 BuildRequires: gettext-tools
 BuildRequires: pciutils-devel
@@ -155,6 +156,36 @@ przez nowe wersje jądra Linuksa.
 Ten pakiet zawiera podstawowe pliki, skrypty oraz interfejs tekstowy
 (TUI).
 
+%package perf-vdso32
+Summary:       perf profiler tool
+Summary(pl.UTF-8):     Narzędzie profilujące perf
+Group:         Applications/System
+Requires:      %{name}-perf = %{version}-%{release}
+
+%description perf-vdso32
+Perf is a profiler tool for Linux 2.6+ based systems that abstracts
+away CPU hardware differences in Linux performance measurements and
+presents a simple commandline interface. Perf is based on the
+perf_events interface exported by recent versions of the Linux kernel.
+
+This package contains perf-read-vdso32 tool for reading the 32-bit
+compatibility VDSO in 64-bit mode.
+
+%package perf-vdsox32
+Summary:       perf profiler tool
+Summary(pl.UTF-8):     Narzędzie profilujące perf
+Group:         Applications/System
+Requires:      %{name}-perf = %{version}-%{release}
+
+%description perf-vdsox32
+Perf is a profiler tool for Linux 2.6+ based systems that abstracts
+away CPU hardware differences in Linux performance measurements and
+presents a simple commandline interface. Perf is based on the
+perf_events interface exported by recent versions of the Linux kernel.
+
+This package contains perf-read-vdso32 tool for reading the x32 mode
+32-bit compatibility VDSO in 64-bit mode.
+
 %package perf-gtk
 Summary:       perf profiler tool (GTK+ 2 GUI)
 Summary(pl.UTF-8):     Narzędzie profilujące perf (interfejs graficzny GTK+ 2)
@@ -247,6 +278,9 @@ CFLAGS="%{rpmcflags}" \
 
 %if %{with perf}
 %{__make} -C tools/perf all man \
+%ifarch %{x8664}
+       IS_X86_64=1 \
+%endif
        %{!?with_gtk:NO_GTK2=1} \
        %{!?with_libunwind:NO_LIBUNWIND=1} \
        %{makeopts} \
@@ -295,34 +329,21 @@ install -p dslm $RPM_BUILD_ROOT%{_sbindir}
 
 %ifarch %{ix86} %{x8664} x32
 install -d $RPM_BUILD_ROOT%{_mandir}/man8
-# broken makefile, install manually
-%if 0
 %{__make} install \
        -C tools/power/x86/x86_energy_perf_policy \
        DESTDIR=$RPM_BUILD_ROOT
-%else
-cd tools/power/x86/x86_energy_perf_policy
-install -p x86_energy_perf_policy $RPM_BUILD_ROOT%{_bindir}
-cp -p x86_energy_perf_policy.8 $RPM_BUILD_ROOT%{_mandir}/man8
-cd -
-%endif
 
-# broken makefile, install manually
-%if 0
 %{__make} install \
        -C tools/power/x86/turbostat \
        DESTDIR=$RPM_BUILD_ROOT
-%else
-cd tools/power/x86/turbostat
-cp -p turbostat.8 $RPM_BUILD_ROOT%{_mandir}/man8
-cd -
-install -p turbostat $RPM_BUILD_ROOT%{_bindir}/turbostat
-%endif
 %endif
 
 %if %{with perf}
 %{__make} -j1 install install-man \
        -C tools/perf \
+%ifarch %{x8664}
+       IS_X86_64=1 \
+%endif
        %{!?with_gtk:NO_GTK2=1} \
        %{!?with_libunwind:NO_LIBUNWIND=1} \
        CC="%{__cc}" \
@@ -397,10 +418,6 @@ rm -rf $RPM_BUILD_ROOT
 %files perf
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/perf
-%ifarch %{x8664}
-%attr(755,root,root) %{_bindir}/perf-read-vdso32
-%attr(755,root,root) %{_bindir}/perf-read-vdsox32
-%endif
 %attr(755,root,root) %{_bindir}/trace
 %{_mandir}/man1/perf*.1*
 %dir %{_datadir}/perf-core
@@ -433,6 +450,16 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/traceevent/plugins
 %attr(755,root,root) %{_libdir}/traceevent/plugins/plugin_*.so
 
+%ifarch %{x8664}
+%files perf-vdso32
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/perf-read-vdso32
+
+%files perf-vdsox32
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/perf-read-vdsox32
+%endif
+
 %if %{with gtk}
 %files perf-gtk
 %defattr(644,root,root,755)
This page took 0.06786 seconds and 4 git commands to generate.