]> git.pld-linux.org Git - packages/kernel-tools.git/blobdiff - kernel-tools.spec
- -cpupower-libs-devel doesn't require base
[packages/kernel-tools.git] / kernel-tools.spec
index b562752a53aa3c439965a8e0b031a849b8a4d863..369261fcdac0546dd6a19a2fa421f19c537cfc7b 100644 (file)
@@ -1,32 +1,41 @@
 # TODO:
 # - redefine: PACKAGE_BUGREPORT=cpufreq@vger.kernel.org
 # - add -n python-perf?
-# - without perf bcond does not work (it still builds it)
 # - add bcond to disable building docs (perf docs)
-# - install of perf compiles things over again
+# - install of perf links perf binary again
 
 # Conditional build:
 %bcond_without verbose         # verbose build (V=1)
 %bcond_without perf            # perf tools
 %bcond_without gtk             # GTK+ 2.x perf support
+%bcond_without libunwind       # libunwind perf support
+%bcond_without multilib        # multilib perf support
 
-%define                basever         3.16
-%define                postver         .2
+%ifarch x32
+%undefine      with_libunwind
+%endif
+%ifnarch %{x8664}
+%undefine      with_multilib
+%endif
+
+%define                basever         4.4
+%define                postver         .0
 Summary:       Assortment of tools for the Linux kernel
 Summary(pl.UTF-8):     Zestaw narzędzi dla jądra Linuksa
 Name:          kernel-tools
 Version:       %{basever}%{postver}
-Release:       2
+Release:       1
 License:       GPL v2
 Group:         Applications/System
-Source0:       https://www.kernel.org/pub/linux/kernel/v3.x/linux-%{basever}.tar.xz
-# Source0-md5: 5c569ed649a0c9711879f333e90c5386
-%if "%{postver}" != ".0"
-Patch0:                https://www.kernel.org/pub/linux/kernel/v3.x/patch-%{version}.xz
-# Patch0-md5:  926e6e2ee0634ce53730701da749b040
-%endif
+Source0:       https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
+# Source0-md5: 9a78fa2eb6c68ca5a40ed5af08142599
 Source1:       cpupower.service
 Source2:       cpupower.config
+%if "%{postver}" != ".0"
+Patch0:                https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
+# Patch0-md5:  3a465c7cf55ec9dbf2d72d9292aa5fde
+%endif
+Patch1:                x32.patch
 URL:           http://www.kernel.org/
 BuildRequires: gettext-tools
 BuildRequires: pciutils-devel
@@ -42,7 +51,11 @@ BuildRequires:       docbook-dtd45-xml
 BuildRequires: docbook-style-xsl
 BuildRequires: elfutils-devel
 BuildRequires: flex
-BuildRequires: libunwind-devel >= 0.99
+%if %{with multilib}
+BuildRequires: gcc-multilib-32
+BuildRequires: gcc-multilib-x32
+%endif
+%{?with_libunwind:BuildRequires:       libunwind-devel >= 0.99}
 BuildRequires: numactl-devel
 BuildRequires: perl-devel >= 5.1
 BuildRequires: python-devel
@@ -76,11 +89,7 @@ Group:               Applications/System
 Requires(post,preun,postun):   systemd-units >= 38
 Requires:      %{name}-cpupower-libs = %{version}-%{release}
 Requires:      systemd-units >= 0.38
-Provides:      cpufreq-utils = 1:009-0.6.p1
-Provides:      cpufrequtils = 1:009-0.6.p1
 Provides:      cpupowerutils = 1:009-0.6.p1
-Obsoletes:     cpufreq-utils < 1:009-0.6.p1
-Obsoletes:     cpufrequtils < 1:009-0.6.p1
 Obsoletes:     cpupowerutils < 1:009-0.6.p1
 Obsoletes:     cpuspeed < 1:1.5-16
 
@@ -107,12 +116,10 @@ Biblioteka cpupower.
 Summary:       Development files for the cpupower library
 Summary(pl.UTF-8):     Pliki programistyczne biblioteki cpupower
 Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
 Requires:      %{name}-cpupower-libs = %{version}-%{release}
-Provides:      cpufrequtils-devel = 1:009-0.6.p1
 Provides:      cpupowerutils-devel = 1:009-0.6.p1
-Obsoletes:     cpufrequtils-devel < 1:009-0.6.p1
 Obsoletes:     cpupowerutils-devel < 1:009-0.6.p1
+Conflicts:     cpufrequtils-devel
 
 %description cpupower-libs-devel
 Development files for the cpupower library.
@@ -146,6 +153,56 @@ przez nowe wersje jądra Linuksa.
 Ten pakiet zawiera podstawowe pliki, skrypty oraz interfejs tekstowy
 (TUI).
 
+%package perf-vdso32
+Summary:       perf profiler tool - VDSO 32-bit ABI reader
+Summary(pl.UTF-8):     Narzędzie profilujące perf - odczyt VDSO dla ABI 32-bitowego
+Group:         Applications/System
+Requires:      %{name}-perf = %{version}-%{release}
+
+%description perf-vdso32
+Perf is a profiler tool for Linux 2.6+ based systems that abstracts
+away CPU hardware differences in Linux performance measurements and
+presents a simple commandline interface. Perf is based on the
+perf_events interface exported by recent versions of the Linux kernel.
+
+This package contains perf-read-vdso32 tool for reading the 32-bit
+compatibility VDSO in 64-bit mode.
+
+%description perf-vdso32 -l pl.UTF-8
+Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
+odseparowujące od różnic sprzętowych między pomiarami wydajności w
+zależności od procesora oraz udostępniające prosty interfejs linii
+poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
+przez nowe wersje jądra Linuksa.
+
+Ten pakiet zawiera narzędzie perf-read-vdso32 do odczytu VDSO dla
+binariów 32-bitowych w trybie 64-bitowym.
+
+%package perf-vdsox32
+Summary:       perf profiler tool - VDSO x32 ABI reader
+Summary(pl.UTF-8):     Narzędzie profilujące perf - odczyt VDSO dla ABI x32
+Group:         Applications/System
+Requires:      %{name}-perf = %{version}-%{release}
+
+%description perf-vdsox32
+Perf is a profiler tool for Linux 2.6+ based systems that abstracts
+away CPU hardware differences in Linux performance measurements and
+presents a simple commandline interface. Perf is based on the
+perf_events interface exported by recent versions of the Linux kernel.
+
+This package contains perf-read-vdso32 tool for reading the x32 mode
+32-bit compatibility VDSO in 64-bit mode.
+
+%description perf-vdsox32 -l pl.UTF-8
+Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
+odseparowujące od różnic sprzętowych między pomiarami wydajności w
+zależności od procesora oraz udostępniające prosty interfejs linii
+poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
+przez nowe wersje jądra Linuksa.
+
+Ten pakiet zawiera narzędzie perf-read-vdso32 do odczytu VDSO dla
+binariów ABI x32 w trybie 64-bitowym.
+
 %package perf-gtk
 Summary:       perf profiler tool (GTK+ 2 GUI)
 Summary(pl.UTF-8):     Narzędzie profilujące perf (interfejs graficzny GTK+ 2)
@@ -193,6 +250,8 @@ cd linux-%{basever}
 %patch0 -p1
 %endif
 
+%patch1 -p1
+
 sed -i -e 's#libexec/perf-core#%{_datadir}/perf-core#g' tools/perf/config/Makefile
 
 %build
@@ -208,19 +267,19 @@ cd linux-%{basever}
        OPTIMIZATION="%{rpmcflags}" \
        STRIPCMD=true
 
-%ifarch %{ix86}
+%ifarch %{ix86} x32
 %{__make} -C tools/power/cpupower/debug/i386 centrino-decode powernow-k8-decode \
        CC="%{__cc}" \
        CFLAGS="%{rpmcflags}"
 %endif
 
-%ifarch %{x8664}
+%ifarch %{x8664} x32
 %{__make} -C tools/power/cpupower/debug/x86_64 centrino-decode powernow-k8-decode \
        CC="%{__cc}" \
        CFLAGS="%{rpmcflags}"
 %endif
 
-%ifarch %{ix86} %{x8664}
+%ifarch %{ix86} %{x8664} x32
 %{__make} -C tools/power/x86/x86_energy_perf_policy \
        CC="%{__cc}" \
        CFLAGS="%{rpmcflags}"
@@ -236,12 +295,18 @@ CFLAGS="%{rpmcflags}" \
 
 %if %{with perf}
 %{__make} -C tools/perf all man \
+%ifarch %{x8664}
+       IS_X86_64=1 \
+       %{!?with_multilib:NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1} \
+%endif
        %{!?with_gtk:NO_GTK2=1} \
+       %{!?with_libunwind:NO_LIBUNWIND=1} \
        %{makeopts} \
        CFLAGS_OPTIMIZE="%{rpmcflags}" \
        WERROR=0 \
        prefix=%{_prefix} \
        perfexecdir=%{_datadir}/perf-core \
+       lib=%{_lib} \
        template_dir=%{_datadir}/perf-core/templates
 %endif
 
@@ -269,10 +334,10 @@ install -d $RPM_BUILD_ROOT{/etc/sysconfig,%{systemdunitdir}}
 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/cpupower.service
 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/cpupower
 
-%ifarch %{ix86}
+%ifarch %{ix86} x32
 install -p tools/power/cpupower/debug/i386/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
 %endif
-%ifarch %{x8664}
+%ifarch %{x8664} x32
 install -p tools/power/cpupower/debug/x86_64/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
 %endif
 
@@ -280,37 +345,23 @@ install -p tools/vm/slabinfo $RPM_BUILD_ROOT%{_bindir}
 install -p tools/vm/page-types $RPM_BUILD_ROOT%{_sbindir}
 install -p dslm $RPM_BUILD_ROOT%{_sbindir}
 
-%ifarch %{ix86} %{x8664}
+%ifarch %{ix86} %{x8664} x32
 install -d $RPM_BUILD_ROOT%{_mandir}/man8
-# broken makefile, install manually
-%if 0
-%{__make} install \
-       -C tools/power/x86/x86_energy_perf_policy \
+%{__make} -C tools/power/x86/x86_energy_perf_policy install \
        DESTDIR=$RPM_BUILD_ROOT
-%else
-cd tools/power/x86/x86_energy_perf_policy
-install -p x86_energy_perf_policy $RPM_BUILD_ROOT%{_bindir}
-cp -p x86_energy_perf_policy.8 $RPM_BUILD_ROOT%{_mandir}/man8
-cd -
-%endif
 
-# broken makefile, install manually
-%if 0
-%{__make} install \
-       -C tools/power/x86/turbostat \
+%{__make} -C tools/power/x86/turbostat install \
        DESTDIR=$RPM_BUILD_ROOT
-%else
-cd tools/power/x86/turbostat
-cp -p turbostat.8 $RPM_BUILD_ROOT%{_mandir}/man8
-cd -
-install -p turbostat $RPM_BUILD_ROOT%{_bindir}/turbostat
-%endif
 %endif
 
 %if %{with perf}
-%{__make} -j1 install install-man \
-       -C tools/perf \
+%{__make} -C tools/perf -j1 install install-man \
+%ifarch %{x8664}
+       IS_X86_64=1 \
+       %{!?with_multilib:NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1} \
+%endif
        %{!?with_gtk:NO_GTK2=1} \
+       %{!?with_libunwind:NO_LIBUNWIND=1} \
        CC="%{__cc}" \
        CFLAGS_OPTIMIZE="%{rpmcflags}" \
        WERROR=0 \
@@ -318,6 +369,7 @@ install -p turbostat $RPM_BUILD_ROOT%{_bindir}/turbostat
        prefix=%{_prefix} \
        perfexecdir=%{_datadir}/perf-core \
        template_dir=%{_datadir}/perf-core/templates \
+       lib=%{_lib} \
        DESTDIR=$RPM_BUILD_ROOT
 
 %py_comp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
@@ -350,11 +402,11 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/slabinfo
 %attr(755,root,root) %{_sbindir}/dslm
 %attr(755,root,root) %{_sbindir}/page-types
-%ifarch %{ix86} %{x8664}
+%ifarch %{ix86} %{x8664} x32
 %attr(755,root,root) %{_bindir}/centrino-decode
 %attr(755,root,root) %{_bindir}/powernow-k8-decode
 %endif
-%ifarch %{ix86} %{x8664}
+%ifarch %{ix86} %{x8664} x32
 %attr(755,root,root) %{_bindir}/turbostat
 %attr(755,root,root) %{_bindir}/x86_energy_perf_policy
 %{_mandir}/man8/turbostat.8*
@@ -386,6 +438,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/perf*.1*
 %dir %{_datadir}/perf-core
 %attr(755,root,root) %{_datadir}/perf-core/perf-archive
+%attr(755,root,root) %{_datadir}/perf-core/perf-with-kcore
 
 %dir %{_datadir}/perf-core/scripts
 
@@ -413,6 +466,16 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/traceevent/plugins
 %attr(755,root,root) %{_libdir}/traceevent/plugins/plugin_*.so
 
+%if %{with multilib}
+%files perf-vdso32
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/perf-read-vdso32
+
+%files perf-vdsox32
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/perf-read-vdsox32
+%endif
+
 %if %{with gtk}
 %files perf-gtk
 %defattr(644,root,root,755)
This page took 0.09862 seconds and 4 git commands to generate.