]> git.pld-linux.org Git - packages/kernel-tools.git/blobdiff - kernel-tools.spec
- up to 3.16.1
[packages/kernel-tools.git] / kernel-tools.spec
index 9499686fd7fb8a8afc0877d14c871a4e26fccee0..02666f335988c94fe790581572562a52e827a14b 100644 (file)
@@ -1,55 +1,80 @@
-# TODO
-# - BR deps for -perf
-# - asciidoc used at install stage of perf (should build doc in build section)
-# - different packages for perf-slang and perf-gtk
+# TODO:
+# - redefine: PACKAGE_BUGREPORT=cpufreq@vger.kernel.org
+# - add -n python-perf?
+# - without perf bcond does not work (it still builds it)
+# - add bcond to disable building docs (perf docs)
+# - install of perf compiles things over again
 
-#
 # Conditional build:
 %bcond_without verbose         # verbose build (V=1)
-%bcond_with    perf            # perf tools (unfinished)
+%bcond_without perf            # perf tools
+%bcond_without gtk             # gtk perf version
 
-%define                rel             0.3
-%define                basever 3.6
-%define                postver .6
+%define                basever         3.16
+%define                postver         .1
 Summary:       Assortment of tools for the Linux kernel
+Summary(pl.UTF-8):     Zestaw narzędzi dla jądra Linuksa
 Name:          kernel-tools
 Version:       %{basever}%{postver}
-Release:       %{rel}
+Release:       1
 License:       GPL v2
 Group:         Applications/System
-Source0:       http://www.kernel.org/pub/linux/kernel/v3.x/linux-%{basever}.tar.xz
-# Source0-md5: 1a1760420eac802c541a20ab51a093d1
+Source0:       https://www.kernel.org/pub/linux/kernel/v3.x/linux-%{basever}.tar.xz
+# Source0-md5: 5c569ed649a0c9711879f333e90c5386
 %if "%{postver}" != ".0"
-Patch0:                http://www.kernel.org/pub/linux/kernel/v3.x/patch-%{version}.bz2
-# Patch0-md5:  363e730147333182616cc687345e7fe2
+Patch0:                https://www.kernel.org/pub/linux/kernel/v3.x/patch-%{version}.xz
+# Patch0-md5:  9da4b0f5e343455b8141bcfa47e88cf5
 %endif
 Source1:       cpupower.service
 Source2:       cpupower.config
+Source3:       perf.sh
+URL:           http://www.kernel.org/
+BuildRequires: gettext-tools
+BuildRequires: pciutils-devel
 BuildRequires: rpmbuild(macros) >= 1.647
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
 %if %{with perf}
 BuildRequires: asciidoc
-BuildRequires: newt-devel
+BuildRequires: audit-libs-devel
+BuildRequires: binutils-devel
+BuildRequires: bison
+BuildRequires: docbook-dtd45-xml
+BuildRequires: docbook-style-xsl
+BuildRequires: elfutils-devel
+BuildRequires: flex
+BuildRequires: libunwind-devel >= 0.99
+BuildRequires: perl-devel >= 5.1
+BuildRequires: python-devel
 BuildRequires: rpm-pythonprov
 BuildRequires: slang-devel
 BuildRequires: xmlto
-# provides perf.h which util/parse-events.l loads via ../perf.h, and -I/usr/include/slang makes it being loaded first
-BuildConflicts:        Firebird-devel
+%if %{with gtk}
+BuildRequires: gtk+2-devel >= 2.0
+BuildRequires: pkgconfig
+%endif
 %endif
-Requires:      %{name}-libs = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# otherwise /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
+%define                _enable_debug_packages  0
+
 %define                makeopts        CC="%{__cc}" %{?with_verbose:V=1}
 
 %description
-This package contains the tools/ directory from the kernel source and
-the supporting documentation.
+This package contains the software from tools/ subdirectory from Linux
+kernel source and the supporting documentation.
+
+%description -l pl.UTF-8
+Ten pakiet zawiera oprogramowanie z podkatalogu tools/ ze źródeł jądra
+Linuksa oraz związaną z nim dokumentację.
 
 %package cpupower
 Summary:       cpupower - Shows and sets processor power related values
+Summary(pl.UTF-8):     cpupower - wyświetlanie i ustawianie wartości związanych z zużyciem energii przez procesor
 Group:         Applications/System
 Requires(post,preun,postun):   systemd-units >= 38
+Requires:      %{name}-cpupower-libs = %{version}-%{release}
 Requires:      systemd-units >= 0.38
 Provides:      cpufreq-utils = 1:009-0.6.p1
 Provides:      cpufrequtils = 1:009-0.6.p1
@@ -63,37 +88,125 @@ Obsoletes: cpuspeed < 1:1.5-16
 cpupower is a collection of tools to examine and tune power saving
 related features of your processor.
 
+%description cpupower -l pl.UTF-8
+cpupower to zbiór narzędzi do sprawdzania i ustawiania opcji procesora
+związanych z oszczędzaniem energii.
+
 %package cpupower-libs
-Summary:       cpupower libraries
-License:       GPL v2
+Summary:       cpupower library
+Summary(pl.UTF-8):     Biblioteka cpupower
 Group:         Libraries
 
 %description cpupower-libs
-cpupower libraries.
+cpupower library.
+
+%description cpupower-libs -l pl.UTF-8
+Biblioteka cpupower.
 
 %package cpupower-libs-devel
-Summary:       Development files for the cpupower libraries
-License:       GPL v2
+Summary:       Development files for the cpupower library
+Summary(pl.UTF-8):     Pliki programistyczne biblioteki cpupower
 Group:         Development/Libraries
-Requires:      kernel-tools = %{version}-%{release}
-Requires:      kernel-tools-libs = %{version}-%{release}
+Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-cpupower-libs = %{version}-%{release}
+Provides:      cpufrequtils-devel = 1:009-0.6.p1
 Provides:      cpupowerutils-devel = 1:009-0.6.p1
-Provides:      kernel-tools-devel
+Obsoletes:     cpufrequtils-devel < 1:009-0.6.p1
 Obsoletes:     cpupowerutils-devel < 1:009-0.6.p1
 
 %description cpupower-libs-devel
-Development files for the cpupower libraries.
+Development files for the cpupower library.
+
+%description cpupower-libs-devel -l pl.UTF-8
+Pliki programistyczne biblioteki cpupower.
 
-%package perf
-Summary:       perf tool
+%package perf-core
+Summary:       perf profiler tool (core package)
+Summary(pl.UTF-8):     Narzędzie profilujące perf (podstawowe narzędzia)
 Group:         Applications/System
+Suggests:      binutils
+
+%description perf-core
+Perf is a profiler tool for Linux 2.6+ based systems that abstracts
+away CPU hardware differences in Linux performance measurements and
+presents a simple commandline interface. Perf is based on the
+perf_events interface exported by recent versions of the Linux kernel.
+
+This package contains core files and scripts.
+
+%description perf-core -l pl.UTF-8
+Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
+odseparowujące od różnic sprzętowych między pomiarami wydajności w
+zależności od procesora oraz udostępniające prosty interfejs linii
+poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
+przez nowe wersje jądra Linuksa.
 
-%description perf
+Ten pakiet zawiera podstawowe pliki i skrypty.
+
+%package perf-gtk
+Summary:       perf profiler tool (GTK+ GUI)
+Summary(pl.UTF-8):     Narzędzie profilujące perf (interfejs graficzny GTK+)
+Group:         X11/Applications
+Requires:      %{name}-perf-core = %{version}-%{release}
+Provides:      %{name}-perf = %{version}-%{release}
+
+%description perf-gtk
 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
 away CPU hardware differences in Linux performance measurements and
 presents a simple commandline interface. Perf is based on the
 perf_events interface exported by recent versions of the Linux kernel.
 
+This package contains GTK+ based GUI.
+
+%description perf-gtk -l pl.UTF-8
+Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
+odseparowujące od różnic sprzętowych między pomiarami wydajności w
+zależności od procesora oraz udostępniające prosty interfejs linii
+poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
+przez nowe wersje jądra Linuksa.
+
+Ten pakiet zawiera graficzny interfejs oparty na GTK+.
+
+%package perf-slang
+Summary:       perf profiler tool (Slang TUI)
+Summary(pl.UTF-8):     Narzędzie profilujące perf (interfejs tekstowy Slang)
+Group:         X11/Applications
+Requires:      %{name}-perf-core = %{version}-%{release}
+Provides:      %{name}-perf = %{version}-%{release}
+
+%description perf-slang
+Perf is a profiler tool for Linux 2.6+ based systems that abstracts
+away CPU hardware differences in Linux performance measurements and
+presents a simple commandline interface. Perf is based on the
+perf_events interface exported by recent versions of the Linux kernel.
+
+This package contains Slang based TUI.
+
+%description perf-slang -l pl.UTF-8
+Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
+odseparowujące od różnic sprzętowych między pomiarami wydajności w
+zależności od procesora oraz udostępniające prosty interfejs linii
+poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
+przez nowe wersje jądra Linuksa.
+
+Ten pakiet zawiera tekstowy interfejs oparty na bibliotece Slang.
+
+%package -n bash-completion-perf
+Summary:       Bash completion for perf command
+Summary(pl.UTF-8):     Bashowe uzupełnianie parametrów dla polecenia perf
+Group:         Applications/Shells
+Requires:      %{name}-perf
+Requires:      bash-completion
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
+
+%description -n bash-completion-perf
+Bash completion for perf command.
+
+%description -n bash-completion-perf -l pl.UTF-8
+Bashowe uzupełnianie parametrów dla polecenia perf.
+
 %prep
 %setup -qc
 cd linux-%{basever}
@@ -102,61 +215,86 @@ cd linux-%{basever}
 %patch0 -p1
 %endif
 
+sed -i -e 's#libexec/perf-core#%{_datadir}/perf-core#g' tools/perf/config/Makefile
+
 %build
 cd linux-%{basever}
 
+# Simple Disk Sleep Monitor
+%{__cc} %{rpmcppflags} %{rpmcflags} %{rpmldflags} Documentation/laptops/dslm.c -o dslm
+
 # cpupower
 %{__make} -C tools/power/cpupower \
        %{makeopts} \
-       CPUFREQ_BENCH=false
+       CPUFREQ_BENCH=false \
+       OPTIMIZATION="%{rpmcflags}" \
+       STRIPCMD=true
 
 %ifarch %{ix86}
 %{__make} -C tools/power/cpupower/debug/i386 centrino-decode powernow-k8-decode \
-       %{makeopts} \
+       CC="%{__cc}" \
+       CFLAGS="%{rpmcflags}"
 %endif
 
 %ifarch %{x8664}
 %{__make} -C tools/power/cpupower/debug/x86_64 centrino-decode powernow-k8-decode \
-       %{makeopts}
+       CC="%{__cc}" \
+       CFLAGS="%{rpmcflags}"
 %endif
 
 %ifarch %{ix86} %{x8664}
 %{__make} -C tools/power/x86/x86_energy_perf_policy \
-       %{makeopts}
+       CC="%{__cc}" \
+       CFLAGS="%{rpmcflags}"
+CFLAGS="%{rpmcflags}" \
 %{__make} -C tools/power/x86/turbostat \
-       %{makeopts}
+       CC="%{__cc}"
 %endif
 
+# page-types, slabinfo
+%{__make} -C tools/vm page-types slabinfo \
+       CC="%{__cc}" \
+       CFLAGS="%{rpmcflags} -Wall -Wextra -I../lib"
+
 %if %{with perf}
 # perf slang version
 PWD=${PWD:-$(pwd)}
 install -d $PWD/perf-{slang,gtk}
-%{__make} -C tools/perf \
+%{__make} -C tools/perf all man \
        O=$PWD/perf-slang \
        NO_GTK2=1 \
        %{makeopts} \
+       CFLAGS_OPTIMIZE="%{rpmcflags}" \
+       WERROR=0 \
        prefix=%{_prefix} \
        perfexecdir=%{_datadir}/perf-core \
        template_dir=%{_datadir}/perf-core/templates
 
+%if %{with gtk}
 # perf gtk version
-%{__make} -C tools/perf \
+%{__make} -C tools/perf all man \
        O=$PWD/perf-gtk \
        %{makeopts} \
+       CFLAGS_OPTIMIZE="%{rpmcflags}" \
+       WERROR=0 \
        prefix=%{_prefix} \
        perfexecdir=%{_datadir}/perf-core \
        template_dir=%{_datadir}/perf-core/templates
 %endif
+%endif
 
 # gen_init_cpio
 %{__make} -C usr gen_init_cpio \
        %{makeopts} \
+       CFLAGS="%{rpmcflags}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
+
 cd linux-%{basever}
+install -d $RPM_BUILD_ROOT%{_sbindir}
 
-%{__make} -C tools/power/cpupower  install \
+%{__make} -C tools/power/cpupower install \
        DESTDIR=$RPM_BUILD_ROOT \
        libdir=%{_libdir} \
        mandir=%{_mandir} \
@@ -170,18 +308,16 @@ cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/cpupower.service
 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/cpupower
 
 %ifarch %{ix86}
-cd tools/power/cpupower/debug/i386
-install -p centrino-decode $RPM_BUILD_ROOT%{_bindir}/centrino-decode
-install -p powernow-k8-decode $RPM_BUILD_ROOT%{_bindir}/powernow-k8-decode
-cd -
+install -p tools/power/cpupower/debug/i386/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
 %endif
 %ifarch %{x8664}
-cd tools/power/cpupower/debug/x86_64
-install -p centrino-decode $RPM_BUILD_ROOT%{_bindir}/centrino-decode
-install -p powernow-k8-decode $RPM_BUILD_ROOT%{_bindir}/powernow-k8-decode
-cd -
+install -p tools/power/cpupower/debug/x86_64/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
 %endif
 
+install -p tools/vm/slabinfo $RPM_BUILD_ROOT%{_bindir}
+install -p tools/vm/page-types $RPM_BUILD_ROOT%{_sbindir}
+install -p dslm $RPM_BUILD_ROOT%{_sbindir}
+
 %ifarch %{ix86} %{x8664}
 install -d $RPM_BUILD_ROOT%{_mandir}/man8
 # broken makefile, install manually
@@ -192,7 +328,7 @@ install -d $RPM_BUILD_ROOT%{_mandir}/man8
 %else
 cd tools/power/x86/x86_energy_perf_policy
 install -p x86_energy_perf_policy $RPM_BUILD_ROOT%{_bindir}
-install -p x86_energy_perf_policy.8 $RPM_BUILD_ROOT%{_mandir}/man8
+cp -p x86_energy_perf_policy.8 $RPM_BUILD_ROOT%{_mandir}/man8
 cd -
 %endif
 
@@ -203,9 +339,9 @@ cd -
        DESTDIR=$RPM_BUILD_ROOT
 %else
 cd tools/power/x86/turbostat
-install -p turbostat $RPM_BUILD_ROOT%{_bindir}/turbostat
-install -p turbostat.8 $RPM_BUILD_ROOT%{_mandir}/man8
+cp -p turbostat.8 $RPM_BUILD_ROOT%{_mandir}/man8
 cd -
+install -p turbostat $RPM_BUILD_ROOT%{_bindir}/turbostat
 %endif
 %endif
 
@@ -218,22 +354,37 @@ PWD=${PWD:-$(pwd)}
        O=$PWD/perf-slang \
        NO_GTK2=1 \
        CC="%{__cc}" \
+       CFLAGS_OPTIMIZE="%{rpmcflags}" \
+       WERROR=0 \
        %{?with_verbose:V=1} \
        prefix=%{_prefix} \
        perfexecdir=%{_datadir}/perf-core \
        template_dir=%{_datadir}/perf-core/templates \
        DESTDIR=$RPM_BUILD_ROOT
+%{__mv} $RPM_BUILD_ROOT%{_bindir}/perf{,_slang}
 
+%if %{with gtk}
 # perf gtk
 %{__make} -j1 install install-man \
        -C tools/perf \
        O=$PWD/perf-gtk \
        CC="%{__cc}" \
+       CFLAGS_OPTIMIZE="%{rpmcflags}" \
+       WERROR=0 \
        %{?with_verbose:V=1} \
        prefix=%{_prefix} \
        perfexecdir=%{_datadir}/perf-core \
        template_dir=%{_datadir}/perf-core/templates \
        DESTDIR=$RPM_BUILD_ROOT
+%{__mv} $RPM_BUILD_ROOT%{_bindir}/perf{,_gtk}
+%endif
+
+%py_comp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
+%py_ocomp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
+
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/perf-core/tests
+
+install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/perf
 %endif
 
 # gen_init_cpio
@@ -256,6 +407,10 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/gen_init_cpio
+%attr(755,root,root) %{_bindir}/slabinfo
+%attr(755,root,root) %{_sbindir}/dslm
+%attr(755,root,root) %{_sbindir}/page-types
 %ifarch %{ix86} %{x8664}
 %attr(755,root,root) %{_bindir}/centrino-decode
 %attr(755,root,root) %{_bindir}/powernow-k8-decode
@@ -263,30 +418,29 @@ rm -rf $RPM_BUILD_ROOT
 %ifarch %{ix86} %{x8664}
 %attr(755,root,root) %{_bindir}/turbostat
 %attr(755,root,root) %{_bindir}/x86_energy_perf_policy
-%{_mandir}/man8/turbostat*
-%{_mandir}/man8/x86_energy_perf_policy*
+%{_mandir}/man8/turbostat.8*
+%{_mandir}/man8/x86_energy_perf_policy.8*
 %endif
-%attr(755,root,root) %{_bindir}/gen_init_cpio
 
 %files cpupower -f cpupower.lang
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/cpupower
-%{_mandir}/man[1-8]/cpupower*
+%{_mandir}/man1/cpupower*.1*
 %{systemdunitdir}/cpupower.service
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cpupower
 
 %files cpupower-libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libcpupower.so.*.*.*
-%ghost %{_libdir}/libcpupower.so.0
+%attr(755,root,root) %ghost %{_libdir}/libcpupower.so.0
 
 %files cpupower-libs-devel
 %defattr(644,root,root,755)
-%{_libdir}/libcpupower.so
+%attr(755,root,root) %{_libdir}/libcpupower.so
 %{_includedir}/cpufreq.h
 
 %if %{with perf}
-%files perf
+%files perf-core
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/perf
 %{_mandir}/man1/perf*.1*
@@ -310,8 +464,26 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib
 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf
 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace
-%{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace/*.py
+%{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace/*.py*
 %dir %{_datadir}/perf-core/scripts/python/bin
 %attr(755,root,root) %{_datadir}/perf-core/scripts/python/bin/*
-%{_datadir}/perf-core/scripts/python/*.py
+%{_datadir}/perf-core/scripts/python/*.py*
+
+%dir %{_libdir}/traceevent
+%dir %{_libdir}/traceevent/plugins
+%attr(755,root,root) %{_libdir}/traceevent/plugins/plugin_*.so
+
+%if %{with gtk}
+%files perf-gtk
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/perf_gtk
+%endif
+
+%files perf-slang
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/perf_slang
+
+%files -n bash-completion-perf
+%defattr(644,root,root,755)
+/etc/bash_completion.d/perf
 %endif
This page took 0.089243 seconds and 4 git commands to generate.