]> git.pld-linux.org Git - packages/kernel-tools.git/blame - kernel-tools.spec
- up to 4.4.0
[packages/kernel-tools.git] / kernel-tools.spec
CommitLineData
bb6b0f50
ER
1# TODO:
2# - redefine: PACKAGE_BUGREPORT=cpufreq@vger.kernel.org
b1f08c11
ER
3# - add -n python-perf?
4# - without perf bcond does not work (it still builds it)
5# - add bcond to disable building docs (perf docs)
6# - install of perf compiles things over again
bb6b0f50 7
49fba13a
ER
8# Conditional build:
9%bcond_without verbose # verbose build (V=1)
db5f9ac9 10%bcond_without perf # perf tools
ae4c1fd4 11%bcond_without gtk # GTK+ 2.x perf support
5a8bbd03
JR
12%bcond_without libunwind # libunwind perf support
13
14%ifarch x32
15%undefine with_libunwind
16%endif
49fba13a 17
da4153c4
JR
18%define basever 4.4
19%define postver .0
49fba13a 20Summary: Assortment of tools for the Linux kernel
bd620db3 21Summary(pl.UTF-8): Zestaw narzędzi dla jądra Linuksa
49fba13a
ER
22Name: kernel-tools
23Version: %{basever}%{postver}
da4153c4 24Release: 1
49fba13a 25License: GPL v2
fea1e605 26Group: Applications/System
3109d83e 27Source0: https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
da4153c4 28# Source0-md5: 9a78fa2eb6c68ca5a40ed5af08142599
bedc6c43
JR
29Source1: cpupower.service
30Source2: cpupower.config
49fba13a 31%if "%{postver}" != ".0"
3109d83e 32Patch0: https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
dcbcf21f 33# Patch0-md5: 3a465c7cf55ec9dbf2d72d9292aa5fde
49fba13a 34%endif
bedc6c43 35Patch1: x32.patch
52583efa 36URL: http://www.kernel.org/
bedc6c43 37%ifarch %{x8664}
e8e6f555 38BuildRequires: gcc-multilib-32
c0d5ff44 39BuildRequires: gcc-multilib-x32
bedc6c43 40%endif
4a7175d2 41BuildRequires: gettext-tools
9596c3d3 42BuildRequires: pciutils-devel
a8b28c3a 43BuildRequires: rpmbuild(macros) >= 1.647
49fba13a
ER
44BuildRequires: tar >= 1:1.22
45BuildRequires: xz
fea1e605
ER
46%if %{with perf}
47BuildRequires: asciidoc
52583efa 48BuildRequires: audit-libs-devel
db5f9ac9 49BuildRequires: binutils-devel
52583efa 50BuildRequires: bison
a8b28c3a 51BuildRequires: docbook-dtd45-xml
52583efa
JB
52BuildRequires: docbook-style-xsl
53BuildRequires: elfutils-devel
54BuildRequires: flex
5a8bbd03 55%{?with_libunwind:BuildRequires: libunwind-devel >= 0.99}
60ccbbd3 56BuildRequires: numactl-devel
52583efa 57BuildRequires: perl-devel >= 5.1
52583efa 58BuildRequires: python-devel
fea1e605 59BuildRequires: rpm-pythonprov
a1c57a8e 60BuildRequires: slang-devel
fea1e605 61BuildRequires: xmlto
a8b28c3a
ER
62%if %{with gtk}
63BuildRequires: gtk+2-devel >= 2.0
64BuildRequires: pkgconfig
65%endif
fea1e605 66%endif
49fba13a
ER
67BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
eb373af4
AM
69# otherwise /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
70%define _enable_debug_packages 0
71
60972f76
ER
72%define makeopts CC="%{__cc}" %{?with_verbose:V=1}
73
49fba13a 74%description
bd620db3
JB
75This package contains the software from tools/ subdirectory from Linux
76kernel source and the supporting documentation.
77
78%description -l pl.UTF-8
79Ten pakiet zawiera oprogramowanie z podkatalogu tools/ ze źródeł jądra
80Linuksa oraz związaną z nim dokumentację.
49fba13a 81
4bc5704a
JK
82%package cpupower
83Summary: cpupower - Shows and sets processor power related values
bd620db3 84Summary(pl.UTF-8): cpupower - wyświetlanie i ustawianie wartości związanych z zużyciem energii przez procesor
4bc5704a 85Group: Applications/System
f57fcd71 86Requires(post,preun,postun): systemd-units >= 38
91fd1f55 87Requires: %{name}-cpupower-libs = %{version}-%{release}
f57fcd71 88Requires: systemd-units >= 0.38
2bd21e06 89Provides: cpupowerutils = 1:009-0.6.p1
2bd21e06
ER
90Obsoletes: cpupowerutils < 1:009-0.6.p1
91Obsoletes: cpuspeed < 1:1.5-16
4bc5704a
JK
92
93%description cpupower
60972f76
ER
94cpupower is a collection of tools to examine and tune power saving
95related features of your processor.
4bc5704a 96
bd620db3
JB
97%description cpupower -l pl.UTF-8
98cpupower to zbiór narzędzi do sprawdzania i ustawiania opcji procesora
99związanych z oszczędzaniem energii.
100
4bc5704a 101%package cpupower-libs
bd620db3
JB
102Summary: cpupower library
103Summary(pl.UTF-8): Biblioteka cpupower
49fba13a
ER
104Group: Libraries
105
4bc5704a 106%description cpupower-libs
bd620db3
JB
107cpupower library.
108
109%description cpupower-libs -l pl.UTF-8
110Biblioteka cpupower.
49fba13a 111
4bc5704a 112%package cpupower-libs-devel
bd620db3
JB
113Summary: Development files for the cpupower library
114Summary(pl.UTF-8): Pliki programistyczne biblioteki cpupower
49fba13a 115Group: Development/Libraries
178c4b31
ER
116Requires: %{name} = %{version}-%{release}
117Requires: %{name}-cpupower-libs = %{version}-%{release}
49fba13a 118Provides: cpupowerutils-devel = 1:009-0.6.p1
49fba13a 119Obsoletes: cpupowerutils-devel < 1:009-0.6.p1
08be99c5 120Conflicts: cpufrequtils-devel
49fba13a 121
4bc5704a 122%description cpupower-libs-devel
bd620db3
JB
123Development files for the cpupower library.
124
125%description cpupower-libs-devel -l pl.UTF-8
126Pliki programistyczne biblioteki cpupower.
49fba13a 127
ae4c1fd4
JB
128%package perf
129Summary: perf profiler tool
130Summary(pl.UTF-8): Narzędzie profilujące perf
fea1e605 131Group: Applications/System
9efc8fed 132Suggests: binutils
ae4c1fd4
JB
133Obsoletes: perf-core
134Obsoletes: perf-slang
fea1e605 135
ae4c1fd4 136%description perf
fea1e605
ER
137Perf is a profiler tool for Linux 2.6+ based systems that abstracts
138away CPU hardware differences in Linux performance measurements and
139presents a simple commandline interface. Perf is based on the
140perf_events interface exported by recent versions of the Linux kernel.
141
ae4c1fd4 142This package contains core files, scripts and text interface (TUI).
db5f9ac9 143
ae4c1fd4 144%description perf -l pl.UTF-8
db5f9ac9
JB
145Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
146odseparowujące od różnic sprzętowych między pomiarami wydajności w
147zależności od procesora oraz udostępniające prosty interfejs linii
148poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
149przez nowe wersje jądra Linuksa.
150
ae4c1fd4
JB
151Ten pakiet zawiera podstawowe pliki, skrypty oraz interfejs tekstowy
152(TUI).
db5f9ac9 153
0a3bb9dd 154%package perf-vdso32
dda20c35
JB
155Summary: perf profiler tool - VDSO 32-bit ABI reader
156Summary(pl.UTF-8): Narzędzie profilujące perf - odczyt VDSO dla ABI 32-bitowego
0a3bb9dd
JR
157Group: Applications/System
158Requires: %{name}-perf = %{version}-%{release}
159
160%description perf-vdso32
161Perf is a profiler tool for Linux 2.6+ based systems that abstracts
162away CPU hardware differences in Linux performance measurements and
163presents a simple commandline interface. Perf is based on the
164perf_events interface exported by recent versions of the Linux kernel.
165
166This package contains perf-read-vdso32 tool for reading the 32-bit
167compatibility VDSO in 64-bit mode.
168
dda20c35
JB
169%description perf-vdso32 -l pl.UTF-8
170Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
171odseparowujące od różnic sprzętowych między pomiarami wydajności w
172zależności od procesora oraz udostępniające prosty interfejs linii
173poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
174przez nowe wersje jądra Linuksa.
175
176Ten pakiet zawiera narzędzie perf-read-vdso32 do odczytu VDSO dla
177binariów 32-bitowych w trybie 64-bitowym.
178
0a3bb9dd 179%package perf-vdsox32
dda20c35
JB
180Summary: perf profiler tool - VDSO x32 ABI reader
181Summary(pl.UTF-8): Narzędzie profilujące perf - odczyt VDSO dla ABI x32
0a3bb9dd
JR
182Group: Applications/System
183Requires: %{name}-perf = %{version}-%{release}
184
185%description perf-vdsox32
186Perf is a profiler tool for Linux 2.6+ based systems that abstracts
187away CPU hardware differences in Linux performance measurements and
188presents a simple commandline interface. Perf is based on the
189perf_events interface exported by recent versions of the Linux kernel.
190
191This package contains perf-read-vdso32 tool for reading the x32 mode
19232-bit compatibility VDSO in 64-bit mode.
193
dda20c35
JB
194%description perf-vdsox32 -l pl.UTF-8
195Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
196odseparowujące od różnic sprzętowych między pomiarami wydajności w
197zależności od procesora oraz udostępniające prosty interfejs linii
198poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
199przez nowe wersje jądra Linuksa.
200
201Ten pakiet zawiera narzędzie perf-read-vdso32 do odczytu VDSO dla
202binariów ABI x32 w trybie 64-bitowym.
203
db5f9ac9 204%package perf-gtk
ae4c1fd4
JB
205Summary: perf profiler tool (GTK+ 2 GUI)
206Summary(pl.UTF-8): Narzędzie profilujące perf (interfejs graficzny GTK+ 2)
db5f9ac9 207Group: X11/Applications
dad8cd2d 208Requires: %{name}-perf = %{version}-%{release}
db5f9ac9
JB
209
210%description perf-gtk
211Perf is a profiler tool for Linux 2.6+ based systems that abstracts
212away CPU hardware differences in Linux performance measurements and
213presents a simple commandline interface. Perf is based on the
214perf_events interface exported by recent versions of the Linux kernel.
215
ae4c1fd4 216This package contains GTK+ 2 based GUI.
db5f9ac9
JB
217
218%description perf-gtk -l pl.UTF-8
219Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
220odseparowujące od różnic sprzętowych między pomiarami wydajności w
221zależności od procesora oraz udostępniające prosty interfejs linii
222poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
223przez nowe wersje jądra Linuksa.
224
ae4c1fd4 225Ten pakiet zawiera graficzny interfejs oparty na GTK+ 2.
db5f9ac9 226
db5f9ac9
JB
227%package -n bash-completion-perf
228Summary: Bash completion for perf command
229Summary(pl.UTF-8): Bashowe uzupełnianie parametrów dla polecenia perf
230Group: Applications/Shells
3385eb86 231Requires: %{name}-perf
db5f9ac9 232Requires: bash-completion
741b96de
ER
233%if "%{_rpmversion}" >= "5"
234BuildArch: noarch
235%endif
db5f9ac9
JB
236
237%description -n bash-completion-perf
238Bash completion for perf command.
239
240%description -n bash-completion-perf -l pl.UTF-8
241Bashowe uzupełnianie parametrów dla polecenia perf.
242
49fba13a
ER
243%prep
244%setup -qc
245cd linux-%{basever}
246
247%if "%{postver}" != ".0"
248%patch0 -p1
249%endif
250
bedc6c43
JR
251%patch1 -p1
252
eb373af4
AM
253sed -i -e 's#libexec/perf-core#%{_datadir}/perf-core#g' tools/perf/config/Makefile
254
49fba13a
ER
255%build
256cd linux-%{basever}
257
b1f08c11
ER
258# Simple Disk Sleep Monitor
259%{__cc} %{rpmcppflags} %{rpmcflags} %{rpmldflags} Documentation/laptops/dslm.c -o dslm
260
49fba13a
ER
261# cpupower
262%{__make} -C tools/power/cpupower \
60972f76 263 %{makeopts} \
fb1ff9fc
JB
264 CPUFREQ_BENCH=false \
265 OPTIMIZATION="%{rpmcflags}" \
266 STRIPCMD=true
49fba13a 267
bedc6c43 268%ifarch %{ix86} x32
49fba13a 269%{__make} -C tools/power/cpupower/debug/i386 centrino-decode powernow-k8-decode \
fb1ff9fc
JB
270 CC="%{__cc}" \
271 CFLAGS="%{rpmcflags}"
49fba13a
ER
272%endif
273
bedc6c43 274%ifarch %{x8664} x32
49fba13a 275%{__make} -C tools/power/cpupower/debug/x86_64 centrino-decode powernow-k8-decode \
fb1ff9fc
JB
276 CC="%{__cc}" \
277 CFLAGS="%{rpmcflags}"
49fba13a
ER
278%endif
279
bedc6c43 280%ifarch %{ix86} %{x8664} x32
49fba13a 281%{__make} -C tools/power/x86/x86_energy_perf_policy \
fb1ff9fc
JB
282 CC="%{__cc}" \
283 CFLAGS="%{rpmcflags}"
4b352448 284CFLAGS="%{rpmcflags}" \
49fba13a 285%{__make} -C tools/power/x86/turbostat \
4b352448 286 CC="%{__cc}"
49fba13a
ER
287%endif
288
f111fe43
JK
289# page-types, slabinfo
290%{__make} -C tools/vm page-types slabinfo \
701b458f 291 CC="%{__cc}" \
f111fe43 292 CFLAGS="%{rpmcflags} -Wall -Wextra -I../lib"
701b458f 293
fea1e605 294%if %{with perf}
52583efa 295%{__make} -C tools/perf all man \
4dfb9dde
JR
296%ifarch %{x8664}
297 IS_X86_64=1 \
298%endif
ae4c1fd4 299 %{!?with_gtk:NO_GTK2=1} \
5a8bbd03 300 %{!?with_libunwind:NO_LIBUNWIND=1} \
60972f76 301 %{makeopts} \
fb1ff9fc 302 CFLAGS_OPTIMIZE="%{rpmcflags}" \
d0e13ec9 303 WERROR=0 \
fea1e605
ER
304 prefix=%{_prefix} \
305 perfexecdir=%{_datadir}/perf-core \
4f4642fc 306 lib=%{_lib} \
fea1e605 307 template_dir=%{_datadir}/perf-core/templates
bc35d286 308%endif
fea1e605 309
dd28be58
JK
310# gen_init_cpio
311%{__make} -C usr gen_init_cpio \
60972f76 312 %{makeopts} \
fb1ff9fc 313 CFLAGS="%{rpmcflags}"
dd28be58 314
49fba13a
ER
315%install
316rm -rf $RPM_BUILD_ROOT
b1f08c11 317
49fba13a 318cd linux-%{basever}
b1f08c11 319install -d $RPM_BUILD_ROOT%{_sbindir}
49fba13a 320
bd620db3 321%{__make} -C tools/power/cpupower install \
49fba13a
ER
322 DESTDIR=$RPM_BUILD_ROOT \
323 libdir=%{_libdir} \
324 mandir=%{_mandir} \
325 CPUFREQ_BENCH=false
326
327%find_lang cpupower
328mv cpupower.lang ..
329
f57fcd71
ER
330install -d $RPM_BUILD_ROOT{/etc/sysconfig,%{systemdunitdir}}
331cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/cpupower.service
332cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/cpupower
333
bedc6c43 334%ifarch %{ix86} x32
701b458f 335install -p tools/power/cpupower/debug/i386/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
49fba13a 336%endif
bedc6c43 337%ifarch %{x8664} x32
701b458f 338install -p tools/power/cpupower/debug/x86_64/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
49fba13a
ER
339%endif
340
b1f08c11 341install -p tools/vm/slabinfo $RPM_BUILD_ROOT%{_bindir}
f111fe43 342install -p tools/vm/page-types $RPM_BUILD_ROOT%{_sbindir}
b1f08c11 343install -p dslm $RPM_BUILD_ROOT%{_sbindir}
701b458f 344
bedc6c43 345%ifarch %{ix86} %{x8664} x32
49fba13a 346install -d $RPM_BUILD_ROOT%{_mandir}/man8
49fba13a
ER
347%{__make} install \
348 -C tools/power/x86/x86_energy_perf_policy \
349 DESTDIR=$RPM_BUILD_ROOT
49fba13a 350
49fba13a
ER
351%{__make} install \
352 -C tools/power/x86/turbostat \
353 DESTDIR=$RPM_BUILD_ROOT
49fba13a 354%endif
fea1e605
ER
355
356%if %{with perf}
fea1e605
ER
357%{__make} -j1 install install-man \
358 -C tools/perf \
4dfb9dde
JR
359%ifarch %{x8664}
360 IS_X86_64=1 \
361%endif
ae4c1fd4 362 %{!?with_gtk:NO_GTK2=1} \
5a8bbd03 363 %{!?with_libunwind:NO_LIBUNWIND=1} \
fea1e605 364 CC="%{__cc}" \
fb1ff9fc 365 CFLAGS_OPTIMIZE="%{rpmcflags}" \
6e9d46c8 366 WERROR=0 \
fea1e605
ER
367 %{?with_verbose:V=1} \
368 prefix=%{_prefix} \
369 perfexecdir=%{_datadir}/perf-core \
370 template_dir=%{_datadir}/perf-core/templates \
4f4642fc 371 lib=%{_lib} \
fea1e605 372 DESTDIR=$RPM_BUILD_ROOT
db5f9ac9
JB
373
374%py_comp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
375%py_ocomp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
a8b28c3a 376
4b352448 377%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/perf-core/tests
49fba13a
ER
378%endif
379
dd28be58 380# gen_init_cpio
60972f76 381install -p usr/gen_init_cpio $RPM_BUILD_ROOT%{_bindir}/gen_init_cpio
dd28be58 382
49fba13a
ER
383%clean
384rm -rf $RPM_BUILD_ROOT
385
4bc5704a
JK
386%post cpupower-libs -p /sbin/ldconfig
387%postun cpupower-libs -p /sbin/ldconfig
49fba13a 388
f57fcd71
ER
389%post cpupower
390%systemd_post cpupower.service
391
392%preun cpupower
393%systemd_preun cpupower.service
394
395%postun cpupower
396%systemd_reload
397
4bc5704a 398%files
49fba13a 399%defattr(644,root,root,755)
701b458f
JB
400%attr(755,root,root) %{_bindir}/gen_init_cpio
401%attr(755,root,root) %{_bindir}/slabinfo
b1f08c11 402%attr(755,root,root) %{_sbindir}/dslm
f111fe43 403%attr(755,root,root) %{_sbindir}/page-types
bedc6c43 404%ifarch %{ix86} %{x8664} x32
49fba13a
ER
405%attr(755,root,root) %{_bindir}/centrino-decode
406%attr(755,root,root) %{_bindir}/powernow-k8-decode
407%endif
bedc6c43 408%ifarch %{ix86} %{x8664} x32
49fba13a
ER
409%attr(755,root,root) %{_bindir}/turbostat
410%attr(755,root,root) %{_bindir}/x86_energy_perf_policy
bd620db3
JB
411%{_mandir}/man8/turbostat.8*
412%{_mandir}/man8/x86_energy_perf_policy.8*
49fba13a
ER
413%endif
414
4bc5704a
JK
415%files cpupower -f cpupower.lang
416%defattr(644,root,root,755)
417%attr(755,root,root) %{_bindir}/cpupower
bd620db3 418%{_mandir}/man1/cpupower*.1*
f57fcd71
ER
419%{systemdunitdir}/cpupower.service
420%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cpupower
4bc5704a
JK
421
422%files cpupower-libs
49fba13a
ER
423%defattr(644,root,root,755)
424%attr(755,root,root) %{_libdir}/libcpupower.so.*.*.*
bd620db3 425%attr(755,root,root) %ghost %{_libdir}/libcpupower.so.0
49fba13a 426
4bc5704a 427%files cpupower-libs-devel
49fba13a 428%defattr(644,root,root,755)
bd620db3 429%attr(755,root,root) %{_libdir}/libcpupower.so
49fba13a 430%{_includedir}/cpufreq.h
fea1e605
ER
431
432%if %{with perf}
ae4c1fd4 433%files perf
fea1e605 434%defattr(644,root,root,755)
35be6466 435%attr(755,root,root) %{_bindir}/perf
ae4c1fd4 436%attr(755,root,root) %{_bindir}/trace
fea1e605
ER
437%{_mandir}/man1/perf*.1*
438%dir %{_datadir}/perf-core
439%attr(755,root,root) %{_datadir}/perf-core/perf-archive
4f4642fc 440%attr(755,root,root) %{_datadir}/perf-core/perf-with-kcore
fea1e605
ER
441
442%dir %{_datadir}/perf-core/scripts
443
444%dir %{_datadir}/perf-core/scripts/perl
445%dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util
446%dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib
447%dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf
448%dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace
449%{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace/*.pm
450%dir %{_datadir}/perf-core/scripts/perl/bin
451%attr(755,root,root) %{_datadir}/perf-core/scripts/perl/bin/*
452%{_datadir}/perf-core/scripts/perl/*.pl
453
454%dir %{_datadir}/perf-core/scripts/python
455%dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util
456%dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib
457%dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf
458%dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace
db5f9ac9 459%{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace/*.py*
fea1e605
ER
460%dir %{_datadir}/perf-core/scripts/python/bin
461%attr(755,root,root) %{_datadir}/perf-core/scripts/python/bin/*
db5f9ac9
JB
462%{_datadir}/perf-core/scripts/python/*.py*
463
eb373af4
AM
464%dir %{_libdir}/traceevent
465%dir %{_libdir}/traceevent/plugins
466%attr(755,root,root) %{_libdir}/traceevent/plugins/plugin_*.so
467
0a3bb9dd
JR
468%ifarch %{x8664}
469%files perf-vdso32
470%defattr(644,root,root,755)
471%attr(755,root,root) %{_bindir}/perf-read-vdso32
472
473%files perf-vdsox32
474%defattr(644,root,root,755)
475%attr(755,root,root) %{_bindir}/perf-read-vdsox32
476%endif
477
bc35d286 478%if %{with gtk}
db5f9ac9
JB
479%files perf-gtk
480%defattr(644,root,root,755)
ae4c1fd4 481%attr(755,root,root) %{_libdir}/libperf-gtk.so
bc35d286 482%endif
db5f9ac9 483
db5f9ac9
JB
484%files -n bash-completion-perf
485%defattr(644,root,root,755)
486/etc/bash_completion.d/perf
fea1e605 487%endif
This page took 0.128361 seconds and 4 git commands to generate.