]> git.pld-linux.org Git - packages/kde4-kdeplasma-addons.git/blame - kde4-kdeplasma-addons.spec
- BR: qca-devel
[packages/kde4-kdeplasma-addons.git] / kde4-kdeplasma-addons.spec
CommitLineData
32c4451f 1# TODO:
2# Lancelot: installed - cmake unimplemented because not found
3# * XRender - Lancelot compositing support
4# * Eigen2 - Eigen2 enables the Mandelbrot wallpaper plugin.
c73f6b0c 5
6%bcond_without marble # don't build marble plasma support
7
32c4451f 8%define orgname kdeplasma-addons
9%define _state stable
40f03c32 10%define qtver 4.7.0
1cf65df3 11
12Summary: KDE4 Plasmoids
b4bc4746 13Summary(pl.UTF-8): Plazmoidy dla KDE4
1cf65df3 14Name: kde4-kdeplasma-addons
49eaf52c 15Version: 4.5.3
fd153232 16Release: 3
1cf65df3 17License: GPL v2
18Group: X11/Applications
19Source0: ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
49eaf52c 20# Source0-md5: f23d0d5d465e314c05c5282cddfa6ab6
9baaa66a 21Patch100: %{name}-branch.diff
28096eda 22Patch0: %{name}-pastebinpld.patch
7ab2d436 23URL: http://www.kde.org/
22957f69 24BuildRequires: OpenGL-GLU-devel
ae48935e 25BuildRequires: OpenGL-devel
32c4451f 26BuildRequires: QtCore-devel >= %{qtver}
27BuildRequires: QtNetwork-devel >= %{qtver}
28BuildRequires: QtOpenGL-devel >= %{qtver}
29BuildRequires: QtScript-devel >= %{qtver}
30BuildRequires: QtSvg-devel >= %{qtver}
31BuildRequires: QtWebKit-devel >= %{qtver}
28096eda 32BuildRequires: automoc4 >= 0.9.88
32c4451f 33BuildRequires: cmake >= 2.8.0
cae2d48b 34BuildRequires: eigen >= 1:2.0.12-3
1cf65df3 35BuildRequires: kde4-kdebase-workspace-devel >= %{version}
fa5beca3 36%{?with_marble:BuildRequires: kde4-kdeedu-devel >= %{version}}
c73f6b0c 37BuildRequires: kde4-kdegraphics-devel >= %{version}
1cf65df3 38BuildRequires: kde4-kdelibs-devel >= %{version}
39BuildRequires: kde4-kdepimlibs-devel >= %{version}
05a0aa81 40BuildRequires: phonon-devel >= 4.4.1
0915a2df 41BuildRequires: pkgconfig
42BuildRequires: python
fd153232 43BuildRequires: qca-devel >= 2.0.2
64ed9cbc 44BuildRequires: qimageblitz-devel >= 0.0.6
32c4451f 45BuildRequires: qt4-build >= %{qtver}
46BuildRequires: qt4-qmake >= %{qtver}
1cf65df3 47BuildRequires: rpmbuild(macros) >= 1.293
05a0aa81 48BuildRequires: shared-desktop-ontologies-devel >= 0.5
49BuildRequires: soprano-devel >= 2.4.64
50BuildRequires: strigi-devel >= 0.7.2
32c4451f 51BuildRequires: xorg-lib-libXcomposite-devel
52BuildRequires: xorg-lib-libXdamage-devel
53BuildRequires: xorg-lib-libXrender-devel
75f86cc0 54BuildRequires: xorg-lib-libXtst-devel
1cf65df3 55Obsoletes: kde4-kdeplasmoids
56BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58%description
b4bc4746 59KDE4 plasmoids.
1cf65df3 60
61%description -l pl.UTF-8
b4bc4746 62Plazmoidy dla KDE4.
1cf65df3 63
28096eda 64%package lancelot
65Summary: Lancelot Desktop Theme
72db3ff2 66Summary(pl.UTF-8): Motyw pulpitu Lancelot
28096eda 67Group: X11/Applications
68Requires: kde4-kdebase-workspace >= %{version}
69
70%description lancelot
71Lancelot Desktop Theme.
72
73%description lancelot -l pl.UTF-8
72db3ff2 74Motyw pulpitu Lancelot.
28096eda 75
c73f6b0c 76%package devel
77Summary: Development files for KDE4 Plasmoids
78Summary(pl.UTF-8): Pliki nagłówkowe bibliotek plazmoidów dla KDE4
79Group: X11/Development/Libraries
80Requires: %{name} = %{version}-%{release}
0e26ec14 81Requires: kde4-kdebase-workspace-devel >= %{version}
82Requires: kde4-kdegraphics-devel >= %{version}
83Requires: kde4-kdelibs-devel >= %{version}
84Requires: kde4-kdepimlibs-devel >= %{version}
c73f6b0c 85
86%description devel
87This package contains header files needed if you wish to build
88applications based on KDE4 Plasmoids.
89
90%description devel -l pl.UTF-8
91Pakiet ten zawiera pliki nagłówkowe potrzebne do budowy aplikacji
92opartych na plazmoidach dla KDE4.
93
1cf65df3 94%prep
95%setup -q -n %{orgname}-%{version}
508bd1fc 96#%patch100 -p0
28096eda 97%patch0 -p1
1cf65df3 98
99%build
100install -d build
101cd build
102%cmake \
103 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
c73f6b0c 104 -DLIB_INSTALL_DIR=%{_libdir} \
07563c11 105 -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
1cf65df3 106%if "%{_lib}" != "lib"
107 -DLIB_SUFFIX=64 \
108%endif
109 ../
110
111%{__make}
112
113%install
114rm -rf $RPM_BUILD_ROOT
115
116%{__make} -C build install \
117 DESTDIR=$RPM_BUILD_ROOT
118
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%post -p /sbin/ldconfig
123%postun -p /sbin/ldconfig
124
28096eda 125%post lancelot -p /sbin/ldconfig
126%postun lancelot -p /sbin/ldconfig
127
1cf65df3 128%files
129%defattr(644,root,root,755)
130%attr(755,root,root) %{_libdir}/kde4/krunner_*.so
28096eda 131%attr(755,root,root) %{_libdir}/kde4/kcm_krunner_*.so
05fc8ea2
RT
132%attr(755,root,root) %{_libdir}/kde4/plasma_applet_bball.so
133%attr(755,root,root) %{_libdir}/kde4/plasma_applet_binaryclock.so
134%attr(755,root,root) %{_libdir}/kde4/plasma_applet_blackboard.so
135%attr(755,root,root) %{_libdir}/kde4/plasma_applet_bookmarks.so
136%attr(755,root,root) %{_libdir}/kde4/plasma_applet_bubblemon.so
137%attr(755,root,root) %{_libdir}/kde4/plasma_applet_calculator.so
138%attr(755,root,root) %{_libdir}/kde4/plasma_applet_charselect.so
139%attr(755,root,root) %{_libdir}/kde4/plasma_applet_comic.so
140%attr(755,root,root) %{_libdir}/kde4/plasma_applet_dict.so
141%attr(755,root,root) %{_libdir}/kde4/plasma_applet_eyes.so
142%attr(755,root,root) %{_libdir}/kde4/plasma_applet_fifteenPuzzle.so
143%attr(755,root,root) %{_libdir}/kde4/plasma_applet_fileWatcher.so
144%attr(755,root,root) %{_libdir}/kde4/plasma_applet_frame.so
145%attr(755,root,root) %{_libdir}/kde4/plasma_applet_fuzzy_clock.so
146%attr(755,root,root) %{_libdir}/kde4/plasma_applet_incomingmsg.so
147%attr(755,root,root) %{_libdir}/kde4/plasma_applet_knowledgebase.so
148%attr(755,root,root) %{_libdir}/kde4/plasma_applet_kolourpicker.so
149%attr(755,root,root) %{_libdir}/kde4/plasma_applet_konqprofiles.so
150%attr(755,root,root) %{_libdir}/kde4/plasma_applet_konsoleprofiles.so
151%attr(755,root,root) %{_libdir}/kde4/plasma_applet_leavenote.so
152%attr(755,root,root) %{_libdir}/kde4/plasma_applet_life.so
153%attr(755,root,root) %{_libdir}/kde4/plasma_applet_luna.so
154%attr(755,root,root) %{_libdir}/kde4/plasma_applet_magnifique.so
155%attr(755,root,root) %{_libdir}/kde4/plasma_applet_mediaplayer.so
156%attr(755,root,root) %{_libdir}/kde4/plasma_applet_microblog.so
157%attr(755,root,root) %{_libdir}/kde4/plasma_applet_news.so
158%attr(755,root,root) %{_libdir}/kde4/plasma_applet_notes.so
159%attr(755,root,root) %{_libdir}/kde4/plasma_applet_nowplaying.so
160%attr(755,root,root) %{_libdir}/kde4/plasma_applet_opendesktop.so
161%attr(755,root,root) %{_libdir}/kde4/plasma_applet_opendesktop_activities.so
162%attr(755,root,root) %{_libdir}/kde4/plasma_applet_paste.so
163%attr(755,root,root) %{_libdir}/kde4/plasma_applet_pastebin.so
164%attr(755,root,root) %{_libdir}/kde4/plasma_applet_plasmaboard.so
165%attr(755,root,root) %{_libdir}/kde4/plasma_applet_previewer.so
166%attr(755,root,root) %{_libdir}/kde4/plasma_applet_qalculate.so
167%attr(755,root,root) %{_libdir}/kde4/plasma_applet_rssnow.so
168%attr(755,root,root) %{_libdir}/kde4/plasma_applet_rtm.so
169%attr(755,root,root) %{_libdir}/kde4/plasma_applet_showdashboard.so
170%attr(755,root,root) %{_libdir}/kde4/plasma_applet_showdesktop.so
171%attr(755,root,root) %{_libdir}/kde4/plasma_applet_spellcheck.so
172%attr(755,root,root) %{_libdir}/kde4/plasma_applet_timer.so
173%attr(755,root,root) %{_libdir}/kde4/plasma_applet_unitconverter.so
174%attr(755,root,root) %{_libdir}/kde4/plasma_applet_weather.so
175%attr(755,root,root) %{_libdir}/kde4/plasma_applet_weatherstation.so
176%attr(755,root,root) %{_libdir}/kde4/plasma_applet_webslice.so
1cf65df3 177%attr(755,root,root) %{_libdir}/kde4/plasma_comic_*.so
178%attr(755,root,root) %{_libdir}/kde4/plasma_engine_*.so
28096eda 179%attr(755,root,root) %{_libdir}/kde4/plasma_packagestructure_comic.so
1cf65df3 180%attr(755,root,root) %ghost %{_libdir}/libplasmacomicprovidercore.so.?
181%attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so.*.*.*
c73f6b0c 182%attr(755,root,root) %{_libdir}/kde4/plasma-applet_systemloadviewer.so
183%attr(755,root,root) %{_libdir}/kde4/plasma_potd_apodprovider.so
184%attr(755,root,root) %{_libdir}/kde4/plasma_potd_epodprovider.so
185%attr(755,root,root) %{_libdir}/kde4/plasma_potd_flickrprovider.so
186%attr(755,root,root) %{_libdir}/kde4/plasma_potd_oseiprovider.so
187%attr(755,root,root) %{_libdir}/kde4/plasma_potd_wcpotdprovider.so
85896f2c 188%attr(755,root,root) %{_libdir}/kde4/plasma_runner_datetime.so
c73f6b0c 189%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_mandelbrot.so
190%if %{with marble}
191%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_marble.so
192%endif
193%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_pattern.so
194%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_virus.so
195%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_weather.so
c73f6b0c 196%attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so
197%attr(755,root,root) %ghost %{_libdir}/libplasmapotdprovidercore.so.?
198%attr(755,root,root) %{_libdir}/libplasmapotdprovidercore.so.*.*.*
199%attr(755,root,root) %ghost %{_libdir}/libplasmaweather.so.?
200%attr(755,root,root) %{_libdir}/libplasmaweather.so.*.*.*
201%attr(755,root,root) %ghost %{_libdir}/librtm.so.?
202%attr(755,root,root) %{_libdir}/librtm.so.*.*.*
1cf65df3 203%{_datadir}/apps/desktoptheme/Aya
204%{_datadir}/apps/desktoptheme/Elegance
205%{_datadir}/apps/desktoptheme/Silicon
28096eda 206%dir %{_datadir}/apps/desktoptheme/default/stylesheets
207%{_datadir}/apps/desktoptheme/default/stylesheets/*
208%dir %{_datadir}/apps/desktoptheme/default/weatherstation
209%{_datadir}/apps/desktoptheme/default/weatherstation/*
c73f6b0c 210%dir %{_datadir}/apps/desktoptheme/default/weather/
211%{_datadir}/apps/desktoptheme/default/weather/wind-arrows.svgz
1cf65df3 212%{_datadir}/apps/desktoptheme/default/widgets/*
213%{_datadir}/apps/desktoptheme/heron
214%{_datadir}/apps/desktoptheme/slim-glow
05fc8ea2
RT
215%{_datadir}/kde4/services/CharRunner_config.desktop
216%{_datadir}/kde4/services/CharacterRunner.desktop
217%{_datadir}/kde4/services/apodprovider.desktop
218%{_datadir}/kde4/services/browserhistory.desktop
219%{_datadir}/kde4/services/epodprovider.desktop
220%{_datadir}/kde4/services/flickrprovider.desktop
221%{_datadir}/kde4/services/katesessions.desktop
222%{_datadir}/kde4/services/konquerorsessions.desktop
223%{_datadir}/kde4/services/konsolesessions.desktop
224%{_datadir}/kde4/services/oseiprovider.desktop
225%{_datadir}/kde4/services/plasma-applet-bball.desktop
226%{_datadir}/kde4/services/plasma-applet-binaryclock.desktop
227%{_datadir}/kde4/services/plasma-applet-blackboard.desktop
228%{_datadir}/kde4/services/plasma-applet-bookmarks.desktop
229%{_datadir}/kde4/services/plasma-applet-bubblemon.desktop
230%{_datadir}/kde4/services/plasma-applet-calculator.desktop
231%{_datadir}/kde4/services/plasma-applet-charselect.desktop
232%{_datadir}/kde4/services/plasma-applet-eyes.desktop
233%{_datadir}/kde4/services/plasma-applet-fifteenPuzzle.desktop
234%{_datadir}/kde4/services/plasma-applet-incomingmsg.desktop
235%{_datadir}/kde4/services/plasma-applet-knowledgebase.desktop
236%{_datadir}/kde4/services/plasma-applet-konqprofiles.desktop
237%{_datadir}/kde4/services/plasma-applet-konsoleprofiles.desktop
238%{_datadir}/kde4/services/plasma-applet-leavenote.desktop
239%{_datadir}/kde4/services/plasma-applet-life.desktop
240%{_datadir}/kde4/services/plasma-applet-luna.desktop
241%{_datadir}/kde4/services/plasma-applet-magnifique.desktop
242%{_datadir}/kde4/services/plasma-applet-mediaplayer.desktop
243%{_datadir}/kde4/services/plasma-applet-microblog.desktop
244%{_datadir}/kde4/services/plasma-applet-news.desktop
245%{_datadir}/kde4/services/plasma-applet-nowplaying.desktop
246%{_datadir}/kde4/services/plasma-applet-opendesktop-activities.desktop
247%{_datadir}/kde4/services/plasma-applet-opendesktop.desktop
248%{_datadir}/kde4/services/plasma-applet-paste.desktop
249%{_datadir}/kde4/services/plasma-applet-pastebin.desktop
250%{_datadir}/kde4/services/plasma-applet-previewer.desktop
251%{_datadir}/kde4/services/plasma-applet-qalculate.desktop
252%{_datadir}/kde4/services/plasma-applet-rememberthemilk.desktop
253%{_datadir}/kde4/services/plasma-applet-rssnow.desktop
254%{_datadir}/kde4/services/plasma-applet-showdashboard.desktop
255%{_datadir}/kde4/services/plasma-applet-showdesktop.desktop
256%{_datadir}/kde4/services/plasma-applet-spellcheck.desktop
257%{_datadir}/kde4/services/plasma-applet-systemloadviewer.desktop
258%{_datadir}/kde4/services/plasma-applet-timer.desktop
259%{_datadir}/kde4/services/plasma-applet-unitconverter.desktop
260%{_datadir}/kde4/services/plasma-applet-weather.desktop
261%{_datadir}/kde4/services/plasma-applet-weatherstation.desktop
262%{_datadir}/kde4/services/plasma-applet-webslice.desktop
263%{_datadir}/kde4/services/plasma-clock-fuzzy.desktop
264%{_datadir}/kde4/services/plasma-comic-default.desktop
265%{_datadir}/kde4/services/plasma-dataengine-comic.desktop
266%{_datadir}/kde4/services/plasma-dataengine-microblog.desktop
267%{_datadir}/kde4/services/plasma-dataengine-ocs.desktop
268%{_datadir}/kde4/services/plasma-dataengine-potd.desktop
269%{_datadir}/kde4/services/plasma-dict-default.desktop
270%{_datadir}/kde4/services/plasma-engine-kdeobservatory.desktop
271%{_datadir}/kde4/services/plasma-engine-pastebin.desktop
272%{_datadir}/kde4/services/plasma-engine-rtm.desktop
273%{_datadir}/kde4/services/plasma-fileWatcher-default.desktop
274%{_datadir}/kde4/services/plasma-frame-default.desktop
275%{_datadir}/kde4/services/plasma-kolourpicker-default.desktop
276%{_datadir}/kde4/services/plasma-notes-default.desktop
277%{_datadir}/kde4/services/plasma-packagestructure-comic.desktop
278%{_datadir}/kde4/services/plasma-runner-audioplayercontrol.desktop
279%{_datadir}/kde4/services/plasma-runner-audioplayercontrol_config.desktop
280%{_datadir}/kde4/services/plasma-runner-contacts.desktop
281%{_datadir}/kde4/services/plasma-runner-converter.desktop
282%{_datadir}/kde4/services/plasma-runner-datetime.desktop
283%{_datadir}/kde4/services/plasma-runner-kopete.desktop
284%{_datadir}/kde4/services/plasma-runner-spellchecker.desktop
285%{_datadir}/kde4/services/plasma-runner-spellchecker_config.desktop
286%{_datadir}/kde4/services/plasma-runner-techbase.desktop
287%{_datadir}/kde4/services/plasma-runner-wikipedia.desktop
288%{_datadir}/kde4/services/plasma-runner-wikitravel.desktop
289%{_datadir}/kde4/services/plasma-wallpaper-mandelbrot.desktop
290%{_datadir}/kde4/services/plasma-wallpaper-marble.desktop
291%{_datadir}/kde4/services/plasma-wallpaper-pattern.desktop
292%{_datadir}/kde4/services/plasma-wallpaper-virus.desktop
293%{_datadir}/kde4/services/plasma-wallpaper-weather.desktop
294%{_datadir}/kde4/services/plasma_applet_plasmaboard.desktop
295%{_datadir}/kde4/services/wcpotdprovider.desktop
1cf65df3 296%{_datadir}/kde4/servicetypes/plasma_comicprovider.desktop
c73f6b0c 297%{_datadir}/kde4/servicetypes/plasma_potdprovider.desktop
28096eda 298%{_datadir}/config/comic.knsrc
32c4451f 299%{_datadir}/config/plasmaweather.knsrc
c73f6b0c 300%{_datadir}/config/virus_wallpaper.knsrc
28096eda 301%dir %{_datadir}/apps/desktoptheme/default/rssnow
302%{_datadir}/apps/desktoptheme/default/rssnow/background.svgz
303%{_datadir}/apps/desktoptheme/default/rssnow/left.svgz
304%{_datadir}/apps/desktoptheme/default/rssnow/right.svgz
305%{_datadir}/apps/desktoptheme/default/rssnow/rssnow.svgz
c73f6b0c 306%dir %{_datadir}/apps/desktoptheme/default/bubblemon
307%{_datadir}/apps/desktoptheme/default/bubblemon/bubble.svg
308%dir %{_datadir}/apps/desktoptheme/default/fifteenPuzzle
32c4451f 309%{_datadir}/apps/desktoptheme/default/fifteenPuzzle/blanksquare.svg
c73f6b0c 310%{_iconsdir}/hicolor/scalable/apps/fifteenpuzzle.svgz
32c4451f 311%{_iconsdir}/hicolor/scalable/apps/accessories-dictionary.svgz
312%{_iconsdir}/hicolor/scalable/apps/bball.svgz
544dba0a 313%{_iconsdir}/hicolor/*x*/apps/qalculate-applet.png
85896f2c 314%{_iconsdir}/hicolor/*x*/apps/plasmaapplet-shelf.png
c73f6b0c 315
28096eda 316%dir %{_datadir}/apps/rssnow
317%{_datadir}/apps/rssnow/feeds
318%{_iconsdir}/*/*x*/apps/previewer.png
28096eda 319%{_datadir}/kde4/services/ServiceMenus/preview.desktop
320%dir %{_datadir}/apps/bball
321%{_datadir}/apps/bball/bball.svgz
32c4451f 322%{_iconsdir}/*/*x*/apps/bball.png
28096eda 323%{_datadir}/apps/bball/bounce.ogg
324%{_datadir}/apps/bball/football.svgz
c73f6b0c 325%{_datadir}/apps/plasma
85896f2c 326%{_datadir}/apps/plasmaboard
c73f6b0c 327%{_datadir}/apps/plasma-applet-opendesktop
32c4451f 328%{_datadir}/apps/plasma-applet-opendesktop-activities
329%{_datadir}/apps/plasma-applet-frame
c73f6b0c 330%{_datadir}/apps/plasma_pastebin
331%{_datadir}/apps/plasma_wallpaper_pattern
28096eda 332
333%files lancelot
334%defattr(644,root,root,755)
335%attr(755,root,root) %{_bindir}/lancelot
336%attr(755,root,root) %ghost %{_libdir}/liblancelot.so.?
337%attr(755,root,root) %{_libdir}/liblancelot.so.*.*.*
05fc8ea2
RT
338%attr(755,root,root) %{_libdir}/liblancelot.so
339%attr(755,root,root) %{_libdir}/liblancelot-datamodels.so.?
340%attr(755,root,root) %{_libdir}/liblancelot-datamodels.so.*.*.*
341%attr(755,root,root) %{_libdir}/kde4/plasma_applet_lancelot_launcher.so
342%attr(755,root,root) %{_libdir}/kde4/plasma_applet_lancelot_part.so
28096eda 343%{_datadir}/apps/desktoptheme/default/lancelot
32c4451f 344%{_datadir}/apps/desktoptheme/oxygen/lancelot
05fc8ea2
RT
345%{_datadir}/kde4/services/plasma-applet-lancelot-launcher.desktop
346%{_datadir}/kde4/services/plasma-applet-lancelot-part.desktop
28096eda 347%{_datadir}/dbus-1/services/org.kde.lancelot.service
348%{_datadir}/mime/packages/lancelotpart-mime.xml
c73f6b0c 349%{_datadir}/apps/lancelot
28096eda 350%{_iconsdir}/hicolor/*x*/apps/lancelot.png
85896f2c 351%{_iconsdir}/hicolor/*x*/apps/lancelot-start.png
c73f6b0c 352
353%files devel
354%defattr(644,root,root,755)
355%attr(755,root,root) %{_libdir}/*.so
05fc8ea2
RT
356%{_includedir}/KDE/Lancelot
357%{_includedir}/lancelot-datamodels
c73f6b0c 358%{_includedir}/lancelot
40f03c32 359%{_datadir}/apps/cmake/modules/*.cmake
This page took 0.20608 seconds and 4 git commands to generate.