]> git.pld-linux.org Git - packages/kde4-kdeplasma-addons.git/blame - kde4-kdeplasma-addons.spec
- release 2
[packages/kde4-kdeplasma-addons.git] / kde4-kdeplasma-addons.spec
CommitLineData
32c4451f 1# TODO:
2# Lancelot: installed - cmake unimplemented because not found
3# * XRender - Lancelot compositing support
4# * Eigen2 - Eigen2 enables the Mandelbrot wallpaper plugin.
c73f6b0c 5
6%bcond_without marble # don't build marble plasma support
7
32c4451f 8%define orgname kdeplasma-addons
9%define _state stable
40f03c32 10%define qtver 4.7.0
1cf65df3 11
12Summary: KDE4 Plasmoids
b4bc4746 13Summary(pl.UTF-8): Plazmoidy dla KDE4
1cf65df3 14Name: kde4-kdeplasma-addons
49eaf52c 15Version: 4.5.3
3593dc1f 16Release: 2
1cf65df3 17License: GPL v2
18Group: X11/Applications
19Source0: ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
49eaf52c 20# Source0-md5: f23d0d5d465e314c05c5282cddfa6ab6
9baaa66a 21Patch100: %{name}-branch.diff
28096eda 22Patch0: %{name}-pastebinpld.patch
7ab2d436 23URL: http://www.kde.org/
22957f69 24BuildRequires: OpenGL-GLU-devel
ae48935e 25BuildRequires: OpenGL-devel
32c4451f 26BuildRequires: QtCore-devel >= %{qtver}
27BuildRequires: QtNetwork-devel >= %{qtver}
28BuildRequires: QtOpenGL-devel >= %{qtver}
29BuildRequires: QtScript-devel >= %{qtver}
30BuildRequires: QtSvg-devel >= %{qtver}
31BuildRequires: QtWebKit-devel >= %{qtver}
28096eda 32BuildRequires: automoc4 >= 0.9.88
32c4451f 33BuildRequires: cmake >= 2.8.0
cae2d48b 34BuildRequires: eigen >= 1:2.0.12-3
1cf65df3 35BuildRequires: kde4-kdebase-workspace-devel >= %{version}
fa5beca3 36%{?with_marble:BuildRequires: kde4-kdeedu-devel >= %{version}}
c73f6b0c 37BuildRequires: kde4-kdegraphics-devel >= %{version}
1cf65df3 38BuildRequires: kde4-kdelibs-devel >= %{version}
39BuildRequires: kde4-kdepimlibs-devel >= %{version}
05a0aa81 40BuildRequires: phonon-devel >= 4.4.1
0915a2df 41BuildRequires: pkgconfig
42BuildRequires: python
64ed9cbc 43BuildRequires: qimageblitz-devel >= 0.0.6
32c4451f 44BuildRequires: qt4-build >= %{qtver}
45BuildRequires: qt4-qmake >= %{qtver}
1cf65df3 46BuildRequires: rpmbuild(macros) >= 1.293
05a0aa81 47BuildRequires: shared-desktop-ontologies-devel >= 0.5
48BuildRequires: soprano-devel >= 2.4.64
49BuildRequires: strigi-devel >= 0.7.2
32c4451f 50BuildRequires: xorg-lib-libXcomposite-devel
51BuildRequires: xorg-lib-libXdamage-devel
52BuildRequires: xorg-lib-libXrender-devel
75f86cc0 53BuildRequires: xorg-lib-libXtst-devel
1cf65df3 54Obsoletes: kde4-kdeplasmoids
55BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57%description
b4bc4746 58KDE4 plasmoids.
1cf65df3 59
60%description -l pl.UTF-8
b4bc4746 61Plazmoidy dla KDE4.
1cf65df3 62
28096eda 63%package lancelot
64Summary: Lancelot Desktop Theme
72db3ff2 65Summary(pl.UTF-8): Motyw pulpitu Lancelot
28096eda 66Group: X11/Applications
67Requires: kde4-kdebase-workspace >= %{version}
68
69%description lancelot
70Lancelot Desktop Theme.
71
72%description lancelot -l pl.UTF-8
72db3ff2 73Motyw pulpitu Lancelot.
28096eda 74
c73f6b0c 75%package devel
76Summary: Development files for KDE4 Plasmoids
77Summary(pl.UTF-8): Pliki nagłówkowe bibliotek plazmoidów dla KDE4
78Group: X11/Development/Libraries
79Requires: %{name} = %{version}-%{release}
0e26ec14 80Requires: kde4-kdebase-workspace-devel >= %{version}
81Requires: kde4-kdegraphics-devel >= %{version}
82Requires: kde4-kdelibs-devel >= %{version}
83Requires: kde4-kdepimlibs-devel >= %{version}
c73f6b0c 84
85%description devel
86This package contains header files needed if you wish to build
87applications based on KDE4 Plasmoids.
88
89%description devel -l pl.UTF-8
90Pakiet ten zawiera pliki nagłówkowe potrzebne do budowy aplikacji
91opartych na plazmoidach dla KDE4.
92
1cf65df3 93%prep
94%setup -q -n %{orgname}-%{version}
508bd1fc 95#%patch100 -p0
28096eda 96%patch0 -p1
1cf65df3 97
98%build
99install -d build
100cd build
101%cmake \
102 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
c73f6b0c 103 -DLIB_INSTALL_DIR=%{_libdir} \
07563c11 104 -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
1cf65df3 105%if "%{_lib}" != "lib"
106 -DLIB_SUFFIX=64 \
107%endif
108 ../
109
110%{__make}
111
112%install
113rm -rf $RPM_BUILD_ROOT
114
115%{__make} -C build install \
116 DESTDIR=$RPM_BUILD_ROOT
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%post -p /sbin/ldconfig
122%postun -p /sbin/ldconfig
123
28096eda 124%post lancelot -p /sbin/ldconfig
125%postun lancelot -p /sbin/ldconfig
126
1cf65df3 127%files
128%defattr(644,root,root,755)
129%attr(755,root,root) %{_libdir}/kde4/krunner_*.so
28096eda 130%attr(755,root,root) %{_libdir}/kde4/kcm_krunner_*.so
05fc8ea2
RT
131%attr(755,root,root) %{_libdir}/kde4/plasma_applet_bball.so
132%attr(755,root,root) %{_libdir}/kde4/plasma_applet_binaryclock.so
133%attr(755,root,root) %{_libdir}/kde4/plasma_applet_blackboard.so
134%attr(755,root,root) %{_libdir}/kde4/plasma_applet_bookmarks.so
135%attr(755,root,root) %{_libdir}/kde4/plasma_applet_bubblemon.so
136%attr(755,root,root) %{_libdir}/kde4/plasma_applet_calculator.so
137%attr(755,root,root) %{_libdir}/kde4/plasma_applet_charselect.so
138%attr(755,root,root) %{_libdir}/kde4/plasma_applet_comic.so
139%attr(755,root,root) %{_libdir}/kde4/plasma_applet_dict.so
140%attr(755,root,root) %{_libdir}/kde4/plasma_applet_eyes.so
141%attr(755,root,root) %{_libdir}/kde4/plasma_applet_fifteenPuzzle.so
142%attr(755,root,root) %{_libdir}/kde4/plasma_applet_fileWatcher.so
143%attr(755,root,root) %{_libdir}/kde4/plasma_applet_frame.so
144%attr(755,root,root) %{_libdir}/kde4/plasma_applet_fuzzy_clock.so
145%attr(755,root,root) %{_libdir}/kde4/plasma_applet_incomingmsg.so
146%attr(755,root,root) %{_libdir}/kde4/plasma_applet_knowledgebase.so
147%attr(755,root,root) %{_libdir}/kde4/plasma_applet_kolourpicker.so
148%attr(755,root,root) %{_libdir}/kde4/plasma_applet_konqprofiles.so
149%attr(755,root,root) %{_libdir}/kde4/plasma_applet_konsoleprofiles.so
150%attr(755,root,root) %{_libdir}/kde4/plasma_applet_leavenote.so
151%attr(755,root,root) %{_libdir}/kde4/plasma_applet_life.so
152%attr(755,root,root) %{_libdir}/kde4/plasma_applet_luna.so
153%attr(755,root,root) %{_libdir}/kde4/plasma_applet_magnifique.so
154%attr(755,root,root) %{_libdir}/kde4/plasma_applet_mediaplayer.so
155%attr(755,root,root) %{_libdir}/kde4/plasma_applet_microblog.so
156%attr(755,root,root) %{_libdir}/kde4/plasma_applet_news.so
157%attr(755,root,root) %{_libdir}/kde4/plasma_applet_notes.so
158%attr(755,root,root) %{_libdir}/kde4/plasma_applet_nowplaying.so
159%attr(755,root,root) %{_libdir}/kde4/plasma_applet_opendesktop.so
160%attr(755,root,root) %{_libdir}/kde4/plasma_applet_opendesktop_activities.so
161%attr(755,root,root) %{_libdir}/kde4/plasma_applet_paste.so
162%attr(755,root,root) %{_libdir}/kde4/plasma_applet_pastebin.so
163%attr(755,root,root) %{_libdir}/kde4/plasma_applet_plasmaboard.so
164%attr(755,root,root) %{_libdir}/kde4/plasma_applet_previewer.so
165%attr(755,root,root) %{_libdir}/kde4/plasma_applet_qalculate.so
166%attr(755,root,root) %{_libdir}/kde4/plasma_applet_rssnow.so
167%attr(755,root,root) %{_libdir}/kde4/plasma_applet_rtm.so
168%attr(755,root,root) %{_libdir}/kde4/plasma_applet_showdashboard.so
169%attr(755,root,root) %{_libdir}/kde4/plasma_applet_showdesktop.so
170%attr(755,root,root) %{_libdir}/kde4/plasma_applet_spellcheck.so
171%attr(755,root,root) %{_libdir}/kde4/plasma_applet_timer.so
172%attr(755,root,root) %{_libdir}/kde4/plasma_applet_unitconverter.so
173%attr(755,root,root) %{_libdir}/kde4/plasma_applet_weather.so
174%attr(755,root,root) %{_libdir}/kde4/plasma_applet_weatherstation.so
175%attr(755,root,root) %{_libdir}/kde4/plasma_applet_webslice.so
1cf65df3 176%attr(755,root,root) %{_libdir}/kde4/plasma_comic_*.so
177%attr(755,root,root) %{_libdir}/kde4/plasma_engine_*.so
28096eda 178%attr(755,root,root) %{_libdir}/kde4/plasma_packagestructure_comic.so
1cf65df3 179%attr(755,root,root) %ghost %{_libdir}/libplasmacomicprovidercore.so.?
180%attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so.*.*.*
c73f6b0c 181%attr(755,root,root) %{_libdir}/kde4/plasma-applet_systemloadviewer.so
182%attr(755,root,root) %{_libdir}/kde4/plasma_potd_apodprovider.so
183%attr(755,root,root) %{_libdir}/kde4/plasma_potd_epodprovider.so
184%attr(755,root,root) %{_libdir}/kde4/plasma_potd_flickrprovider.so
185%attr(755,root,root) %{_libdir}/kde4/plasma_potd_oseiprovider.so
186%attr(755,root,root) %{_libdir}/kde4/plasma_potd_wcpotdprovider.so
85896f2c 187%attr(755,root,root) %{_libdir}/kde4/plasma_runner_datetime.so
c73f6b0c 188%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_mandelbrot.so
189%if %{with marble}
190%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_marble.so
191%endif
192%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_pattern.so
193%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_virus.so
194%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_weather.so
c73f6b0c 195%attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so
196%attr(755,root,root) %ghost %{_libdir}/libplasmapotdprovidercore.so.?
197%attr(755,root,root) %{_libdir}/libplasmapotdprovidercore.so.*.*.*
198%attr(755,root,root) %ghost %{_libdir}/libplasmaweather.so.?
199%attr(755,root,root) %{_libdir}/libplasmaweather.so.*.*.*
200%attr(755,root,root) %ghost %{_libdir}/librtm.so.?
201%attr(755,root,root) %{_libdir}/librtm.so.*.*.*
1cf65df3 202%{_datadir}/apps/desktoptheme/Aya
203%{_datadir}/apps/desktoptheme/Elegance
204%{_datadir}/apps/desktoptheme/Silicon
28096eda 205%dir %{_datadir}/apps/desktoptheme/default/stylesheets
206%{_datadir}/apps/desktoptheme/default/stylesheets/*
207%dir %{_datadir}/apps/desktoptheme/default/weatherstation
208%{_datadir}/apps/desktoptheme/default/weatherstation/*
c73f6b0c 209%dir %{_datadir}/apps/desktoptheme/default/weather/
210%{_datadir}/apps/desktoptheme/default/weather/wind-arrows.svgz
1cf65df3 211%{_datadir}/apps/desktoptheme/default/widgets/*
212%{_datadir}/apps/desktoptheme/heron
213%{_datadir}/apps/desktoptheme/slim-glow
05fc8ea2
RT
214%{_datadir}/kde4/services/CharRunner_config.desktop
215%{_datadir}/kde4/services/CharacterRunner.desktop
216%{_datadir}/kde4/services/apodprovider.desktop
217%{_datadir}/kde4/services/browserhistory.desktop
218%{_datadir}/kde4/services/epodprovider.desktop
219%{_datadir}/kde4/services/flickrprovider.desktop
220%{_datadir}/kde4/services/katesessions.desktop
221%{_datadir}/kde4/services/konquerorsessions.desktop
222%{_datadir}/kde4/services/konsolesessions.desktop
223%{_datadir}/kde4/services/oseiprovider.desktop
224%{_datadir}/kde4/services/plasma-applet-bball.desktop
225%{_datadir}/kde4/services/plasma-applet-binaryclock.desktop
226%{_datadir}/kde4/services/plasma-applet-blackboard.desktop
227%{_datadir}/kde4/services/plasma-applet-bookmarks.desktop
228%{_datadir}/kde4/services/plasma-applet-bubblemon.desktop
229%{_datadir}/kde4/services/plasma-applet-calculator.desktop
230%{_datadir}/kde4/services/plasma-applet-charselect.desktop
231%{_datadir}/kde4/services/plasma-applet-eyes.desktop
232%{_datadir}/kde4/services/plasma-applet-fifteenPuzzle.desktop
233%{_datadir}/kde4/services/plasma-applet-incomingmsg.desktop
234%{_datadir}/kde4/services/plasma-applet-knowledgebase.desktop
235%{_datadir}/kde4/services/plasma-applet-konqprofiles.desktop
236%{_datadir}/kde4/services/plasma-applet-konsoleprofiles.desktop
237%{_datadir}/kde4/services/plasma-applet-leavenote.desktop
238%{_datadir}/kde4/services/plasma-applet-life.desktop
239%{_datadir}/kde4/services/plasma-applet-luna.desktop
240%{_datadir}/kde4/services/plasma-applet-magnifique.desktop
241%{_datadir}/kde4/services/plasma-applet-mediaplayer.desktop
242%{_datadir}/kde4/services/plasma-applet-microblog.desktop
243%{_datadir}/kde4/services/plasma-applet-news.desktop
244%{_datadir}/kde4/services/plasma-applet-nowplaying.desktop
245%{_datadir}/kde4/services/plasma-applet-opendesktop-activities.desktop
246%{_datadir}/kde4/services/plasma-applet-opendesktop.desktop
247%{_datadir}/kde4/services/plasma-applet-paste.desktop
248%{_datadir}/kde4/services/plasma-applet-pastebin.desktop
249%{_datadir}/kde4/services/plasma-applet-previewer.desktop
250%{_datadir}/kde4/services/plasma-applet-qalculate.desktop
251%{_datadir}/kde4/services/plasma-applet-rememberthemilk.desktop
252%{_datadir}/kde4/services/plasma-applet-rssnow.desktop
253%{_datadir}/kde4/services/plasma-applet-showdashboard.desktop
254%{_datadir}/kde4/services/plasma-applet-showdesktop.desktop
255%{_datadir}/kde4/services/plasma-applet-spellcheck.desktop
256%{_datadir}/kde4/services/plasma-applet-systemloadviewer.desktop
257%{_datadir}/kde4/services/plasma-applet-timer.desktop
258%{_datadir}/kde4/services/plasma-applet-unitconverter.desktop
259%{_datadir}/kde4/services/plasma-applet-weather.desktop
260%{_datadir}/kde4/services/plasma-applet-weatherstation.desktop
261%{_datadir}/kde4/services/plasma-applet-webslice.desktop
262%{_datadir}/kde4/services/plasma-clock-fuzzy.desktop
263%{_datadir}/kde4/services/plasma-comic-default.desktop
264%{_datadir}/kde4/services/plasma-dataengine-comic.desktop
265%{_datadir}/kde4/services/plasma-dataengine-microblog.desktop
266%{_datadir}/kde4/services/plasma-dataengine-ocs.desktop
267%{_datadir}/kde4/services/plasma-dataengine-potd.desktop
268%{_datadir}/kde4/services/plasma-dict-default.desktop
269%{_datadir}/kde4/services/plasma-engine-kdeobservatory.desktop
270%{_datadir}/kde4/services/plasma-engine-pastebin.desktop
271%{_datadir}/kde4/services/plasma-engine-rtm.desktop
272%{_datadir}/kde4/services/plasma-fileWatcher-default.desktop
273%{_datadir}/kde4/services/plasma-frame-default.desktop
274%{_datadir}/kde4/services/plasma-kolourpicker-default.desktop
275%{_datadir}/kde4/services/plasma-notes-default.desktop
276%{_datadir}/kde4/services/plasma-packagestructure-comic.desktop
277%{_datadir}/kde4/services/plasma-runner-audioplayercontrol.desktop
278%{_datadir}/kde4/services/plasma-runner-audioplayercontrol_config.desktop
279%{_datadir}/kde4/services/plasma-runner-contacts.desktop
280%{_datadir}/kde4/services/plasma-runner-converter.desktop
281%{_datadir}/kde4/services/plasma-runner-datetime.desktop
282%{_datadir}/kde4/services/plasma-runner-kopete.desktop
283%{_datadir}/kde4/services/plasma-runner-spellchecker.desktop
284%{_datadir}/kde4/services/plasma-runner-spellchecker_config.desktop
285%{_datadir}/kde4/services/plasma-runner-techbase.desktop
286%{_datadir}/kde4/services/plasma-runner-wikipedia.desktop
287%{_datadir}/kde4/services/plasma-runner-wikitravel.desktop
288%{_datadir}/kde4/services/plasma-wallpaper-mandelbrot.desktop
289%{_datadir}/kde4/services/plasma-wallpaper-marble.desktop
290%{_datadir}/kde4/services/plasma-wallpaper-pattern.desktop
291%{_datadir}/kde4/services/plasma-wallpaper-virus.desktop
292%{_datadir}/kde4/services/plasma-wallpaper-weather.desktop
293%{_datadir}/kde4/services/plasma_applet_plasmaboard.desktop
294%{_datadir}/kde4/services/wcpotdprovider.desktop
1cf65df3 295%{_datadir}/kde4/servicetypes/plasma_comicprovider.desktop
c73f6b0c 296%{_datadir}/kde4/servicetypes/plasma_potdprovider.desktop
28096eda 297%{_datadir}/config/comic.knsrc
32c4451f 298%{_datadir}/config/plasmaweather.knsrc
c73f6b0c 299%{_datadir}/config/virus_wallpaper.knsrc
28096eda 300%dir %{_datadir}/apps/desktoptheme/default/rssnow
301%{_datadir}/apps/desktoptheme/default/rssnow/background.svgz
302%{_datadir}/apps/desktoptheme/default/rssnow/left.svgz
303%{_datadir}/apps/desktoptheme/default/rssnow/right.svgz
304%{_datadir}/apps/desktoptheme/default/rssnow/rssnow.svgz
c73f6b0c 305%dir %{_datadir}/apps/desktoptheme/default/bubblemon
306%{_datadir}/apps/desktoptheme/default/bubblemon/bubble.svg
307%dir %{_datadir}/apps/desktoptheme/default/fifteenPuzzle
32c4451f 308%{_datadir}/apps/desktoptheme/default/fifteenPuzzle/blanksquare.svg
c73f6b0c 309%{_iconsdir}/hicolor/scalable/apps/fifteenpuzzle.svgz
32c4451f 310%{_iconsdir}/hicolor/scalable/apps/accessories-dictionary.svgz
311%{_iconsdir}/hicolor/scalable/apps/bball.svgz
544dba0a 312%{_iconsdir}/hicolor/*x*/apps/qalculate-applet.png
85896f2c 313%{_iconsdir}/hicolor/*x*/apps/plasmaapplet-shelf.png
c73f6b0c 314
28096eda 315%dir %{_datadir}/apps/rssnow
316%{_datadir}/apps/rssnow/feeds
317%{_iconsdir}/*/*x*/apps/previewer.png
28096eda 318%{_datadir}/kde4/services/ServiceMenus/preview.desktop
319%dir %{_datadir}/apps/bball
320%{_datadir}/apps/bball/bball.svgz
32c4451f 321%{_iconsdir}/*/*x*/apps/bball.png
28096eda 322%{_datadir}/apps/bball/bounce.ogg
323%{_datadir}/apps/bball/football.svgz
c73f6b0c 324%{_datadir}/apps/plasma
85896f2c 325%{_datadir}/apps/plasmaboard
c73f6b0c 326%{_datadir}/apps/plasma-applet-opendesktop
32c4451f 327%{_datadir}/apps/plasma-applet-opendesktop-activities
328%{_datadir}/apps/plasma-applet-frame
c73f6b0c 329%{_datadir}/apps/plasma_pastebin
330%{_datadir}/apps/plasma_wallpaper_pattern
28096eda 331
332%files lancelot
333%defattr(644,root,root,755)
334%attr(755,root,root) %{_bindir}/lancelot
335%attr(755,root,root) %ghost %{_libdir}/liblancelot.so.?
336%attr(755,root,root) %{_libdir}/liblancelot.so.*.*.*
05fc8ea2
RT
337%attr(755,root,root) %{_libdir}/liblancelot.so
338%attr(755,root,root) %{_libdir}/liblancelot-datamodels.so.?
339%attr(755,root,root) %{_libdir}/liblancelot-datamodels.so.*.*.*
340%attr(755,root,root) %{_libdir}/kde4/plasma_applet_lancelot_launcher.so
341%attr(755,root,root) %{_libdir}/kde4/plasma_applet_lancelot_part.so
28096eda 342%{_datadir}/apps/desktoptheme/default/lancelot
32c4451f 343%{_datadir}/apps/desktoptheme/oxygen/lancelot
05fc8ea2
RT
344%{_datadir}/kde4/services/plasma-applet-lancelot-launcher.desktop
345%{_datadir}/kde4/services/plasma-applet-lancelot-part.desktop
28096eda 346%{_datadir}/dbus-1/services/org.kde.lancelot.service
347%{_datadir}/mime/packages/lancelotpart-mime.xml
c73f6b0c 348%{_datadir}/apps/lancelot
28096eda 349%{_iconsdir}/hicolor/*x*/apps/lancelot.png
85896f2c 350%{_iconsdir}/hicolor/*x*/apps/lancelot-start.png
c73f6b0c 351
352%files devel
353%defattr(644,root,root,755)
354%attr(755,root,root) %{_libdir}/*.so
05fc8ea2
RT
355%{_includedir}/KDE/Lancelot
356%{_includedir}/lancelot-datamodels
c73f6b0c 357%{_includedir}/lancelot
40f03c32 358%{_datadir}/apps/cmake/modules/*.cmake
This page took 0.499826 seconds and 4 git commands to generate.