]> git.pld-linux.org Git - packages/kde4-kdeplasma-addons.git/blame - kde4-kdeplasma-addons.spec
- 4.3.1
[packages/kde4-kdeplasma-addons.git] / kde4-kdeplasma-addons.spec
CommitLineData
c73f6b0c 1
2%bcond_without marble # don't build marble plasma support
3
1cf65df3 4%define orgname kdeplasma-addons
57887d81 5%define _state stable
c73f6b0c 6%define _qtver 4.5.2
1cf65df3 7
8Summary: KDE4 Plasmoids
b4bc4746 9Summary(pl.UTF-8): Plazmoidy dla KDE4
1cf65df3 10Name: kde4-kdeplasma-addons
508bd1fc 11Version: 4.3.1
12Release: 1
1cf65df3 13License: GPL v2
14Group: X11/Applications
15Source0: ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
508bd1fc 16# Source0-md5: 282473836da35a48a6c6bee0b6fa6666
c73f6b0c 17#Source0: ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
9baaa66a 18Patch100: %{name}-branch.diff
28096eda 19Patch0: %{name}-pastebinpld.patch
7ab2d436 20URL: http://www.kde.org/
22957f69 21BuildRequires: OpenGL-GLU-devel
ae48935e 22BuildRequires: OpenGL-devel
1cf65df3 23BuildRequires: QtCore-devel >= %{_qtver}
75f86cc0 24BuildRequires: QtNetwork-devel >= %{_qtver}
ae48935e 25BuildRequires: QtOpenGL-devel >= %{_qtver}
28096eda 26BuildRequires: QtScript-devel >= %{_qtver}
75f86cc0 27BuildRequires: QtSvg-devel >= %{_qtver}
28096eda 28BuildRequires: QtWebKit-devel >= %{_qtver}
29BuildRequires: automoc4 >= 0.9.88
bad3bd06 30BuildRequires: cmake >= 2.6.3
c73f6b0c 31BuildRequires: eigen-devel >= 2.0.51
1cf65df3 32BuildRequires: kde4-kdebase-workspace-devel >= %{version}
c73f6b0c 33BuildRequires: kde4-kdegraphics-devel >= %{version}
1cf65df3 34BuildRequires: kde4-kdelibs-devel >= %{version}
35BuildRequires: kde4-kdepimlibs-devel >= %{version}
c73f6b0c 36%{?with_marble:BuildRequires: kde4-kdeedu-devel >= %{version}}
f1ec62d6 37BuildRequires: phonon-devel >= 4.3.1
1cf65df3 38BuildRequires: qt4-build >= %{_qtver}
39BuildRequires: qt4-qmake >= %{_qtver}
40BuildRequires: rpmbuild(macros) >= 1.293
c73f6b0c 41BuildRequires: strigi-devel >= 0.6.5
42BuildRequires: xorg-lib-libXcomposite
43BuildRequires: xorg-lib-libXdamage
44BuildRequires: xorg-lib-libXrender
75f86cc0 45BuildRequires: xorg-lib-libXtst-devel
1cf65df3 46Obsoletes: kde4-kdeplasmoids
47BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49%description
b4bc4746 50KDE4 plasmoids.
1cf65df3 51
52%description -l pl.UTF-8
b4bc4746 53Plazmoidy dla KDE4.
1cf65df3 54
28096eda 55%package lancelot
56Summary: Lancelot Desktop Theme
72db3ff2 57Summary(pl.UTF-8): Motyw pulpitu Lancelot
28096eda 58Group: X11/Applications
59Requires: kde4-kdebase-workspace >= %{version}
60
61%description lancelot
62Lancelot Desktop Theme.
63
64%description lancelot -l pl.UTF-8
72db3ff2 65Motyw pulpitu Lancelot.
28096eda 66
c73f6b0c 67%package devel
68Summary: Development files for KDE4 Plasmoids
69Summary(pl.UTF-8): Pliki nagłówkowe bibliotek plazmoidów dla KDE4
70Group: X11/Development/Libraries
71Requires: %{name} = %{version}-%{release}
0e26ec14 72Requires: kde4-kdebase-workspace-devel >= %{version}
73Requires: kde4-kdegraphics-devel >= %{version}
74Requires: kde4-kdelibs-devel >= %{version}
75Requires: kde4-kdepimlibs-devel >= %{version}
c73f6b0c 76
77%description devel
78This package contains header files needed if you wish to build
79applications based on KDE4 Plasmoids.
80
81%description devel -l pl.UTF-8
82Pakiet ten zawiera pliki nagłówkowe potrzebne do budowy aplikacji
83opartych na plazmoidach dla KDE4.
84
1cf65df3 85%prep
86%setup -q -n %{orgname}-%{version}
508bd1fc 87#%patch100 -p0
28096eda 88%patch0 -p1
1cf65df3 89
90%build
91install -d build
92cd build
93%cmake \
94 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
c73f6b0c 95 -DLIB_INSTALL_DIR=%{_libdir} \
07563c11 96 -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
1cf65df3 97%if "%{_lib}" != "lib"
98 -DLIB_SUFFIX=64 \
99%endif
100 ../
101
102%{__make}
103
104%install
105rm -rf $RPM_BUILD_ROOT
106
107%{__make} -C build install \
108 DESTDIR=$RPM_BUILD_ROOT
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114%postun -p /sbin/ldconfig
115
28096eda 116%post lancelot -p /sbin/ldconfig
117%postun lancelot -p /sbin/ldconfig
118
1cf65df3 119%files
120%defattr(644,root,root,755)
121%attr(755,root,root) %{_libdir}/kde4/krunner_*.so
28096eda 122%attr(755,root,root) %{_libdir}/kde4/kcm_krunner_*.so
1cf65df3 123%attr(755,root,root) %{_libdir}/kde4/plasma_applet_*.so
124%attr(755,root,root) %{_libdir}/kde4/plasma_comic_*.so
125%attr(755,root,root) %{_libdir}/kde4/plasma_engine_*.so
28096eda 126%attr(755,root,root) %{_libdir}/kde4/plasma_packagestructure_comic.so
1cf65df3 127%attr(755,root,root) %ghost %{_libdir}/libplasmacomicprovidercore.so.?
128%attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so.*.*.*
c73f6b0c 129%attr(755,root,root) %{_libdir}/kde4/plasma-applet_systemloadviewer.so
130%attr(755,root,root) %{_libdir}/kde4/plasma_potd_apodprovider.so
131%attr(755,root,root) %{_libdir}/kde4/plasma_potd_epodprovider.so
132%attr(755,root,root) %{_libdir}/kde4/plasma_potd_flickrprovider.so
133%attr(755,root,root) %{_libdir}/kde4/plasma_potd_oseiprovider.so
134%attr(755,root,root) %{_libdir}/kde4/plasma_potd_wcpotdprovider.so
135%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_mandelbrot.so
136%if %{with marble}
137%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_marble.so
138%endif
139%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_pattern.so
140%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_virus.so
141%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_weather.so
142%attr(755,root,root) %ghost %{_libdir}/libconversion.so.?
143%attr(755,root,root) %{_libdir}/libconversion.so.*.*.*
144%attr(755,root,root) %{_libdir}/liblancelot.so
145%attr(755,root,root) %ghost %{_libdir}/libocsclient.so.?
146%attr(755,root,root) %{_libdir}/libocsclient.so.*.*.*
147%attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so
148%attr(755,root,root) %ghost %{_libdir}/libplasmapotdprovidercore.so.?
149%attr(755,root,root) %{_libdir}/libplasmapotdprovidercore.so.*.*.*
150%attr(755,root,root) %ghost %{_libdir}/libplasmaweather.so.?
151%attr(755,root,root) %{_libdir}/libplasmaweather.so.*.*.*
152%attr(755,root,root) %ghost %{_libdir}/librtm.so.?
153%attr(755,root,root) %{_libdir}/librtm.so.*.*.*
1cf65df3 154%{_datadir}/apps/desktoptheme/Aya
155%{_datadir}/apps/desktoptheme/Elegance
156%{_datadir}/apps/desktoptheme/Silicon
28096eda 157%dir %{_datadir}/apps/desktoptheme/default/stylesheets
158%{_datadir}/apps/desktoptheme/default/stylesheets/*
159%dir %{_datadir}/apps/desktoptheme/default/weatherstation
160%{_datadir}/apps/desktoptheme/default/weatherstation/*
c73f6b0c 161%dir %{_datadir}/apps/desktoptheme/default/weather/
162%{_datadir}/apps/desktoptheme/default/weather/wind-arrows.svgz
1cf65df3 163%{_datadir}/apps/desktoptheme/default/widgets/*
164%{_datadir}/apps/desktoptheme/heron
165%{_datadir}/apps/desktoptheme/slim-glow
1cf65df3 166%{_datadir}/kde4/services/*.desktop
167%{_datadir}/kde4/servicetypes/plasma_comicprovider.desktop
c73f6b0c 168%{_datadir}/kde4/servicetypes/plasma_potdprovider.desktop
28096eda 169%{_datadir}/config/comic.knsrc
c73f6b0c 170%{_datadir}/config/virus_wallpaper.knsrc
28096eda 171%dir %{_datadir}/apps/desktoptheme/default/rssnow
172%{_datadir}/apps/desktoptheme/default/rssnow/background.svgz
173%{_datadir}/apps/desktoptheme/default/rssnow/left.svgz
174%{_datadir}/apps/desktoptheme/default/rssnow/right.svgz
175%{_datadir}/apps/desktoptheme/default/rssnow/rssnow.svgz
c73f6b0c 176%dir %{_datadir}/apps/desktoptheme/default/bubblemon
177%{_datadir}/apps/desktoptheme/default/bubblemon/bubble.svg
178%dir %{_datadir}/apps/desktoptheme/default/fifteenPuzzle
179%{_datadir}/apps/desktoptheme/default/fifteenPuzzle/greensquare.svgz
180%{_iconsdir}/hicolor/scalable/apps/fifteenpuzzle.svgz
181
28096eda 182%dir %{_datadir}/apps/rssnow
183%{_datadir}/apps/rssnow/feeds
184%{_iconsdir}/*/*x*/apps/previewer.png
28096eda 185%{_datadir}/kde4/services/ServiceMenus/preview.desktop
186%dir %{_datadir}/apps/bball
187%{_datadir}/apps/bball/bball.svgz
188%{_datadir}/apps/bball/bounce.ogg
189%{_datadir}/apps/bball/football.svgz
c73f6b0c 190#%{_datadir}/apps/plasma-bluemarble
191%{_datadir}/apps/plasma
192%{_datadir}/apps/plasma-applet-opendesktop
193%{_datadir}/apps/plasma_pastebin
194%{_datadir}/apps/plasma_wallpaper_pattern
28096eda 195
196%files lancelot
197%defattr(644,root,root,755)
198%attr(755,root,root) %{_bindir}/lancelot
199%attr(755,root,root) %ghost %{_libdir}/liblancelot.so.?
200%attr(755,root,root) %{_libdir}/liblancelot.so.*.*.*
201%{_datadir}/apps/desktoptheme/default/lancelot
c73f6b0c 202#%{_datadir}/apps/desktoptheme/air/
203
28096eda 204%{_datadir}/dbus-1/services/org.kde.lancelot.service
205%{_datadir}/mime/packages/lancelotpart-mime.xml
c73f6b0c 206%{_datadir}/apps/lancelot
28096eda 207%{_iconsdir}/hicolor/*x*/apps/lancelot.png
208%{_iconsdir}/hicolor/*x*/apps/lancelot-part.png
c73f6b0c 209
210%files devel
211%defattr(644,root,root,755)
212%attr(755,root,root) %{_libdir}/*.so
213%{_includedir}/conversion
214%{_includedir}/lancelot
215%{_datadir}/apps/cmake/modules/*.cmake
This page took 0.29387 seconds and 4 git commands to generate.